Bug 359627 - choose order in which krunner displays results of different kinds
Summary: choose order in which krunner displays results of different kinds
Status: RESOLVED DUPLICATE of bug 340283
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: 5.4.3
Platform: Other Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Kai Uwe Broulik
URL:
Keywords: usability
: 399834 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-21 10:34 UTC by Martin Steigerwald
Modified: 2020-06-30 17:34 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
krunner places last used document and image files before binaries (28.25 KB, image/png)
2016-02-21 10:42 UTC, Martin Steigerwald
Details
Third suggestion in list is by far the most frequently opened (almost always opened via Krunner itself) (89.27 KB, image/png)
2019-06-08 14:41 UTC, S
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Steigerwald 2016-02-21 10:34:52 UTC
Often I press Alt-F2, enter the name of a binary and then hit enter. But instead of the binary it views an image with a similar name. I´d like to specify the order in which krunner displays results of different kinds, for example binaries / programs first, as this is my number one use case for krunner.

Reproducible: Always

Steps to Reproduce:
1. Have a png file called "systemsettings-baumansicht.png" that Baloo indexed
2. Press Alt-F2 and type "systemsettings"

Actual Results:  
"systemsettings-baumansicht.png" displayed as first result.

Expected Results:  
I want to start systemsettings instead.

It does not seem to learn by preference. Even when I Alt-F2, type "systemsettings" and select the binary for more than 5 times it still displays the image first. Also it displays last opened document before the binary.

I want the binary first as this is my >90% use case.

Alternatively have it learn my preference. So when usually choose the binary instead of the image, learn it.
Comment 1 Martin Steigerwald 2016-02-21 10:42:01 UTC
Created attachment 97329 [details]
krunner places last used document and image files before binaries

I first step could be, to be able to drag and drop order the seach modules in the configuration dialog.
Comment 2 Martin Steigerwald 2017-05-04 08:20:45 UTC
Another example of this:

- I type the name of a directory like "~/Marketing"
- … and it still displays a lot of documents containing the word "Marketing", despite me indicating that this is a path.

I thought about reported this separately, but one could want to see documents that contains the path name "~/Marketing" and it appears that Baloo tokenizes this to "Marketing" without preceeding "~/". So the more generic solution to this is to allow the user to specify the order to search results.

I want to say krunner:

1. executable / app names
2. path and filenames *first*
3. then everything else

*always*.

One way to allow that would be to allow to drag and drop sort the plugins to the desired order in the krunner settings dialog.
Comment 3 Nate Graham 2018-10-17 15:01:16 UTC
*** Bug 399834 has been marked as a duplicate of this bug. ***
Comment 4 S 2018-10-17 15:13:26 UTC
(In reply to Nate Graham)
> 
> What macOS does in this case is allows the plugins/search results to be
> sorted via their System Settings KCM equivalent. So you can put Apps always
> on top if there is an app result and a System Settings result. We should
> probably do the same here.

Sounds good to me. Thanks for taking this into account.
Comment 5 Martin Steigerwald 2019-06-05 09:10:40 UTC
I just came upon this again as I entered the name of a location in Dolphin and it opened a Kate session with the same name. For me the frequency of accessing locations in Dolphin is much higher than accessing Kate sessions, so… I'd like to locations in Dolphins come before Kate sessions.
Comment 6 S 2019-06-08 14:41:33 UTC
Created attachment 120696 [details]
Third suggestion in list is by far the most frequently opened (almost always opened via Krunner itself)

I'm not sure if this belongs here or if I should open a new request.

I just realized that Krunner does not appear to count the number of times a file has been opened via Krunner, and the most frequently opened files are not suggested first. I thought it used to do so?

In this screenshot, I have a very frequently accessed PDF document whose filename ends in "-standard.pdf". Krunner remembers and autocompletes my search for "standard" when I start typing "st......" However, the PDF I want is always in the third position on the list. I don't think I've ever even opened the first two suggestions on the list.
Comment 7 Jeffrey Bouter 2020-06-30 09:32:04 UTC
This "bug" (or rather, feature request) is still present in today's plasma. I too would like to be able to select the order in which krunner finds results. For example, if I type 'shutdown' I want the desktop session to be the first result. Not open 'shutdown.svg' or have krunner execute the 'shutdown' cli-command (which will result in a "computer will shut down in 60 seconds" pop-up).
Comment 8 Alexander Lohnau 2020-06-30 17:34:14 UTC

*** This bug has been marked as a duplicate of bug 340283 ***