Bug 359607 - Kmail crashes after I changed (moved) the mail folders (in this case the local-mail)
Summary: Kmail crashes after I changed (moved) the mail folders (in this case the loca...
Status: RESOLVED DUPLICATE of bug 362339
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-02-20 17:37 UTC by Eric
Modified: 2017-01-10 00:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric 2016-02-20 17:37:05 UTC
Application: kontact (4.14.10)
KDE Platform Version: 4.14.17 (Compiled from sources)
Qt Version: 4.8.6
Operating System: Linux 4.1.15-8-default x86_64
Distribution: "openSUSE Leap 42.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I renamed the symlink that link to the local-folder on a different partition
I renamed it wrong,
Opening Kontact got me an error message (can't fetch information)
I changed/corrected my error

- Custom settings of the application:
all /.local; /.kde4; /.config; are symlink to the separat "emails" partition on a differnent drive

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9a0f701800 (LWP 2236))]

Thread 5 (Thread 0x7f99f2ab8700 (LWP 2237)):
#0  0x00007f9a06c5b03f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9a0bde1eb6 in WTF::TCMalloc_PageHeap::scavengerThread() () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f9a0bde1ee9 in WTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f9a06c570a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f9a0cbd1fed in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f99b21b5700 (LWP 2238)):
#0  0x00007f9a06c5b03f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9a0bb54b3d in JSC::BlockAllocator::blockFreeingThreadMain() () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f9a0be09a06 in WTF::wtfThreadEntryPoint(void*) () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f9a06c570a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f9a0cbd1fed in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f99a307b700 (LWP 2243)):
#0  0x00007f9a0668a017 in g_main_context_release () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f9a0668ae0e in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9a0668af7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9a0d3c6fde in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f9a0d398d4f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f9a0d399045 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f9a0d2964df in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007f9a0d298bbf in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007f9a06c570a4 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f9a0cbd1fed in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f999b7fe700 (LWP 2272)):
#0  0x00007f9a06c5b03f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f99a9eb886b in ?? () from /usr/lib64/libQtScript.so.4
#2  0x00007f99a9eb88a9 in ?? () from /usr/lib64/libQtScript.so.4
#3  0x00007f9a06c570a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f9a0cbd1fed in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f9a0f701800 (LWP 2236)):
[KCrash Handler]
#6  0x00007f9a0cb220a7 in raise () from /lib64/libc.so.6
#7  0x00007f9a0cb23458 in abort () from /lib64/libc.so.6
#8  0x00007f9a0d28e6d4 in qt_message_output(QtMsgType, char const*) () from /usr/lib64/libQtCore.so.4
#9  0x00007f9a0d28e859 in ?? () from /usr/lib64/libQtCore.so.4
#10 0x00007f9a0d28f064 in qFatal(char const*, ...) () from /usr/lib64/libQtCore.so.4
#11 0x00007f99a824bd84 in MailCommon::Kernel::self() () from /usr/lib64/libmailcommon.so.4
#12 0x00007f99a8293fd0 in MailCommon::FolderCollection::writeConfig() const () from /usr/lib64/libmailcommon.so.4
#13 0x00007f99a82947d2 in MailCommon::FolderCollection::~FolderCollection() () from /usr/lib64/libmailcommon.so.4
#14 0x00007f99a8294849 in MailCommon::FolderCollection::~FolderCollection() () from /usr/lib64/libmailcommon.so.4
#15 0x00007f99a8293104 in ?? () from /usr/lib64/libmailcommon.so.4
#16 0x00007f9a0cb24b19 in __run_exit_handlers () from /lib64/libc.so.6
#17 0x00007f9a0cb24b65 in exit () from /lib64/libc.so.6
#18 0x00007f99a824c457 in MailCommon::Kernel::emergencyExit(QString const&) () from /usr/lib64/libmailcommon.so.4
#19 0x00007f99a824ca17 in MailCommon::Kernel::createDefaultCollectionDone(KJob*) () from /usr/lib64/libmailcommon.so.4
#20 0x00007f9a0d3ae0fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#21 0x00007f9a0d82e132 in KJob::result (this=this@entry=0x9945e0, _t1=_t1@entry=0x9945e0) at /usr/src/debug/kdelibs-4.14.17/build/kdecore/kjob.moc:207
#22 0x00007f9a0d82e170 in KJob::emitResult (this=0x9945e0) at /usr/src/debug/kdelibs-4.14.17/kdecore/jobs/kjob.cpp:318
#23 0x00007f9a08ca777a in Akonadi::TransactionSequence::slotResult(KJob*) () from /usr/lib64/libakonadi-kde.so.4
#24 0x00007f9a08c836de in Akonadi::SpecialCollectionsRequestJob::slotResult(KJob*) () from /usr/lib64/libakonadi-kde.so.4
#25 0x00007f9a08ca6fe0 in ?? () from /usr/lib64/libakonadi-kde.so.4
#26 0x00007f9a0d3ae0fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#27 0x00007f9a0d82e132 in KJob::result (this=this@entry=0x25f9eb0, _t1=_t1@entry=0x25f9eb0) at /usr/src/debug/kdelibs-4.14.17/build/kdecore/kjob.moc:207
#28 0x00007f9a0d82e170 in KJob::emitResult (this=0x25f9eb0) at /usr/src/debug/kdelibs-4.14.17/kdecore/jobs/kjob.cpp:318
#29 0x00007f9a08c7d56a in ?? () from /usr/lib64/libakonadi-kde.so.4
#30 0x00007f9a0d3ae0fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#31 0x00007f9a0d82e132 in KJob::result (this=this@entry=0xdcb360, _t1=_t1@entry=0xdcb360) at /usr/src/debug/kdelibs-4.14.17/build/kdecore/kjob.moc:207
#32 0x00007f9a0d82e170 in KJob::emitResult (this=0xdcb360) at /usr/src/debug/kdelibs-4.14.17/kdecore/jobs/kjob.cpp:318
#33 0x00007f9a0d3b249e in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#34 0x00007f9a0dda479c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#35 0x00007f9a0ddaacdd in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#36 0x00007f9a0eabbe1a in KApplication::notify (this=0x7ffcd1459210, receiver=0xdcb360, event=0x2701360) at /usr/src/debug/kdelibs-4.14.17/kdeui/kernel/kapplication.cpp:311
#37 0x00007f9a0d39a18d in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#38 0x00007f9a0d39d45d in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#39 0x00007f9a0d3c77fe in ?? () from /usr/lib64/libQtCore.so.4
#40 0x00007f9a0668ac84 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#41 0x00007f9a0668aed8 in ?? () from /usr/lib64/libglib-2.0.so.0
#42 0x00007f9a0668af7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#43 0x00007f9a0d3c6fbe in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#44 0x00007f9a0de416a6 in ?? () from /usr/lib64/libQtGui.so.4
#45 0x00007f9a0d398d4f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#46 0x00007f9a0d399045 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#47 0x00007f9a0d39e499 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#48 0x00000000004037f2 in ?? ()
#49 0x00007f9a0cb0eb05 in __libc_start_main () from /lib64/libc.so.6
#50 0x0000000000403c97 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 359461.

Possible duplicates by query: bug 359461, bug 358650, bug 357924, bug 352801, bug 351686.

Reported using DrKonqi
Comment 1 Christoph Feck 2017-01-10 00:57:07 UTC

*** This bug has been marked as a duplicate of bug 362339 ***