Bug 35926 - should not select following message when deleting
Summary: should not select following message when deleting
Status: RESOLVED INTENTIONAL
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Other
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2001-12-08 13:18 UTC by Daniel Stone
Modified: 2007-09-14 12:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Stone 2001-12-08 13:15:53 UTC
(*** This bug was imported into bugs.kde.org ***)

Package: kmail

------
This bug is forwarded from the Debian BTS as it was filed on
a Debian package.
The original bug report can be seen at http://bugs.debian.org/116824.
As far as I know it is not a duplicate of any existing bug.
If it is I will pick this up and merge within the next 12 hours;
Otherwise please merge yourself.
Thankyou Daniel Stone <daniel@sfarc.net> the "other"
Debian KDE maintainer.
------

kmail should not select the next available message when deleting something. 
The reason is that the following message is thereby marked as read even 
though one just intended to delete some uninteresting messages. 
 Of course that way you can't go through your mails deleting them one by one.
Maybe one keybinding to 'delete currently selected messages' and one to 
'delete currently selected messages and select next' would make everybody 
happy ?

Greetings
Uli
Comment 1 niek 2004-04-07 11:09:59 UTC
This bug is also apparent when selecting multiple messages and deleting them: When I select a connected or nonconnected set of messages and I delete them, then after deletion a number of different messages are still selected. This number may be lower than the original amount of selected messages though.

Still, I strongly feel that this behaviour is underisable (If I click delete twice, I've deleted a (to me) unknown amount of messages.

This goes for kmail 3.1.5
Comment 2 Till Adam 2004-04-07 12:05:12 UTC
@Uli: The mark as read thingie is configurable, and selecting the next message is what people expect, so I'll close this as WONTFIX since we won't change the current behavior.

@Niek: What you describe has been fixed in KMail 1.6. It no longer selects more than one message after operations on multiple messages.