Bug 359240 - KSysguard segfaults after sorting columns multiple times and then exiting
Summary: KSysguard segfaults after sorting columns multiple times and then exiting
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.5.4
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-02-10 16:44 UTC by Mike
Modified: 2018-02-16 22:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike 2016-02-10 16:44:12 UTC
Application: ksysguard (5.5.4)

Qt Version: 5.5.1
Operating System: Linux 4.4.0-3-default x86_64
Distribution: "openSUSE Tumbleweed (20160117) (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Run Ksysguard, added a column to the view (PID)
Then, sorted by PID, then by user a few times, and then by name a few times
Then, exited by choosing the "X"

The crash can be reproduced sometimes.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4659c8a940 (LWP 3214))]

Thread 2 (Thread 0x7f463056a700 (LWP 3217)):
#0  0x00007f464d4c107f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f4637008ef3 in  () at /usr/lib64/dri/r600_dri.so
#2  0x00007f4637008737 in  () at /usr/lib64/dri/r600_dri.so
#3  0x00007f464d4bb4a4 in start_thread () at /lib64/libpthread.so.0
#4  0x00007f465958ebdd in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7f4659c8a940 (LWP 3214)):
[KCrash Handler]
#6  0x00007f4658b7cb4e in KSGRD::SensorAgent::processAnswer(char const*, int) () at /usr/lib64/libksgrd.so.7
#7  0x00007f4658b84ab0 in  () at /usr/lib64/libksgrd.so.7
#8  0x00007f4654c5be17 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib64/libQt5Core.so.5
#9  0x00007f4654b6c19a in  () at /usr/lib64/libQt5Core.so.5
#10 0x00007f4654b6c5e0 in  () at /usr/lib64/libQt5Core.so.5
#11 0x00007f4654c5bf8a in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib64/libQt5Core.so.5
#12 0x00007f4654cd739e in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) () at /usr/lib64/libQt5Core.so.5
#13 0x00007f4654c67d0b in QSocketNotifier::event(QEvent*) () at /usr/lib64/libQt5Core.so.5
#14 0x00007f46559128cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#15 0x00007f46559179d6 in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#16 0x00007f4654c2ecf3 in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
#17 0x00007f4654c829bd in  () at /usr/lib64/libQt5Core.so.5
#18 0x00007f464cb37097 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#19 0x00007f464cb372c8 in  () at /usr/lib64/libglib-2.0.so.0
#20 0x00007f464cb3736c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#21 0x00007f4654c8250f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#22 0x00007f4654c2c63a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#23 0x00007f4654c342fd in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
#24 0x00007f46598c1616 in kdemain () at /usr/lib64/libkdeinit5_ksysguard.so
#25 0x00007f46594c5610 in __libc_start_main () at /lib64/libc.so.6
#26 0x00000000004007f9 in _start ()

Reported using DrKonqi
Comment 1 Aleix Pol 2016-02-13 02:08:53 UTC
Can you provide the backtrace with debug symbols?
Comment 2 Mike 2016-02-13 15:09:45 UTC
I'll try, I have the debug symbols installed.  It hasn't happened again since the report and I can't repo it so far.....
Comment 3 Christoph Feck 2018-02-16 22:48:32 UTC

*** This bug has been marked as a duplicate of bug 350140 ***