Bug 35918 - wishlist for KPackage: rightclick selection of install/remove operations
Summary: wishlist for KPackage: rightclick selection of install/remove operations
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kpackage
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Other
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Toivo Pedaste
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2001-12-08 13:18 UTC by Daniel Stone
Modified: 2009-12-20 13:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Stone 2001-12-08 13:15:27 UTC
(*** This bug was imported into bugs.kde.org ***)

Package: kpackage
Severity: wishlist

------
This bug is forwarded from the Debian BTS as it was filed on
a Debian package.
The original bug report can be seen at http://bugs.debian.org/102462.
As far as I know it is not a duplicate of any existing bug.
If it is I will pick this up and merge within the next 12 hours;
Otherwise please merge yourself.
Thankyou Daniel Stone <daniel@sfarc.net> the "other"
Debian KDE maintainer.
------

Currently in order to install or remove a package it is necessary to select 
a line in one of the package display trees and then mouse down and press the 
Install Marked or Uninstall Marked button. As a shortcut for single-package 
operations it would be nice if one could right-click on a line and have a 
popup menu appear with the Install and Uninstall options.

I'm using a Debian potato 2.2 system upgraded with kernel 2.4.4 and libc6 
2.2.2-4 KDE 2.1.1 with kdelibs3 2.1.2.

(Thanks for a very good application!)

- Don
Comment 1 Toivo Pedaste 2006-04-27 11:08:46 UTC
That's a good idea, I'll look into doing it.
Comment 2 Dario Andres 2009-12-20 13:57:45 UTC
KPackage was recently removed from KDE SC (since 4.4 beta2) as it was completely broken and unmaintained.

Most of the common GNU/Linux distributions offer their own tools to deal with packages, and KDE is working on an universal package manager replacement named "Shaman" (to superseed KPackageKit)

Closing the KPackage's bug reports as UNMAINTAINED.

Regards