Bug 359138 - KMail doesn't set "In-Reply-To" and "References" headers when forwarding
Summary: KMail doesn't set "In-Reply-To" and "References" headers when forwarding
Status: REPORTED
Alias: None
Product: kmail2
Classification: Applications
Component: composer (show other bugs)
Version: 4.14.7
Platform: OpenSUSE Linux
: NOR normal with 67 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-08 15:44 UTC by kolAflash
Modified: 2022-11-21 08:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kolAflash 2016-02-08 15:44:52 UTC
KMail version 4.14.9

When forwarding a message, KMail doesn't set the "In-Reply-To" and the "References" headers.

Could anyone check this for the current KMail version? (4.15.x)

One workaround would be, to specify custom headers in the forward template. But this would require this bug to be solved first.
https://bugs.kde.org/show_bug.cgi?id=148407

Then you could do something like:
References: %OHEADER="References" %OHEADER="Message-ID"
In-Reply-To: %OHEADER="Message-ID"

Reproducible: Always
Comment 1 kolAflash 2016-02-11 11:48:59 UTC
Looks like Thunderbird is also setting this reasonable additional header when forwarding.
X-Forwarded-Message-Id: ...

So a header-template could look like this:
References: %OHEADER="References" %OHEADER="Message-ID"
In-Reply-To: %OHEADER="Message-ID"
X-Forwarded-Message-Id: %OHEADER="Message-ID"
Comment 2 Justin Zobel 2022-11-06 09:25:08 UTC
Thank you for reporting this issue in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the issue with a recent software version?

If you can reproduce the issue, please change the status to "REPORTED" when replying. Thank you!
Comment 3 Bug Janitor Service 2022-11-21 05:12:17 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Amand Tihon 2022-11-21 08:01:12 UTC
I don't know if the original reporter of this bug is still around, but I can confirm the issue is still present in KMail 5.21.3.

None of the References:, In-Reply-To: or X-Forwarded-Message-Id: headers are set when forwarding a message.
It makes no difference if the message is forwarded inline or as an attachment.