Bug 358970 - SYstem Monitor Crashed
Summary: SYstem Monitor Crashed
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.5.4
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-02-04 02:26 UTC by smoyse
Modified: 2022-09-04 10:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
ksysguard-20160329-115338.kcrash.txt (4.21 KB, text/plain)
2016-03-29 10:03 UTC, .
Details

Note You need to log in before you can comment on or make changes to this bug.
Description smoyse 2016-02-04 02:26:06 UTC
Application: ksysguard (5.5.4)

Qt Version: 5.5.1
Operating System: Linux 4.3.3-303.fc23.x86_64 x86_64
Distribution: "Fedora release 23 (Twenty Three)"

-- Information about the crash:
I opened the system monitor window from the desktop widget.
I closed the system monitor window by clicking the close window control.
The crash happened

The crash can be reproduced sometimes.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f86e12dc940 (LWP 4461))]

Thread 2 (Thread 0x7f86b9847700 (LWP 4463)):
#0  0x00007f86d8af1fdd in poll () at /lib64/libc.so.6
#1  0x00007f86d2ad0272 in _xcb_conn_wait () at /lib64/libxcb.so.1
#2  0x00007f86d2ad1ee7 in xcb_wait_for_event () at /lib64/libxcb.so.1
#3  0x00007f86bc7f8da9 in QXcbEventReader::run() () at /lib64/libQt5XcbQpa.so.5
#4  0x00007f86d96fa3de in QThreadPrivate::start(void*) () at /lib64/libQt5Core.so.5
#5  0x00007f86d365b60a in start_thread () at /lib64/libpthread.so.0
#6  0x00007f86d8afda4d in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7f86e12dc940 (LWP 4461)):
[KCrash Handler]
#5  0x0000000000000000 in  ()
#6  0x00007f86da705a7f in QLabelPrivate::clearContents() () at /lib64/libQt5Widgets.so.5
#7  0x00007f86da7065cc in QLabel::setText(QString const&) () at /lib64/libQt5Widgets.so.5
#8  0x00007f86e0facd59 in TopLevel::answerReceived(int, QList<QByteArray> const&) () at /lib64/libkdeinit5_ksysguard.so
#9  0x00007f86e05ec544 in KSGRD::SensorAgent::processAnswer(char const*, int) () at /lib64/libksgrd.so.7
#10 0x00007f86e05f5090 in KSGRD::SensorShellAgent::msgRcvd() () at /lib64/libksgrd.so.7
#11 0x00007f86d990a127 in QMetaObject::activate(QObject*, int, int, void**) () at /lib64/libQt5Core.so.5
#12 0x00007f86d98111f2 in QProcessPrivate::tryReadFromChannel(QProcessPrivate::Channel*) () at /lib64/libQt5Core.so.5
#13 0x00007f86d9811670 in QProcess::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () at /lib64/libQt5Core.so.5
#14 0x00007f86d990a29a in QMetaObject::activate(QObject*, int, int, void**) () at /lib64/libQt5Core.so.5
#15 0x00007f86d9989eae in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) () at /lib64/libQt5Core.so.5
#16 0x00007f86d991674b in QSocketNotifier::event(QEvent*) () at /lib64/libQt5Core.so.5
#17 0x00007f86da5c041c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#18 0x00007f86da5c58e6 in QApplication::notify(QObject*, QEvent*) () at /lib64/libQt5Widgets.so.5
#19 0x00007f86d98db73b in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /lib64/libQt5Core.so.5
#20 0x00007f86d993237d in socketNotifierSourceDispatch(_GSource*, int (*)(void*), void*) () at /lib64/libQt5Core.so.5
#21 0x00007f86d1444e3a in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#22 0x00007f86d14451d0 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#23 0x00007f86d144527c in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#24 0x00007f86d9931eaf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#25 0x00007f86d98d8eca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQt5Core.so.5
#26 0x00007f86d98e0fac in QCoreApplication::exec() () at /lib64/libQt5Core.so.5
#27 0x00007f86e0fae869 in kdemain () at /lib64/libkdeinit5_ksysguard.so
#28 0x00007f86d8a1b580 in __libc_start_main () at /lib64/libc.so.6
#29 0x000055cdac641bf9 in _start ()

Reported using DrKonqi
Comment 1 Aleix Pol 2016-02-05 01:55:01 UTC
Could you try to provide a backtrace with debug symbols? It would simplify solving the issue.
Comment 2 . 2016-03-29 10:03:35 UTC
Created attachment 98136 [details]
ksysguard-20160329-115338.kcrash.txt

KDE Frameworks 5.20.0
Qt 5.5.1 (built against 5.5.1)
The xcb windowing system
Comment 3 Christoph Feck 2018-02-16 22:48:12 UTC

*** This bug has been marked as a duplicate of bug 350140 ***