Bug 358859 - Screen not always locked when lid closed
Summary: Screen not always locked when lid closed
Status: RESOLVED DUPLICATE of bug 78871
Alias: None
Product: kscreenlocker
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR major
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-01 09:42 UTC by Olivier Churlaud
Modified: 2016-02-01 10:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
dump of the interesting part of journalctl (52.38 KB, text/plain)
2016-02-01 10:11 UTC, Olivier Churlaud
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Churlaud 2016-02-01 09:42:12 UTC
When I close the lid of my computer, it's quite often that when I open it I don't need to type my password.

The network takes some seconds to reconnect, which means that is was suspended. 

Of course in the settings I said: lock screen on suspend. It however doesn't always happen.

=> Security issue: so I raise the severity to major.

I don't know how to debug further...
Comment 1 Olivier Churlaud 2016-02-01 09:53:38 UTC
next time it happens I'll send the journalctl concerned part..
Comment 2 Martin Flöser 2016-02-01 09:57:24 UTC
Are you using logind?
Comment 3 Olivier Churlaud 2016-02-01 10:01:28 UTC
In journalctl I found this:

     systemd-logind[430]: Lid closed.

So I guess yes
Comment 4 Martin Flöser 2016-02-01 10:09:50 UTC
Discussion on IRC showed that closing the lid can interact with the touchpad, thus the common and well known problem of input grab disables lock screen happens

*** This bug has been marked as a duplicate of bug 78871 ***
Comment 5 Olivier Churlaud 2016-02-01 10:11:56 UTC
Created attachment 96951 [details]
dump of the interesting part of journalctl