Bug 358660 - KSystemGuard crashed on closing
Summary: KSystemGuard crashed on closing
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.5.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-01-27 23:17 UTC by Lastique
Modified: 2018-02-16 22:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.66 KB, text/plain)
2016-05-16 06:56 UTC, Pascal d'Hermilly
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lastique 2016-01-27 23:17:01 UTC
Application: ksysguard (5.5.3)

Qt Version: 5.5.1
Operating System: Linux 4.2.0-25-generic x86_64
Distribution: Ubuntu 15.10

-- Information about the crash:
- What I was doing when the application crashed:

KSystemGuard application crashed when I closed it. The crash doesn't happen every time, though.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  operator== (s1=..., s2=...) at tools/qstring.cpp:2553
#7  0x00007fd766c0cbd7 in QLabel::setText (this=0x754550, text=...) at widgets/qlabel.cpp:276
#8  0x00007fd76a410239 in TopLevel::answerReceived (this=0x744020, id=<optimized out>, answerList=...) at ../../gui/ksysguard.cpp:447
#9  0x00007fd7696a8d11 in KSGRD::SensorAgent::processAnswer(char const*, int) () from /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#10 0x00007fd7696b0620 in ?? () from /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#11 0x00007fd766200777 in QtPrivate::QSlotObjectBase::call (a=0x7fff4c3349e0, r=0x841390, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobject_impl.h:124
#12 QMetaObject::activate (sender=sender@entry=0x83bc60, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=5, argv=argv@entry=0x0) at kernel/qobject.cpp:3698
#13 0x00007fd7662010e7 in QMetaObject::activate (sender=sender@entry=0x83bc60, m=m@entry=0x7fd766417360 <QProcess::staticMetaObject>, local_signal_index=local_signal_index@entry=5, argv=argv@entry=0x0) at kernel/qobject.cpp:3578
#14 0x00007fd7660ff1b3 in QProcess::readyReadStandardOutput (this=this@entry=0x83bc60) at .moc/moc_qprocess.cpp:266
#15 0x00007fd766107822 in QProcessPrivate::tryReadFromChannel (this=0x85f9f0, channel=0x85fb20) at io/qprocess.cpp:966
#16 0x00007fd766107ca0 in QProcessPrivate::_q_canReadStandardOutput (this=<optimized out>) at io/qprocess.cpp:977
#17 QProcess::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7fff4c334be0) at .moc/moc_qprocess.cpp:133
#18 0x00007fd7662008ea in QMetaObject::activate (sender=sender@entry=0x7e3eb0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff4c334be0) at kernel/qobject.cpp:3713
#19 0x00007fd7662010e7 in QMetaObject::activate (sender=sender@entry=0x7e3eb0, m=m@entry=0x7fd76641b6e0 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff4c334be0) at kernel/qobject.cpp:3578
#20 0x00007fd7662801fe in QSocketNotifier::activated (this=this@entry=0x7e3eb0, _t1=12) at .moc/moc_qsocketnotifier.cpp:134
#21 0x00007fd76620cd9b in QSocketNotifier::event (this=0x7e3eb0, e=<optimized out>) at kernel/qsocketnotifier.cpp:260
#22 0x00007fd766ac69dc in QApplicationPrivate::notify_helper (this=this@entry=0x6639e0, receiver=receiver@entry=0x7e3eb0, e=e@entry=0x7fff4c334e50) at kernel/qapplication.cpp:3716
#23 0x00007fd766acbea6 in QApplication::notify (this=0x7fff4c335170, receiver=0x7e3eb0, e=0x7fff4c334e50) at kernel/qapplication.cpp:3499
#24 0x00007fd7661d1d7b in QCoreApplication::notifyInternal (this=0x7fff4c335170, receiver=0x7e3eb0, event=event@entry=0x7fff4c334e50) at kernel/qcoreapplication.cpp:965
#25 0x00007fd7662289bd in QCoreApplication::sendEvent (event=0x7fff4c334e50, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:224
#26 socketNotifierSourceDispatch (source=0x698d90) at kernel/qeventdispatcher_glib.cpp:101
#27 0x00007fd75ed14ff7 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fd75ed15250 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fd75ed152fc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fd7662284ef in QEventDispatcherGlib::processEvents (this=0x698ee0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#31 0x00007fd7661cf50a in QEventLoop::exec (this=this@entry=0x7fff4c335060, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#32 0x00007fd7661d75ec in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1229
#33 0x00007fd76650bd1c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1530
#34 0x00007fd766ac2e15 in QApplication::exec () at kernel/qapplication.cpp:2976
#35 0x00007fd76a411b5d in kdemain (argc=1, argv=<optimized out>) at ../../gui/ksysguard.cpp:594
#36 0x00007fd769ff0a40 in __libc_start_main (main=0x400730 <main(int, char**)>, argc=1, argv=0x7fff4c3352b8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff4c3352a8) at libc-start.c:289
#37 0x0000000000400769 in _start ()

Possible duplicates by query: bug 348751, bug 347662.

Reported using DrKonqi
Comment 1 Pascal d'Hermilly 2016-05-16 06:56:06 UTC
Created attachment 99012 [details]
New crash information added by DrKonqi

ksysguard (5.5.5) using Qt 5.5.1

- What I was doing when the application crashed:
It crashed right after closing ksysguard.

-- Backtrace (Reduced):
#6  operator== (s1=..., s2=...) at tools/qstring.cpp:2553
#7  0x00007fc4539cded7 in QLabel::setText (this=0x10489c0, text=...) at widgets/qlabel.cpp:276
#8  0x00007fc4571ce1a9 in TopLevel::answerReceived (this=0x1031c70, id=<optimized out>, answerList=...) at /build/ksysguard-2wYzme/ksysguard-5.5.5/gui/ksysguard.cpp:447
#9  0x00007fc456467cc1 in KSGRD::SensorAgent::processAnswer(char const*, int) () from /usr/lib/x86_64-linux-gnu/libksgrd.so.7
[...]
#11 0x00007fc452fc3e4f in QtPrivate::QSlotObjectBase::call (a=0x7ffc62517770, r=0x109c160, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobject_impl.h:124
Comment 2 Christoph Feck 2018-02-16 22:47:04 UTC

*** This bug has been marked as a duplicate of bug 350140 ***