Bug 358390 - Implement KHamburgerMenu
Summary: Implement KHamburgerMenu
Status: RESOLVED FIXED
Alias: None
Product: kdenlive
Classification: Applications
Component: User Interface (show other bugs)
Version: git-master
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Jean-Baptiste Mardelle
URL:
Keywords: junior-jobs
Depends on:
Blocks:
 
Reported: 2016-01-22 21:18 UTC by Unknown
Modified: 2022-09-20 21:55 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.12.0
fritzibaby: low_hanging+


Attachments
Example of eliminating the top menu bar and replacing it with a graphic button in the main toolbar. (346.23 KB, image/jpeg)
2016-01-22 21:19 UTC, Unknown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2016-01-22 21:18:27 UTC
See mock-up for a visual. What if you did away with the old main menu bar at the top and made it the first button in the main toolbar? The icon could be the new Kdenlive breeze icon, with the text "Menu" (or whatever text you want) to the right of it; and the menu options could be arranged similar to the context menus in the Kdenlive widgets: where the options are listed vertically, and the sub-menu options open to the right of it.

BENEFITS:
(1) Would eliminate the oldy-hokey look of the traditional text-only menu bar, and give a nice, sleek-looking menu that falls in line with the rest of the Kdenlive menu styles
(2) Would increase the default program real-estate by removing the space taken up by the top menu bar, leaving more room for the editor widgets themselves
(3) There's PLENTY of space in the main and extra toolbars

You could make it a mandatory button so the user couldn't accidentally get rid of it if customizing the toolbars.

Food for thought. :)

Reproducible: Always
Comment 1 Unknown 2016-01-22 21:19:00 UTC
Created attachment 96788 [details]
Example of eliminating the top menu bar and replacing it with a graphic button in the main toolbar.
Comment 2 Unknown 2016-01-25 16:56:56 UTC
And if it's not possible to make a fixed button in the main toolbar, maybe make a toolbar just for that button on the far left that couldn't be edited or changed? Just brainstormin', here. :)
Comment 3 Paul Konecny 2016-02-08 13:08:48 UTC
I generally like the idea of a tidied-up look. I think Jesse's suggestion is definitely one approach worth looking into.
On the other hand maybe we could try using Kai Uwe Brouliks new global menu applet as shown in this blog post http://blog.broulik.de/2016/02/outside-the-stellarator/
The one thing that might be an issue though is integrating this in other DEs like GNOME for example. 
Is there a DE independent standard from xdg?
Maybe Ken Vermette's dynamic window decorations would be an option for Plasma?
I'm just throwing in my two cents but I think Jesse's idea would require the least effort to implement a cleanup in a DE independent manner.
Comment 4 Unknown 2016-05-16 18:07:24 UTC
Paul, not a bad idea, but I know that many DE's don't use global menus, nor do they have an option or place for it.

Curious if this is in the discussions at all on Phabricator? Should I be suggesting this in there instead?
Comment 5 Paul Konecny 2016-05-23 20:58:00 UTC
Maybe not a bad idea but have you tried the forums first? 
I think we should get general feedback from more users before we propose it to the developers.
Comment 6 Unknown 2016-05-24 20:09:49 UTC
Thanks for the suggestion Paul. I'll definitely do that from now on. :)
Comment 7 Unknown 2016-10-27 23:48:50 UTC
Curious to know other users' feedback on this idea? I mentioned it in Phabricator as well (see https://phabricator.kde.org/T808).
Comment 8 Unknown 2016-12-15 18:48:15 UTC
Three days ago, I posted a poll on the Google+ Kdenlive community to see what other users thought. To date, 31 votes were put in, 17 in favor of a default "single menu button" that brings all of the menu items to view in a drown-down list style, and 14 were in favor of keeping it the traditional way it is now.
Comment 9 Julius Künzel 2021-04-23 18:04:29 UTC
Thanks for your feature request! I think your suggestion can be useful in some situations, but I don't think we should make it default… However implementing this doesn't seem to be that easy as Kdenlives basic menu structure is based on KDE Frameworks BUT now there is a brand new KHamburgerMenu since the most recent Frameworks update (5.81) for exactly that purpose! This makes it much easier so we should consider to implement it…

See https://api.kde.org/frameworks/kconfigwidgets/html/classKHamburgerMenu.html
Comment 10 Julius Künzel 2022-09-20 21:53:44 UTC
Git commit cb38d57691cfba311c0e59fd748d88a5b8690ba8 by Julius Künzel.
Committed on 20/09/2022 at 21:34.
Pushed by jlskuz into branch 'master'.

Show a hamburger menu in the main toolbar if menu bar is hidden

Implemented via KHamburgerMenu

M  +19   -2    src/mainwindow.cpp

https://invent.kde.org/multimedia/kdenlive/commit/cb38d57691cfba311c0e59fd748d88a5b8690ba8