Bug 358106 - [REGRESSION] Allow week to start on Monday
Summary: [REGRESSION] Allow week to start on Monday
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: GIT (master)
Platform: Archlinux Linux
: NOR normal with 121 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 374803 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-01-17 02:56 UTC by sparhawk
Modified: 2018-04-01 12:03 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.9.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sparhawk 2016-01-17 02:56:10 UTC
In week and month views, the week starts on a Sunday. There is no clear way to make the week start on a Monday. I seem to remember being able to change this in a previous version (a few months ago). However, I cannot find it in the settings any more.

Up-to-date Arch Linux
korganizer 15.12.1

Reproducible: Always

Steps to Reproduce:
Look at week and month views.

Actual Results:  
Week starts on a Sunday.

Expected Results:  
There should be a setting to allow the week to start on a Monday.

Please let me know if there is a workaround in the meantime, as this is quite disconcerting.
Comment 1 sparhawk 2016-01-22 02:18:11 UTC
This is driving me crazy! I missed an appointment the other day, because I looked at the first column in week view, and presumed that it was Monday, not Sunday!

In the current Korganizer (5.1.1), when I select "Settings" > "Configure Date & Time…", it takes me to a pretty limited configuration page, which is identical to "System Settings" > "Regional Setttings".

I had a look at an old Korganizer install (4.14.10) that I had in a Virtual environment. When I select "Settings" > "Configure Date & Time…", it takes me to a much more configurable page named "Country/Region & Language". Here, in the "Calendar" tab, I could select what day the week started on.

Screenshot: http://i.imgur.com/w0GbZlP.png

I couldn't find how to access to this page in either install, through System Settings. Is there another way to access this in the current Plasma?
Comment 2 sparhawk 2016-03-14 02:44:54 UTC
Is there some
Comment 3 Sam 2016-04-14 16:44:59 UTC
+1: cannot find any way to convince korganizer to start the week on Monday. 
This has a quite big impact on usability and can be really confusing for many users.  
It would be very nice to have this functionality back!
Comment 4 sparhawk 2016-04-14 21:25:43 UTC
@Sam, one workaround I found is to set your time format to `en_GB.UTF-8` (via Plasma's System Settings > Personalisation > Regional Settings > Formats > Detailed Settings > Time). This makes the week start on a Monday. Unfortunately, you are then forced to use the full en_GB time formats. For examples (as opposed to my preferred en_AU), time is 24 hours, instead of 12 hours, which exacerbates other korganizer bugs [1] (also filed 4 months ago, with no answer).

Ideally, we'd be able to manually modify all elements of the time format ourselves, but I cannot find a way to do that. More information here [2].

[1] https://bugs.kde.org/show_bug.cgi?id=356216
[2] https://forum.kde.org/viewtopic.php?f=289&t=131794
Comment 5 Sam 2016-04-17 14:08:27 UTC
@sparhawk: thanks for the rapid answer! Unfortunately I already tried that and it doesn't work for me: I have already en_GB for both Region and Time but still in korganizer the week starts on Sunday... pretty weird. 
Thanks anyway! Let's hope this regression will get fixed sooner rather than later.
Comment 6 sparhawk 2016-04-21 05:33:48 UTC
Huh, very strange. I wonder if those locale files are distro specific. Seems unlikely, but possible.

FWIW I wouldn't hold my breath for a quick fix. I think my hit-rate is something like 5% for even getting a dev to respond here, let alone fix it!
Comment 7 Daniel 2016-04-24 12:48:15 UTC
Same here on Kubuntu 16.04
Comment 8 sparhawk 2016-05-03 03:33:57 UTC
I just found this today. Not only is it incorrect to force Australians to "start" their week on a Sunday, it's fairly evenly split across the whole world.

https://i.imgur.com/fRzalMT.png
Comment 9 Michael D 2016-06-21 09:03:01 UTC
I think this should be an option in the widget, rather than having to mess with locale settings so that the clock widget picks it up. Having it a feature of the widget also does not require that the user logout and back in again to enforce changes.
Comment 10 sparhawk 2016-06-21 09:10:25 UTC
@Michael D, ideally the more options the better! As above, seeing as I can't figure out where Plasma picks up its locales from, changing locales messes up a whole bunch of other things too… so ideally I'd love to be able to modify both.
Comment 11 David Wen Riccardi-Zhu 2016-07-07 15:28:42 UTC
Can also confirm Kubuntu 16.04.
Comment 12 sparhawk 2017-02-07 21:58:12 UTC
This source too: https://www.timeanddate.com/calendar/days/monday.html
Comment 13 petteyg359 2017-02-08 01:02:22 UTC
*** This bug has been confirmed by popular vote. ***
Comment 14 livier 2017-10-18 15:18:50 UTC
+1 
Still no solution ?

Neon
Plasma 5.11.1
kdeframeworks 5.39.0
Qt 5.9.
Comment 15 davidblunkett 2018-01-14 18:46:40 UTC
Still a problem in 5.5.3 - I wish to start the week on Sunday but can't and I've no wish to change my regional settings to a foreign country to acheive this (even if I knew how).
Comment 16 livier 2018-01-14 23:50:46 UTC
I use a workaround but maybe this is not a bug, just a feature.
The different countries officially begin the week by a different day, Sunday in north America, Monday in Europa ... if I well remember what I readied.
So just set the LOCALE for the format you need. In general "French Canadian" Locales, I have french ones for Hours and Orders. And it is better now.
All this cam be setuped in KDE : System settings > regionals parameters > Formats (free translation).
Once I changed more specificals Locales, and OpenOffice had accents problems. 
A bit tricky but seems a feature a bit underdocumented.
Hope it will help
Comment 17 sparhawk 2018-01-14 23:55:09 UTC
I think the fact that it's not customisable is arguably a feature (if a poor one). However, there is definitely a bug present, because the hard-coded days are incorrect. See my comments above.
Comment 18 Christoph Feck 2018-01-17 22:37:26 UTC
*** Bug 374803 has been marked as a duplicate of this bug. ***
Comment 19 Allen Winter 2018-03-31 14:39:51 UTC
Git commit 343b00c4a04f7ca945fd2e6e4924fe4412eaf176 by Allen Winter.
Committed on 31/03/2018 at 14:37.
Pushed by winterz into branch 'master'.

support firstDayOfWeek setting (to override the locale) in monthview

M  +1    -1    CMakeLists.txt
M  +6    -0    src/eventviews.kcfg
M  +7    -8    src/month/monthview.cpp
M  +16   -6    src/prefs.cpp
M  +5    -0    src/prefs.h

https://commits.kde.org/eventviews/343b00c4a04f7ca945fd2e6e4924fe4412eaf176
Comment 20 Allen Winter 2018-03-31 15:01:09 UTC
Git commit 121b91e503688dc752e32500314eb1c286e15736 by Allen Winter.
Committed on 31/03/2018 at 14:57.
Pushed by winterz into branch 'master'.

allow configuring first day of week.
FIXED-IN: 5.8.0

note that we've only supported this in the agenda and month views.
it is currently not available in other views, like timeline or whatsnext.
open new wishes if you need those views supported.

also note that you need to restart Kontact/KOrganizer to see the change;
which is yet-another-bug. (in agendaview, moving the range also works)

M  +1    -1    CMakeLists.txt
M  +7    -0    doc/index.docbook
M  +5    -8    src/datenavigator.cpp
M  +28   -29   src/kodaymatrix.cpp
M  +5    -0    src/koglobals.cpp
M  +1    -1    src/koglobals.h
M  +77   -68   src/prefs/koprefsdialog.cpp
M  +7    -0    src/settings/korganizer.kcfg
M  +2    -2    src/widgets/kdatenavigator.cpp

https://commits.kde.org/korganizer/121b91e503688dc752e32500314eb1c286e15736
Comment 21 David 2018-03-31 15:33:31 UTC
I wouldn't call this fixed by any means - there is still no way to set the week starting day for the system in general, such as for the calendar widgets, other than by changing the regional settings to some other country's entirely (like it was possible to do in older KDE versions).
Comment 22 Allen Winter 2018-03-31 15:42:28 UTC
not my problem.