Bug 357873 - libstdc++ unhandled instruction: 0xF 0xC7 0xF0 0x89
Summary: libstdc++ unhandled instruction: 0xF 0xC7 0xF0 0x89
Status: RESOLVED DUPLICATE of bug 353370
Alias: None
Product: valgrind
Classification: Developer tools
Component: vex (show other bugs)
Version: unspecified
Platform: Kubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Julian Seward
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-11 23:09 UTC by Michael
Modified: 2016-01-12 14:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2016-01-11 23:09:38 UTC
Running Krita development version in callgrind causes a crash at startup. The backtrace points to some point in the new c++11 stdlib random number facility. There is some mention of Vc SIMD library in the backtrace, but the call to std::random_device happens before any SIMD operations are invoked so I doubt that is the issue. 

The call occurs around line 165 here: https://phabricator.kde.org/diffusion/KRITA/browse/master/krita/image/kis_brush_mask_applicators.h


vex amd64->IR: unhandled instruction bytes: 0xF 0xC7 0xF0 0x89 0x6 0xF 0x42 0xC1
vex amd64->IR:   REX=0 REX.W=0 REX.R=0 REX.X=0 REX.B=0
vex amd64->IR:   VEX=0 VEX.L=0 VEX.nVVVV=0x0 ESC=0F
vex amd64->IR:   PFX.66=0 PFX.F2=0 PFX.F3=0
==18052== valgrind: Unrecognised instruction at address 0x6a75ec5.
==18052==    at 0x6A75EC5: std::(anonymous namespace)::__x86_rdrand() (random.cc:69)
==18052==    by 0x6A76061: std::random_device::_M_getval() (random.cc:130)
==18052==    by 0x869FF59: std::random_device::operator()() (in ~/lib/x86_64-linux-gnu/libkritaimage.so.15.0.0)
==18052==    by 0x86A04C4: KisBrushMaskScalarApplicator<KisCircleMaskGenerator, (Vc::Implementation)6>::processScalar(QRect const&) (in ~/lib/x86_64-linux-gnu/libkritaimage.so.15.0.0)
Comment 1 Mark Wielaard 2016-01-12 14:45:36 UTC

*** This bug has been marked as a duplicate of bug 353370 ***