Bug 357099 - Stuck at connecting animation [regression]
Summary: Stuck at connecting animation [regression]
Status: RESOLVED DUPLICATE of bug 352326
Alias: None
Product: plasma-nm
Classification: Plasma
Component: general (show other bugs)
Version: 5.4.3
Platform: Fedora RPMs Linux
: NOR normal
Target Milestone: ---
Assignee: Lukáš Tinkl
Depends on:
Reported: 2015-12-23 12:46 UTC by kdebuac.rhn
Modified: 2016-05-25 19:21 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:

Screenshot of the "spinning icon" (36.14 KB, image/png)
2015-12-24 10:42 UTC, brancaleone
dbus output when activating a vpn (43.50 KB, text/plain)
2015-12-29 09:02 UTC, brancaleone
debug output from plasmashell (17.07 KB, text/plain)
2015-12-29 09:09 UTC, brancaleone

Note You need to log in before you can comment on or make changes to this bug.
Description kdebuac.rhn 2015-12-23 12:46:52 UTC
When connecting to a new network, occasionally the applet never acknowledges that an interface has been configured, never ceasing to display the connecting aimation which eats up to 60% (!) CPU time.

The workaround is to disconnect/remove the interface and start it again - it is very inconvenient when said interface belongs to a VM or a container.

Reproducible: Sometimes

Steps to Reproduce:
a) Connect to wireless network using the applet
b) connect to VPN using command line
c) start a (routed) network using virt-manager

Actual Results:  
Even after configuring the interface, it still has the "connecting" animation both in the tray icon and in popup shelf.

Expected Results:  
No animation after interface is operational.
Comment 1 kdebuac.rhn 2015-12-23 12:47:45 UTC
Should it be filed as a separate bug that the animation disproportionately strains the CPU ?
Comment 2 brancaleone 2015-12-24 10:31:27 UTC
I'd like to confirm this. I'm curently using plasma 5.5.2, but it was already in 5.5.0

Note that for me i can also reproduce in different ways :

* At startup : my home wifi need me to unlock kwallet. After it's done the wireless connection is working (even marked as "connected" in the applet details).
* After resume from suspend, any connection previously active (wireless or wired) have the problem
* Connecting a VPN from the applet (tried openvpn, pptp and openconnect).
* Simply disconnecting and reconnecting any running connection.

In all those cases, i have applet icon still "spinning" in systray, and in in connections details (right click on the applet icon) it is also a spinning icon, but the connection is marked "connected" and i have the option to disconnect.

It also give me a high cpu usage of plasmashell.

It can be fixed by simply killing and restarting plasmashell. The icon now show the correct status and cpu usage drops. But of course it restart each time you do one of the actions described previously.
Comment 3 brancaleone 2015-12-24 10:42:42 UTC
Created attachment 96286 [details]
Screenshot of the "spinning icon"

Here is a screenshot of what is shown when there is the problem.

Note that below the connection i activated "BrancaPalace" the status is "connecté" (connected in french), and if i hover the mouse icon over that connection i have the option to "disconnect".
Comment 4 AnAkkk 2015-12-25 19:36:49 UTC
I think I had the same problem here (high CPU usage):

This is not only specific to the network applet, but any animation on the task bar is actually causing this CPU usage issue apparently.
Comment 5 Jan Grulich 2015-12-28 13:43:06 UTC
Please provide info as described here: https://techbase.kde.org/Projects/Solid/Plasma-nm#My_connection_in_the_applet_shows_wrong_information. 

What frameworks version do you have?
Comment 6 brancaleone 2015-12-29 09:02:17 UTC
Created attachment 96351 [details]
dbus output when activating a vpn

Output of dbus when i activate a VPN connection and the icon is still "spinning".

Framework version is 5.17.0
Comment 7 brancaleone 2015-12-29 09:09:43 UTC
Created attachment 96352 [details]
debug output from plasmashell

plasmashell debug output. Note that i removed a bunch of line listing all my vpn connection, as this may be sensitive information. I think the last ones are more relevant anyway.
Comment 8 brancaleone 2015-12-29 09:22:18 UTC
Note also that if i restart plasmashell after the connection has been established, then plasma-nm show the right status. And if i disconnect the active connection, the status is also modified correctly. It seems to be a problem only when i enable a connection.

But maybe the problem is not only with plasma-nm. I've saw today that i have a similar problem with the removable devices applet : If i plug an external usb stick, i got the new device notification.  But when i click on the mount icon, nothing change on the applet interface, but the device is correctly mounted on the filesystem. If i click again on mount, i get an error that it's impossible to mount device (of course because it is already mounted actually). I have the same error when using the unmount button on the applet.
As with plasma-nm, a plasmashell restart fix the status.
Comment 9 Jan Grulich 2016-01-04 07:29:37 UTC

*** This bug has been marked as a duplicate of bug 352326 ***