Bug 356508 - Kontact crashes when requesting close
Summary: Kontact crashes when requesting close
Status: RESOLVED DUPLICATE of bug 328755
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-12-11 10:58 UTC by Mark Stanton
Modified: 2017-05-11 14:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Stanton 2015-12-11 10:58:40 UTC
Application: kontact (4.14.10)
KDE Platform Version: 4.14.14
Qt Version: 4.8.6
Operating System: Linux 4.2.6-201.fc22.x86_64 x86_64
Distribution: "Fedora release 22 (Twenty Two)"

-- Information about the crash:
- What I was doing when the application crashed:

Closing Kontact (using close icon at top right of window) because it seemed to have gone out of control. It was using around 50% cpu most of the time without any visible cause.

- Unusual behavior I noticed:

A very (very) large number of emails appear as "popup notes" in the "overview" section of Kontact, although they don't appear in the popup notes section.
I was looking for a way to remove them, until Kontact seemed to go wild.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8ffd78e900 (LWP 3127))]

Thread 3 (Thread 0x7f8fb2be9700 (LWP 3148)):
#0  0x0000003aad60c540 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x0000003b7858af61 in JSC::BlockAllocator::blockFreeingThreadMain() () at /lib64/libQtWebKit.so.4
#2  0x0000003b788896d6 in WTF::wtfThreadEntryPoint(void*) () at /lib64/libQtWebKit.so.4
#3  0x0000003aad607555 in start_thread () at /lib64/libpthread.so.0
#4  0x0000003aacb02b9d in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7f8fa826b700 (LWP 3259)):
#0  0x0000003aacaf72fd in poll () at /lib64/libc.so.6
#1  0x0000003aae249dbc in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#2  0x0000003aae249ecc in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#3  0x0000003ab77ba4ee in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#4  0x0000003ab7788791 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#5  0x0000003ab7788b05 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#6  0x0000003ab7678289 in QThread::exec() () at /lib64/libQtCore.so.4
#7  0x0000003ab767aaac in QThreadPrivate::start(void*) () at /lib64/libQtCore.so.4
#8  0x0000003aad607555 in start_thread () at /lib64/libpthread.so.0
#9  0x0000003aacb02b9d in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7f8ffd78e900 (LWP 3127)):
[KCrash Handler]
#6  0x00000032bdd9b0d0 in QAbstractSlider::maximum() const () at /lib64/libQtGui.so.4
#7  0x0000003970e23714 in KViewStateSaver::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) [clone .part.25] () at /lib64/libkdeui.so.5
#8  0x0000003ab77a3e61 in QObject::event(QEvent*) () at /lib64/libQtCore.so.4
#9  0x00000032bd9c43ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQtGui.so.4
#10 0x00000032bd9cb206 in QApplication::notify(QObject*, QEvent*) () at /lib64/libQtGui.so.4
#11 0x0000003970e5554a in KApplication::notify(QObject*, QEvent*) () at /lib64/libkdeui.so.5
#12 0x0000003ab7789f1d in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /lib64/libQtCore.so.4
#13 0x0000003ab778d536 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /lib64/libQtCore.so.4
#14 0x0000003ab77ba35e in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () at /lib64/libQtCore.so.4
#15 0x0000003aae249a8a in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#16 0x0000003aae249e20 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#17 0x0000003aae249ecc in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#18 0x0000003ab77ba4ce in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#19 0x00000032bda6a626 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtGui.so.4
#20 0x0000003ab7788791 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#21 0x0000003ab7788b05 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#22 0x0000003ab778e6a9 in QCoreApplication::exec() () at /lib64/libQtCore.so.4
#23 0x0000000000403787 in main ()

Possible duplicates by query: bug 355848, bug 353380.

Reported using DrKonqi
Comment 1 Christoph Feck 2017-05-11 14:14:13 UTC

*** This bug has been marked as a duplicate of bug 328755 ***