Bug 356463 - Importing a calendar item pops up confusing/unclear UI
Summary: Importing a calendar item pops up confusing/unclear UI
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: import/export (show other bugs)
Version: unspecified
Platform: Kubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-10 13:03 UTC by Magnus Hoff
Modified: 2022-04-08 15:46 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Message with wrong actions (23.63 KB, image/png)
2016-01-27 20:59 UTC, info
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus Hoff 2015-12-10 13:03:31 UTC
Clicking a calendar item in my web browser, I opted to open it in KOrganizer. KOrganizer popped up a dialog box with the following text:

> Would you like to merge this calendar item into an existing calendar or use it to create a brand new calendar?
> 
> If you select merge, then you will be given the opportunity to select the destination calendar.
> 
> If you select add, then a new calendar will be created for you automatically.

The buttons for this dialog are "Yes", "No" and "Cancel", but none of the options presented in the text map to any of these buttons. ("Cancel" is pretty clear, though, but not presented in the text)

The texts on the buttons should be more along the lines of "Merge", "Add new" and "Cancel".


Reproducible: Always

Steps to Reproduce:
1. Open a calendar file with KOrganizer


Actual Results:  
Confusing import dialog

Expected Results:  
Clear import dialog

I am also unable to determine the version of KOrganizer. Help -> About KOrganizer / Version gives me "Version" and then nothing, plus "Using:
KDE Frameworks 5.15.0
Qt 5.4.2 (built against 5.4.2)
The xcb windowing system" after.

This in system packages in Kubuntu 15.10.

That is a different bug, but I am noting it here since I was asked which version of KOrganizer I am experiencing this bug in.
Comment 1 info 2016-01-27 20:59:00 UTC
Created attachment 96874 [details]
Message with wrong actions

I was adding event in ics file to my calendar via korganizer and was met with this message. Buttons didn't make any sense in context of the message itself.
Comment 2 Laurent Montel 2017-05-05 05:16:15 UTC
    const int answer =
        KMessageBox::questionYesNoCancel(
            dialogParent(),
            questionText,
            i18nc("@title:window", "Import Calendar"),
            KGuiItem(i18n("Merge into existing calendar")),
            KGuiItem(i18n("Add as new calendar")));

so we have specific name on Ok/Cancel button