Bug 356429 - Suspended reminders quietly disappear if you close Kontact/KOrganizer
Summary: Suspended reminders quietly disappear if you close Kontact/KOrganizer
Status: RESOLVED DUPLICATE of bug 317656
Alias: None
Product: korganizer
Classification: Applications
Component: reminder daemon (korgac) (show other bugs)
Version: 4.14.2
Platform: OpenSUSE Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-09 15:12 UTC by Ian
Modified: 2019-07-29 03:43 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian 2015-12-09 15:12:31 UTC
If i suspend a reminder for "x" hours and i then close kontact, and log out and log back in and reload kontact within that time period, the reminder never pops up again, it is lost. 

Reproducible: Always

Steps to Reproduce:
1. Suspend a reminder for 1 hour (for example)
2. Close kontact
3. logout
4. Login with the hour
5. open kontact
6. wait for reminder

Actual Results:  
Reminder never re-appears

Expected Results:  
Reminder to keep popping up at correct time interval until it is dismissed by the user, even if it runs past the time interval - its important the reminder is only closed by the user.
Comment 1 Ian 2016-05-11 09:38:18 UTC
Still happening with the latest versions of korganiser 5.2.0 
KDE Frameworks 5.21.0
Qt 5.5.1 (built against 5.5.1)
The xcb windowing system
Comment 2 Ian 2016-06-28 08:29:49 UTC
Still happening with the latest versions of korganiser 5.2.2 
KDE Frameworks 5.23.0
Qt 5.6.1 (built against 5.6.1)
The xcb windowing system
Comment 3 Denis Kurz 2016-08-31 18:08:49 UTC

*** This bug has been marked as a duplicate of bug 317656 ***
Comment 4 Philippe Cloutier 2019-07-29 03:43:01 UTC
Thank you very much for reporting Ian,
Can you still reproduce this? If so, at step 4 (" Login with the hour"), should we read "Login within an hour"? If so, should we understand that in the following situation, the reminder shows fine after 4?
1. Suspend a reminder until 19:00
2. logout before 19:00
3. Login *after* 19:00
4. open kontact