Bug 356395 - Missing asset in gtk3 theme
Summary: Missing asset in gtk3 theme
Status: RESOLVED FIXED
Alias: None
Product: Breeze
Classification: Unclassified
Component: gtk theme (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-08 16:43 UTC by Gustavo Alvarez
Modified: 2016-03-15 23:45 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo Alvarez 2015-12-08 16:43:54 UTC
When launch nvidia-settings with GTK3:

(nvidia-settings:31918): Gtk-WARNING **: Error loading image 'file:///usr/share/themes/Breeze-dark-gtk/gtk-3.0/assets/scrollbar-slider-overlay-horizontal-dark.png': Error al abrir el archivo: No existe el fichero o el directorio
(no such file or directory)

and, i'm not sure if is a theme fault

(nvidia-settings:31918): Gtk-WARNING **: Theme directory apps/system-power-actions of theme breeze-dark has no size field
(nvidia-settings:31918): Gtk-WARNING **: Theme directory apps/toolbar of theme breeze-dark has no size field
(nvidia-settings:31918): Gtk-WARNING **: Theme directory categories/kickoff-menu-tabs of theme breeze-dark has no size field

Reproducible: Always

Steps to Reproduce:
1. install breeze-gtk and set default for GTK3
2. launch nvidia-settings with GTK3 (nvidia blob drivers)
3. see the console


Actual Results:  
i don't know because that asset is missing

Expected Results:  
i don't know because that asset is missing

https://github.com/dirruk1/gnome-breeze/issues/18
Comment 1 Christian Stadelmann 2016-01-10 11:59:40 UTC
Same here. Starting gtk+ 3.18.x applications with horizontal scrollbars visible will result in this error message. File file:///usr/share/themes/Breeze-Dark/gtk-3.0/assets/scrollbar-slider-overlay-horizontal-dark.png doesn't exist. This can be easily reproduced when just starting gedit or nautilus and adding some content until horizontal scrollbars are shown. This issue is not related to nvidia. This issue is not present with Gtk default theme Adwaita.

On https://apps.fedoraproject.org/packages/adwaita-icon-theme/ you can get a list of all assets for adwaita icon theme when clicking on "Contents".
Comment 2 Efrem Mc 2016-01-30 02:28:54 UTC
This is a gtk-3.0 issue as this occurs with Plasma 5.5.4 as the </usr/share/themes/Breeze/gtk-3.0/assets/scrollbar-slider-overlay-horizontal.png> file does not exist.
Comment 3 Christian Stadelmann 2016-02-01 19:00:27 UTC
Is there any specification which tells Gtk to provide this file? If not I think it is not an issue in Gtk but in breeze.
Comment 4 Efrem Mc 2016-02-01 19:19:19 UTC
(In reply to Christian Stadelmann from comment #3)
> Is there any specification which tells Gtk to provide this file? If not I
> think it is not an issue in Gtk but in breeze.

No, there is no specification which tells Gtk to provide this.
I agree that it is related to breeze because GTK is kindly reporting the warning.
GTK is not crashing but I have other issues relating to Xorg with Nvidia (nvidia driver) with two monitors.

So how do I report a bug  for the breeze theme?
Comment 5 Christian Stadelmann 2016-02-01 19:29:05 UTC
I think this bug is correctly reported as 

Product: 	Breeze
Component: 	gtk theme

so no need for any action. Your nvidia/Xorg issues could be reported, but probably belong to either nvidia, freedesktop.org or kernel.org.
Comment 7 Aleix Pol 2016-02-02 16:24:53 UTC
https://git.reviewboard.kde.org/r/126970/
Comment 8 Efrem Mc 2016-02-02 20:20:17 UTC
(In reply to Aleix Pol from comment #7)
> https://git.reviewboard.kde.org/r/126970/

These comments also added in the review notes.

I tested this my making changes in /usr/share/themes/Breeze-Dark/gtk-3.0/gtk.css and in /usr/share/themes/Breeze/gtk-3.0/gtk.css

There were two edits because of the name change.  Furthermore, there were already three other lines with the new names already in place.

The changes were made only in the css for gtk-3.0.

Regards,
Efrem McCrimon


Reference:
Linux: OpenMandriva LX3 2015.0 

4.1.15-nrjQL-desktop-1omv #1 SMP PREEMPT Sun Dec 27 14:47:10 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux


Name: Breeze gtk-3.0
Name: Breeze-Dark gtk-3.0

scrollbar-slider-overlay-horizontal-dark.png

scrollbar-slider-overlay-horizontal.png

Looks like these were renamed to scollbar-slider-horizontal-overlay.png,
 scollbar-slider-horizontal-overlay-dark.png
Comment 9 David Edmundson 2016-03-15 23:45:17 UTC
Git commit 0a3dda7c1717f672eee4e8bc6655a7d26561b465 by David Edmundson, on behalf of Last Avengers.
Committed on 15/03/2016 at 23:45.
Pushed by davidedmundson into branch 'Plasma/5.6'.

Gtk3: Fix wrong filename of scrollbar

`(gtk3-demo:5797): Gtk-WARNING **: Error loading image
'file:///usr/share/themes/Breeze/gtk-3.0/assets/scrollbar-slider-
overlay-horizontal.png': Error opening file: No such file or directory`

the image file in assets name `scrollbar-slider-horizontal-overlay.png`
but in css file was `scrollbar-slider-overlay-horizontal.png`.

REVIEW: 127323
REVIEW: 126970

M  +1    -1    Breeze-dark-gtk/gtk-3.0/gtk.css
M  +1    -1    Breeze-gtk/gtk-3.0/_common.scss
M  +1    -1    Breeze-gtk/gtk-3.0/gtk-dark.css
M  +1    -1    Breeze-gtk/gtk-3.0/gtk.css

http://commits.kde.org/breeze-gtk/0a3dda7c1717f672eee4e8bc6655a7d26561b465