Bug 356367 - Google Calendar's Repeated events not correctly updated
Summary: Google Calendar's Repeated events not correctly updated
Status: RESOLVED DUPLICATE of bug 334569
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Google Resource (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Daniel Vrátil
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-07 17:20 UTC by Matti Kettunen
Modified: 2019-02-22 00:37 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matti Kettunen 2015-12-07 17:20:35 UTC
If there are repeated events in Google Calendar and one of them is changed, some or all the events disappear in KOrganizer.


Reproducible: Always

Steps to Reproduce:
1. Create new event in Google Calendar and make it repeated X times (Update KOrganizer to check that events you just created are visible)
2. Change only ONE of the repeated events in Google Calendar (After editing Google Calendar asks: "Would you like to change this event only, all events in the series or this and all following events in the series?" Click: "Only this event")
3. Update KOrganizer


Actual Results:  
Repeated events, or at least some of them, disappear in KOrganizer. In Google Calendar everything is ok. 

Expected Results:  
All the repeated events should be visible and one of them should have been updated.

If modifications are applied to all the repeated events in Google Calendar they are updated correctly in KOrganizer.
If the "not functioning" Google Calendar is exported to file and imported to KOrganizer events are correctly displayed.
Comment 1 David de Cos 2018-12-03 14:44:12 UTC
I can confirm this bug is still present in KOrganizer 5.9.2. I have almost missed an important appointment today because of this.

In case it helps, I have my Google Calendar configured in the Event Calendar plasmoid too, and this bug isn't present there.
Comment 2 Daniel Vrátil 2019-02-22 00:37:21 UTC

*** This bug has been marked as a duplicate of bug 334569 ***