Bug 355457 - Resume from sleep cause kwin crash
Summary: Resume from sleep cause kwin crash
Status: RESOLVED DUPLICATE of bug 361154
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 5.5.4
Platform: Archlinux Linux
: NOR crash with 1 vote (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-11-16 23:21 UTC by barni2000
Modified: 2016-08-27 15:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
qdbus org.kde.KWin /KWin supportInformation (5.43 KB, text/plain)
2015-11-17 00:50 UTC, barni2000
Details
picture from no task icons (3.93 KB, image/png)
2015-11-17 00:59 UTC, barni2000
Details

Note You need to log in before you can comment on or make changes to this bug.
Description barni2000 2015-11-16 23:21:55 UTC
Application: kwin_x11 (5.4.3)

Qt Version: 5.5.1
Operating System: Linux 4.2.5-1-ARCH x86_64
Distribution: "Arch Linux"

-- Information about the crash:
- What I was doing when the application crashed:
I woke up my laptop, thath caused kwin crash and the plasmashell is not load back some taskicon.

The crash can be reproduced sometimes.

-- Backtrace:
Application: KWin (kwin_x11), signal: Aborted
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f03efd85840 (LWP 2169))]

Thread 4 (Thread 0x7f03cedee700 (LWP 2234)):
#0  0x00007ffdc71dd929 in ?? ()
#1  0x00007ffdc71ddc55 in clock_gettime ()
#2  0x00007f03ef5eed36 in clock_gettime () from /usr/lib/libc.so.6
#3  0x00007f03ed433036 in ?? () from /usr/lib/libQt5Core.so.5
#4  0x00007f03ed5b7df9 in QTimerInfoList::updateCurrentTime() () from /usr/lib/libQt5Core.so.5
#5  0x00007f03ed5b720f in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) () from /usr/lib/libQt5Core.so.5
#6  0x00007f03ed5b7a0e in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#7  0x00007f03ed56137a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#8  0x00007f03ed37d9c4 in QThread::exec() () from /usr/lib/libQt5Core.so.5
#9  0x00007f03e783bc85 in ?? () from /usr/lib/libQt5Qml.so.5
#10 0x00007f03ed38296e in ?? () from /usr/lib/libQt5Core.so.5
#11 0x00007f03ef8a44a4 in start_thread () from /usr/lib/libpthread.so.0
#12 0x00007f03ef5e213d in clone () from /usr/lib/libc.so.6

Thread 3 (Thread 0x7f03bffff700 (LWP 2255)):
#0  0x00007f03ef8aa07f in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f03ec2dd5e4 in ?? () from /usr/lib/libQt5Script.so.5
#2  0x00007f03ec2dd629 in ?? () from /usr/lib/libQt5Script.so.5
#3  0x00007f03ef8a44a4 in start_thread () from /usr/lib/libpthread.so.0
#4  0x00007f03ef5e213d in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0x7f03cf5ef700 (LWP 3648)):
#0  0x00007f03ef5ee6a0 in __libc_enable_asynccancel () from /usr/lib/libc.so.6
#1  0x00007f03ef5dae15 in select () from /usr/lib/libc.so.6
#2  0x00007f03ed5b5a2f in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timespec const*) () from /usr/lib/libQt5Core.so.5
#3  0x00007f03ed5b7507 in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) () from /usr/lib/libQt5Core.so.5
#4  0x00007f03ed5b7a0e in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#5  0x00007f03ed56137a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#6  0x00007f03ed37d9c4 in QThread::exec() () from /usr/lib/libQt5Core.so.5
#7  0x00007f03e783bc85 in ?? () from /usr/lib/libQt5Qml.so.5
#8  0x00007f03ed38296e in ?? () from /usr/lib/libQt5Core.so.5
#9  0x00007f03ef8a44a4 in start_thread () from /usr/lib/libpthread.so.0
#10 0x00007f03ef5e213d in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7f03efd85840 (LWP 2169)):
[KCrash Handler]
#5  0x00007f03ef52c5f8 in raise () from /usr/lib/libc.so.6
#6  0x00007f03ef52da7a in abort () from /usr/lib/libc.so.6
#7  0x00007f03ed36ffc1 in QMessageLogger::fatal(char const*, ...) const () from /usr/lib/libQt5Core.so.5
#8  0x00007f03ed36b12e in qt_assert(char const*, char const*, int) () from /usr/lib/libQt5Core.so.5
#9  0x00007f03ef196edf in KWin::DecorationShadowTextureCache::~DecorationShadowTextureCache (this=<optimized out>, __in_chrg=<optimized out>) at /home/user/KDE_DEBUG/kwin/kwin/src/kwin-5.4.3/scene_opengl.cpp:2159
#10 0x00007f03ef52ef88 in __run_exit_handlers () from /usr/lib/libc.so.6
#11 0x00007f03ef52efd5 in exit () from /usr/lib/libc.so.6
#12 0x00007f03eb0ba0fa in ?? () from /usr/lib/libICE.so.6
#13 0x00007f03eb0bfee4 in _IceRead () from /usr/lib/libICE.so.6
#14 0x00007f03eb0c415f in IceProcessMessages () from /usr/lib/libICE.so.6
#15 0x00007f03ed59212a in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQt5Core.so.5
#16 0x00007f03ed61201e in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) () from /usr/lib/libQt5Core.so.5
#17 0x00007f03ed59ec4b in QSocketNotifier::event(QEvent*) () from /usr/lib/libQt5Core.so.5
#18 0x00007f03ee29a01c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#19 0x00007f03ee29f4f6 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#20 0x00007f03ed5639ab in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#21 0x00007f03ed5b7179 in QEventDispatcherUNIX::activateSocketNotifiers() () from /usr/lib/libQt5Core.so.5
#22 0x00007f03ed5b7602 in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timespec*) () from /usr/lib/libQt5Core.so.5
#23 0x00007f03ed5b797c in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#24 0x00007f03d6d8bced in ?? () from /usr/lib/libQt5XcbQpa.so.5
#25 0x00007f03ed56137a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#26 0x00007f03ed56933c in QCoreApplication::exec() () from /usr/lib/libQt5Core.so.5
#27 0x00007f03efabf57f in kdemain (argc=1, argv=0x7ffdc71c9b98) at /home/user/KDE_DEBUG/kwin/kwin/src/kwin-5.4.3/main_x11.cpp:303
#28 0x00007f03ef519610 in __libc_start_main () from /usr/lib/libc.so.6
#29 0x0000000000400809 in _start ()

Reported using DrKonqi
Comment 1 Thomas Lübking 2015-11-16 23:35:14 UTC
Crash on exit, but KWin shouldn't oc. exit itfp.

What does this mean?
> the plasmashell is not load back some taskicon

Can you please attach the output of
  qdbus org.kde.KWin /KWin supportInformation
Comment 2 barni2000 2015-11-17 00:50:37 UTC
Created attachment 95550 [details]
qdbus org.kde.KWin /KWin supportInformation
Comment 3 barni2000 2015-11-17 00:59:49 UTC
Created attachment 95551 [details]
picture from no task icons

After executed 'pkill plasmashell && plasmashell', the icons is showing.
Comment 4 Andreas Hartmetz 2016-04-24 15:28:14 UTC
I get a similar backtrace (at least the same failed assertion) after running zdoom (a Doom engine) with unredirection in full screen enabled. After exiting the game, the window decorations (shadows?) flicker and look very glitchy. kwin will usually crash in less than a minute in that state. If I run kwin_x11 --replace, the old instance crashes during exit. I have a backtrace of that:

Application: KWin (kwin_x11), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9a1df1f940 (LWP 3573))]

Thread 2 (Thread 0x7f9a17fff700 (LWP 3585)):
#0  0x00007f9a2b908d13 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f9a2a4b4562 in qt_safe_select (nfds=8, fdread=0x7f9a10000a78, fdwrite=0x7f9a10000d08, fdexcept=0x7f9a10000f98, orig_timeout=<optimized out>) at /opt/src/ksrc5/qt/stable/qtbase/src/corelib/kernel/qcore_unix.cpp:75
#2  0x00007f9a2a4b4b8d in QEventDispatcherUNIX::select (this=<optimized out>, nfds=<optimized out>, readfds=<optimized out>, writefds=<optimized out>, exceptfds=<optimized out>, timeout=<optimized out>) at /opt/src/ksrc5/qt/stable/qtbase/src/corelib/kernel/qeventdispatcher_unix.cpp:320
#3  0x00007f9a2a4b6157 in QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f9a100008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at /opt/src/ksrc5/qt/stable/qtbase/src/corelib/kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f9a2a4b6945 in QEventDispatcherUNIX::processEvents (this=0x7f9a100008c0, flags=...) at /opt/src/ksrc5/qt/stable/qtbase/src/corelib/kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f9a2a461eec in QEventLoop::processEvents (this=this@entry=0x7f9a17ffec60, flags=..., flags@entry=...) at /opt/src/ksrc5/qt/stable/qtbase/src/corelib/kernel/qeventloop.cpp:128
#6  0x00007f9a2a46232b in QEventLoop::exec (this=this@entry=0x7f9a17ffec60, flags=..., flags@entry=...) at /opt/src/ksrc5/qt/stable/qtbase/src/corelib/kernel/qeventloop.cpp:204
#7  0x00007f9a2a2b76c0 in QThread::exec (this=this@entry=0x7f9a26fb1d60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at /opt/src/ksrc5/qt/stable/qtbase/src/corelib/thread/qthread.cpp:504
#8  0x00007f9a26f3b05c in QDBusConnectionManager::run (this=0x7f9a26fb1d60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at /opt/src/ksrc5/qt/stable/qtbase/src/dbus/qdbusconnection.cpp:181
#9  0x00007f9a2a2bcfe9 in QThreadPrivate::start (arg=0x7f9a26fb1d60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at /opt/src/ksrc5/qt/stable/qtbase/src/corelib/thread/qthread_unix.cpp:340
#10 0x00007f9a2b3276fa in start_thread (arg=0x7f9a17fff700) at pthread_create.c:333
#11 0x00007f9a2b912b5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f9a1df1f940 (LWP 3573)):
[KCrash Handler]
#6  0x00007f9a2b841418 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54
#7  0x00007f9a2b84301a in __GI_abort () at abort.c:89
#8  0x00007f9a2a2a6395 in qt_message_fatal (message=<synthetic pointer>, context=...) at /opt/src/ksrc5/qt/stable/qtbase/src/corelib/global/qlogging.cpp:1645
#9  QMessageLogger::fatal (this=this@entry=0x7ffcbdc5c1f0, msg=msg@entry=0x7f9a2a5093a0 "ASSERT: \"%s\" in file %s, line %d") at /opt/src/ksrc5/qt/stable/qtbase/src/corelib/global/qlogging.cpp:790
#10 0x00007f9a2a2a0678 in qt_assert (assertion=assertion@entry=0x7f9a2b76a262 "m_cache.isEmpty()", file=file@entry=0x7f9a2b765d80 "/home/horst/ksrc5/kde/workspace/kwin/scene_opengl.cpp", line=line@entry=2196) at /opt/src/ksrc5/qt/stable/qtbase/src/corelib/global/qglobal.cpp:2999
#11 0x00007f9a2b6a6e45 in KWin::DecorationShadowTextureCache::~DecorationShadowTextureCache (this=<optimized out>, __in_chrg=<optimized out>) at /home/horst/ksrc5/kde/workspace/kwin/scene_opengl.cpp:2196
#12 0x00007f9a2b845fe8 in __run_exit_handlers (status=0, listp=0x7f9a2bbcf5f8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:82
#13 0x00007f9a2b846035 in __GI_exit (status=<optimized out>) at exit.c:104
#14 0x00007f9a2b82c837 in __libc_start_main (main=0x4008b4 <main(int, char**)>, argc=3, argv=0x7ffcbdc5c358, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffcbdc5c348) at ../csu/libc-start.c:325
#15 0x00000000004007d9 in _start ()
Comment 5 Thomas Lübking 2016-04-24 18:19:28 UTC
Base problem is bug #361154 but the stale shadow cache oc. brilliantly explains that bug!
Comment 6 Martin Flöser 2016-08-27 15:54:01 UTC
The crash on shutdown is also fixed with the change for bug #361154 - as the root problem is the same I set to duplicate.

In the unlikely case that you still experience the crash on exit after 5.7.4 please reopen.

*** This bug has been marked as a duplicate of bug 361154 ***