Bug 354957 - 'To' field completion only works for recent addresses
Summary: 'To' field completion only works for recent addresses
Status: REPORTED
Alias: None
Product: kmail2
Classification: Applications
Component: contact completion (show other bugs)
Version: 5.5.3
Platform: Other Linux
: NOR major with 30 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-06 15:44 UTC by davidebasilio
Modified: 2018-01-04 16:59 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description davidebasilio 2015-11-06 15:44:16 UTC
I have a google contacts account configured in kaddressbook and it works well there.
However, when I compose a message with kmail 5.0.2, autocompletion for the contact only works for recent addresses and not for the google contacts.

This used to work fine with 4.x.


Reproducible: Always

Steps to Reproduce:
1. Add a google contacts resource
2. Compose a message

Actual Results:  
Only recent addresses are used for contact autocomplete.

Expected Results:  
Google contacts addresses should be used.
Comment 1 Stephan Küffner 2015-11-19 09:46:55 UTC
I have the same problem with a owncloud (carddav) account.

Autocompletion not working with carddav addresses, only recent addresses.
When clicking to "Auswählen" (right button on the line of the "to" field), carddav addresses are in the list.
Comment 2 fetzt_doch 2015-12-20 23:44:26 UTC
I can confirm this. There is no completion from the address book, not even from the local one.
Comment 3 Laurent Montel 2015-12-21 08:03:46 UTC
I fixed a bug in 5.1.1 about it.
Comment 4 andros 2016-06-18 14:23:15 UTC
I have 5.1.3 but it still doesn't work. Only recent addresses get completed, not CardDAV.
Comment 5 Laurent Montel 2017-07-31 04:38:31 UTC
5.1.x is very old.
could you verify with 5.5.x or future 5.6.0 ?
Comment 6 Michal Hlavac 2017-07-31 07:47:28 UTC
I am using openSUSE Tumbleweed with latest 5.5.3 and can confirm that it doesn't work. I have 2 google contacts/calendar accounts.
Comment 7 Christoph Feck 2017-08-01 22:40:04 UTC
Thanks for the update; changing status. There doesn't seem to be 5.5.3 tags in bugzilla yet, so using 5.5.2.
Comment 8 Maf. King 2017-08-04 12:07:49 UTC
Also doens't work for me  - and hasn't for a while - presently running OpenSuSE Leap 42.3 and tumbleweed, but I'm pretty sure it was broken in 42.2 as well.

Turning off "recent contacts" in kmail settings means nothing is ever offered as a To:, CC: or BCC: address suggestion

To test further, I made a completely fresh install of Leap 42.3, with a single user. added one local contact and tried to send them an email.  no match.

Pressing the select button found the contact.

My normal user has several loacl and CardDav addressbooks.  Trying to search for something that should match gives several of these in akonadiconsole Debugger:

kontact-1186278907-SearchSession (0x18fc460) 127 { Command: "Search" Query: "{ "limit": -1, "negated": false, "rel": 0, "subTerms": [ { "cond": 0, "key": "name", "negated": false, "value": "Dave" } ] } " Collections: "QVector()" Mimetypes: "(application/x-vnd.kde.contactgroup)" Fetch Scope: { Fetch Flags: "QFlags(0x4|0x10|0x20|0x40|0x100|0x200)" Tag Fetch Scope: "QSet()" Changed Since: "QDateTime( Qt::TimeSpec(LocalTime))" Ancestor Depth: "0" Requested Parts: "QVector(PLD:RFC822)" } Recursive: "false" Remote: "false" }
kontact-1186278907-SearchSession (0x18fc460) 127 { Response: "Search" Error Code: "0" Error Msg: "" }

(the contact "Dave" should return at least 4 or 5 possibles)

I have deleted the all akonadi* directories & files  under ~/.local/share, ~/.config and ~/.cache and re-created all accounts / resources.  No change.
Comment 9 Maf. King 2017-08-04 12:12:09 UTC
Should have said:

Currently on vesrions: Kmail 5.5.3, using KF 5.36.0 Qt 5.9.1

but is affects more than just that version.
Comment 10 Ingo Steuwer 2018-01-04 16:59:07 UTC
I can confirm this bug, seen with various Kubuntu releases (12.04, 16.04, 17.10) with and without KDE backports PPA. Latest Kubuntu package version of kmail and akonadi is 4:17.04.3-0ubuntu1 (Kubuntu 17.10 with backports PPA).

Behaviour is as described in comment #1, carddav/caldav server is Open Xchange.