Bug 354823 - Plasma crashes on multiscreen setup activation
Summary: Plasma crashes on multiscreen setup activation
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Multi-screen support (show other bugs)
Version: 5.5.1
Platform: unspecified Linux
: NOR crash
Target Milestone: 1.0
Assignee: Daniel Vrátil
URL:
Keywords: drkonqi
: 357085 357578 360259 360417 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-04 08:46 UTC by Siddhartha
Modified: 2016-08-08 12:17 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Siddhartha 2015-11-04 08:46:27 UTC
Application: plasmashell (5.4.90)
 (Compiled from sources)
Qt Version: 5.5.1
Operating System: Linux 4.2.5-1-ARCH x86_64
Distribution: "Arch Linux"

-- Information about the crash:
- What I was doing when the application crashed:
Some of the times, attaching secondary screens (Two extra screens using Dell external dock) crashes Plasma. Kscreen also is not able to detect proper resolution, so I have to manually set resolutions using xrandr

The crash can be reproduced sometimes.

-- Backtrace:
Application: Plasma (plasmashell), signal: Aborted
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9664ad9840 (LWP 8884))]

Thread 7 (Thread 0x7f964d223700 (LWP 8885)):
#0  0x00007f965c4c018d in poll () from /usr/lib/libc.so.6
#1  0x00007f9662986ae2 in ?? () from /usr/lib/libxcb.so.1
#2  0x00007f9662988757 in xcb_wait_for_event () from /usr/lib/libxcb.so.1
#3  0x00007f964e314e89 in ?? () from /usr/lib/libQt5XcbQpa.so.5
#4  0x00007f965d0d596e in ?? () from /usr/lib/libQt5Core.so.5
#5  0x00007f965b1974a4 in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f965c4c913d in clone () from /usr/lib/libc.so.6

Thread 6 (Thread 0x7f96466ea700 (LWP 8886)):
#0  0x00007f965c4c018d in poll () from /usr/lib/libc.so.6
#1  0x00007f965742efbc in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f965742f0cc in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f965d30d34f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#4  0x00007f965d2b437a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#5  0x00007f965d0d09c4 in QThread::exec() () from /usr/lib/libQt5Core.so.5
#6  0x00007f9661419c85 in ?? () from /usr/lib/libQt5Qml.so.5
#7  0x00007f965d0d596e in ?? () from /usr/lib/libQt5Core.so.5
#8  0x00007f965b1974a4 in start_thread () from /usr/lib/libpthread.so.0
#9  0x00007f965c4c913d in clone () from /usr/lib/libc.so.6

Thread 5 (Thread 0x7f9639b78700 (LWP 8887)):
#0  0x00007f965c4c018d in poll () from /usr/lib/libc.so.6
#1  0x00007f965742efbc in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f965742f0cc in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f965d30d34f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#4  0x00007f965d2b437a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#5  0x00007f965d0d09c4 in QThread::exec() () from /usr/lib/libQt5Core.so.5
#6  0x00007f9661419c85 in ?? () from /usr/lib/libQt5Qml.so.5
#7  0x00007f965d0d596e in ?? () from /usr/lib/libQt5Core.so.5
#8  0x00007f965b1974a4 in start_thread () from /usr/lib/libpthread.so.0
#9  0x00007f965c4c913d in clone () from /usr/lib/libc.so.6

Thread 4 (Thread 0x7f9633dc7700 (LWP 8888)):
#0  0x00007f965c4c018d in poll () from /usr/lib/libc.so.6
#1  0x00007f965742efbc in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f965742f0cc in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f965d30d34f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#4  0x00007f965d2b437a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#5  0x00007f965d0d09c4 in QThread::exec() () from /usr/lib/libQt5Core.so.5
#6  0x00007f9661419c85 in ?? () from /usr/lib/libQt5Qml.so.5
#7  0x00007f965d0d596e in ?? () from /usr/lib/libQt5Core.so.5
#8  0x00007f965b1974a4 in start_thread () from /usr/lib/libpthread.so.0
#9  0x00007f965c4c913d in clone () from /usr/lib/libc.so.6

Thread 3 (Thread 0x7f9632584700 (LWP 8889)):
#0  0x00007f965b19d07f in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f96642635e4 in ?? () from /usr/lib/libQt5Script.so.5
#2  0x00007f9664263629 in ?? () from /usr/lib/libQt5Script.so.5
#3  0x00007f965b1974a4 in start_thread () from /usr/lib/libpthread.so.0
#4  0x00007f965c4c913d in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0x7f95ab921700 (LWP 8890)):
#0  0x00007f965c4c018d in poll () from /usr/lib/libc.so.6
#1  0x00007f965742efbc in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f965742f0cc in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f965d30d36b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#4  0x00007f965d2b437a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#5  0x00007f965d0d09c4 in QThread::exec() () from /usr/lib/libQt5Core.so.5
#6  0x00007f9661fc0486 in ?? () from /usr/lib/libQt5Quick.so.5
#7  0x00007f965d0d596e in ?? () from /usr/lib/libQt5Core.so.5
#8  0x00007f965b1974a4 in start_thread () from /usr/lib/libpthread.so.0
#9  0x00007f965c4c913d in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7f9664ad9840 (LWP 8884)):
[KCrash Handler]
#6  0x00007f965c4135f8 in raise () from /usr/lib/libc.so.6
#7  0x00007f965c414a7a in abort () from /usr/lib/libc.so.6
#8  0x00007f965d0c2fc1 in QMessageLogger::fatal(char const*, ...) const () from /usr/lib/libQt5Core.so.5
#9  0x00007f965d0be12e in qt_assert(char const*, char const*, int) () from /usr/lib/libQt5Core.so.5
#10 0x0000000000455495 in ShellCorona::isOutputRedundant (this=this@entry=0xdf1e20, screen=...) at /run/media/sdh/sdh-hdd3/sources/kde5/plasma-workspace/shell/shellcorona.cpp:800
#11 0x0000000000458d3f in ShellCorona::addOutput (this=this@entry=0xdf1e20, output=...) at /run/media/sdh/sdh-hdd3/sources/kde5/plasma-workspace/shell/shellcorona.cpp:877
#12 0x000000000045d985 in ShellCorona::load (this=this@entry=0xdf1e20) at /run/media/sdh/sdh-hdd3/sources/kde5/plasma-workspace/shell/shellcorona.cpp:375
#13 0x000000000045de25 in ShellCorona::<lambda(KScreen::ConfigOperation*)>::operator() (op=<optimized out>, __closure=<synthetic pointer>) at /run/media/sdh/sdh-hdd3/sources/kde5/plasma-workspace/shell/shellcorona.cpp:312
#14 QtPrivate::FunctorCall<QtPrivate::IndexesList<0>, QtPrivate::List<KScreen::ConfigOperation*>, void, ShellCorona::setShell(const QString&)::<lambda(KScreen::ConfigOperation*)> >::call (arg=<optimized out>, f=...) at /usr/include/qt/QtCore/qobjectdefs_impl.h:495
#15 QtPrivate::Functor<ShellCorona::setShell(const QString&)::<lambda(KScreen::ConfigOperation*)>, 1>::call<QtPrivate::List<KScreen::ConfigOperation*>, void> (arg=<optimized out>, f=...) at /usr/include/qt/QtCore/qobjectdefs_impl.h:552
#16 QtPrivate::QFunctorSlotObject<ShellCorona::setShell(const QString&)::<lambda(KScreen::ConfigOperation*)>, 1, QtPrivate::List<KScreen::ConfigOperation*>, void>::impl(int, QtPrivate::QSlotObjectBase *, QObject *, void **, bool *) (which=<optimized out>, this_=<optimized out>, r=<optimized out>, a=<optimized out>, ret=<optimized out>) at /usr/include/qt/QtCore/qobject_impl.h:192
#17 0x00007f965d2e4fb7 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQt5Core.so.5
#18 0x00007f96639d2920 in KScreen::ConfigOperation::finished (this=this@entry=0x11ad580, _t1=_t1@entry=0x11ad580) at src/moc_configoperation.cpp:146
#19 0x00007f96639bcefc in KScreen::ConfigOperationPrivate::doEmitResult (this=0x11a4fd0) at /run/media/sdh/sdh-hdd3/sources/kde5/libkscreen/src/configoperation.cpp:56
#20 0x00007f96639d2a97 in KScreen::ConfigOperationPrivate::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at src/moc_configoperation_p.cpp:70
#21 0x00007f965d2e5ff1 in QObject::event(QEvent*) () from /usr/lib/libQt5Core.so.5
#22 0x00007f965e8bf01c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#23 0x00007f965e8c44f6 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#24 0x00007f965d2b69ab in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#25 0x00007f965d2b8da6 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQt5Core.so.5
#26 0x00007f965d30cf43 in ?? () from /usr/lib/libQt5Core.so.5
#27 0x00007f965742edc7 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0x00007f965742f020 in ?? () from /usr/lib/libglib-2.0.so.0
#29 0x00007f965742f0cc in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#30 0x00007f965d30d34f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#31 0x00007f965d2b437a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#32 0x00007f965d2bc33c in QCoreApplication::exec() () from /usr/lib/libQt5Core.so.5
#33 0x00000000004386d0 in main (argc=1, argv=<optimized out>) at /run/media/sdh/sdh-hdd3/sources/kde5/plasma-workspace/shell/main.cpp:176

Reported using DrKonqi
Comment 1 Gero Müller 2015-12-22 11:12:08 UTC
Hello, same happens here.

Thread 1 (Thread 0x7f1094b27800 (LWP 4530)):
[KCrash Handler]
#5  0x00007f10a33897b0 in QScreen::handle() const () from /usr/lib/libQt5Gui.so.5
#6  0x00007f109471ae19 in QXcbIntegration::createPlatformWindow(QWindow*) const () from /usr/lib/libQt5XcbQpa.so.5
#7  0x00007f10a336b714 in QWindowPrivate::create(bool) () from /usr/lib/libQt5Gui.so.5
#8  0x00007f10a336b9d8 in QWindow::winId() const () from /usr/lib/libQt5Gui.so.5
#9  0x0000000000449dab in PanelShadows::Private::clearShadowX11(QWindow const*) ()
#10 0x0000000000449e25 in PanelShadows::Private::clearShadow(QWindow const*) ()
#11 0x000000000044d0ed in PanelShadows::removeWindow(QWindow const*) ()
#12 0x00000000004495cd in PanelConfigView::~PanelConfigView() ()
#13 0x0000000000449669 in PanelConfigView::~PanelConfigView() ()
#14 0x00007f10a3053200 in QObject::event(QEvent*) () from /usr/lib/libQt5Core.so.5
#15 0x00007f10a336d728 in QWindow::event(QEvent*) () from /usr/lib/libQt5Gui.so.5
#16 0x00007f10a61a9081 in QQuickWindow::event(QEvent*) () from /usr/lib/libQt5Quick.so.5
#17 0x00007f10a3b279ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#18 0x00007f10a3b2ce86 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#19 0x00007f10a3023bab in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#20 0x00007f10a3025fa6 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQt5Core.so.5
#21 0x00007f10a307a143 in ?? () from /usr/lib/libQt5Core.so.5
#22 0x00007f109f6d1dc7 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0x00007f109f6d2020 in ?? () from /usr/lib/libglib-2.0.so.0
#24 0x00007f109f6d20cc in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0x00007f10a307a54f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#26 0x00007f10a302157a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#27 0x00007f10a302953c in QCoreApplication::exec() () from /usr/lib/libQt5Core.so.5
#28 0x00000000004313c4 in main ()
Comment 2 Martin Klapetek 2016-02-03 19:28:59 UTC
*** Bug 357578 has been marked as a duplicate of this bug. ***
Comment 3 David Edmundson 2016-03-13 01:11:34 UTC
*** Bug 360259 has been marked as a duplicate of this bug. ***
Comment 4 David Edmundson 2016-03-13 01:11:40 UTC
*** Bug 360417 has been marked as a duplicate of this bug. ***
Comment 5 David Edmundson 2016-03-13 01:12:43 UTC
*** Bug 357085 has been marked as a duplicate of this bug. ***
Comment 6 Henri 2016-03-22 08:52:36 UTC
My bug report was flagged as dublicate to this. I'm using laptop with it's own screen turned off and attached to HDMI splitter where screen is splitted to two displays. From time to time, like when returning from suspend, Plasma wallpaper, panels and widgets just disappear and go black. I don't get pop up about a crash. Everything else still working. Happens too if I try with a new user. This setup used to work fine until recently. Works on most other desktop environments. Using openSUSE Tumbleweed, Plasma 5.5.5, Qt 5.5.1, Frameworks 5.20.0, kernel 4.4.3.

~.xsession-errors -output:
requesting unexisting screen 0
kscreen: Primary output changed from KScreen::Output(Id: 70 , Name: "HDMI1" ) ( "HDMI1" ) to KScreen::Output(Id: 70 , Name: "HDMI1" ) ( "HDMI1" )
kscreen: Requesting missing EDID for outputs (66, 70)
kscreen.kded: Change detected
kscreen.kded: Saving current config to file
Comment 7 Henri 2016-05-01 14:11:46 UTC
The issue is still present with Plasma 5.6.2, Frameworks 5.21.0, Qt 5.5.1. I've tested this with new user getting same results. Sometimes instead of getting just black screen I get info that Plasmashell or ksmserver has crashed. Backtraces at the end. I didn't have this problem until maybe Plasma 5.5.4 or 5.5.5. Plasma 5.5.0 or 5.4 -series returned from suspend with hdmi splitter without problems.

"~/.xsessions-errors:-0" -output when doing suspend and returning from it. result: wallpaper, panels and widgets disappear and there's just black screen instead. I didn't touch my displays.

[QXcbConnection: XCB error: 3 (BadWindow), sequence: 11147, resource id: 41943148, major code: 20 (GetProperty), minor code: 0
powerdevil: Suspend session triggered with QMap(("Explicit", QVariant(bool, true))("Type", QVariant(uint, 1)))
powerdevil: Suspend session triggered with QMap(("Explicit", QVariant(bool, true))("SkipFade", QVariant(bool, true))("Type", QVariant(uint, 1)))
powerdevil: Starting Login1 suspend job
kscreen.kded: System is going to suspend, won't be changing config (waited for  1001 ms)
networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "Metered"
networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "Metered"
plasma-nm: Not emitting connection deactivated notification as we're about to suspend
Time engine Clock skew signaled
powerdevil: Kbd backlight brightness value:  0
powerdevil: set kbd backlight value:  0
kscreen.kded: Resumed from suspend, checking for screen changes
powerdevil: Keyboard brightness changed!!
kdeinit5: Got EXEC_NEW '/usr/lib64/qt5/plugins/kf5/kio/http.so' from launcher.
kdeinit5: preparing to launch '/usr/lib64/qt5/plugins/kf5/kio/http.so'
QXcbConnection: XCB error: 3 (BadWindow), sequence: 13005, resource id: 41943078, major code: 15 (QueryTree), minor code: 0
requesting unexisting screen 0
requesting unexisting screen 0
requesting unexisting screen 0
requesting unexisting screen 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 13006, resource id: 41943078, major code: 20 (GetProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 13061, resource id: 41943070, major code: 15 (QueryTree), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 13062, resource id: 41943070, major code: 20 (GetProperty), minor code: 0
nativeResourceForScreen: null screen
nativeResourceForScreen: null screen
nativeResourceForScreen: null screen
QXcbConnection: XCB error: 3 (BadWindow), sequence: 13114, resource id: 41943082, major code: 15 (QueryTree), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 13115, resource id: 41943082, major code: 20 (GetProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 13166, resource id: 41943086, major code: 15 (QueryTree), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 13167, resource id: 41943086, major code: 20 (GetProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 13213, resource id: 41943056, major code: 15 (QueryTree), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 13214, resource id: 41943056, major code: 20 (GetProperty), minor code: 0
requesting unexisting screen 0
requesting unexisting screen 0
requesting unexisting screen 0
kde.xembedsniproxy: Scaling pixmap of window 117440516 "" from w*h 22 22
kscreen: Requesting missing EDID for outputs (66, 70)
kscreen: Requesting missing EDID for outputs (66, 70)
kscreen.kded: Change detected
kde.xembedsniproxy: Scaling pixmap of window 117440516 "" from w*h 22 22
kscreen.kded: Saving current config to file
kscreen.kded: Calculating config ID for KScreen::Config(0x1020dd0)
kscreen.kded:   Part of the Id:  "36c0397b4c130514192b83daf653f9d7"
kscreen.kded:   Part of the Id:  "488620b885c50298bd95eef521f00120"
kscreen.kded:   Config ID: "ab14884ca1c1c59228da41e688cc9c64"
kscreen.kded: Config saved on:  "/home/henri/.local/share/kscreen/ab14884ca1c1c59228da41e688cc9c64"
kscreen: Requesting missing EDID for outputs (66, 70)
kscreen: Requesting missing EDID for outputs (66, 70)
kscreen.kded: Change detected
kscreen.kded: Saving current config to file
kscreen.kded: Calculating config ID for KScreen::Config(0x1020dd0)
kscreen.kded:   Part of the Id:  "36c0397b4c130514192b83daf653f9d7"
kscreen.kded:   Part of the Id:  "488620b885c50298bd95eef521f00120"
kscreen.kded:   Config ID: "ab14884ca1c1c59228da41e688cc9c64"
kscreen.kded: Config saved on:  "/home/henri/.local/share/kscreen/ab14884ca1c1c59228da41e688cc9c64"

Sometimes I get info that Plasmashell has crashed, backtrace:

Application: Plasma (plasmashell), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f25c341c8c0 (LWP 14034))]

Thread 8 (Thread 0x7f25acad5700 (LWP 14038)):
#0  0x00007f25bc97707d in poll () at /lib64/libc.so.6
#1  0x00007f25c18533f2 in  () at /usr/lib64/libxcb.so.1
#2  0x00007f25c1854fc7 in xcb_wait_for_event () at /usr/lib64/libxcb.so.1
#3  0x00007f25aec25dd9 in  () at /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007f25bd06491f in  () at /usr/lib64/libQt5Core.so.5
#5  0x00007f25bc178424 in start_thread () at /lib64/libpthread.so.0
#6  0x00007f25bc97fadd in clone () at /lib64/libc.so.6

Thread 7 (Thread 0x7f25a5bc2700 (LWP 14045)):
#0  0x00007f25bc97304d in read () at /lib64/libc.so.6
#1  0x00007f25b90a0400 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f25b905de94 in g_main_context_check () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f25b905e308 in  () at /usr/lib64/libglib-2.0.so.0
#4  0x00007f25b905e46c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#5  0x00007f25bd28940b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#6  0x00007f25bd23353a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#7  0x00007f25bd05fadc in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#8  0x00007f25c03310e5 in  () at /usr/lib64/libQt5Qml.so.5
#9  0x00007f25bd06491f in  () at /usr/lib64/libQt5Core.so.5
#10 0x00007f25bc178424 in start_thread () at /lib64/libpthread.so.0
#11 0x00007f25bc97fadd in clone () at /lib64/libc.so.6

Thread 6 (Thread 0x7f2598692700 (LWP 14080)):
#0  0x00007f25bc97304d in read () at /lib64/libc.so.6
#1  0x00007f25b90a0400 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f25b905de94 in g_main_context_check () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f25b905e308 in  () at /usr/lib64/libglib-2.0.so.0
#4  0x00007f25b905e46c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#5  0x00007f25bd28940b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#6  0x00007f25bd23353a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#7  0x00007f25bd05fadc in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#8  0x00007f25c03310e5 in  () at /usr/lib64/libQt5Qml.so.5
#9  0x00007f25bd06491f in  () at /usr/lib64/libQt5Core.so.5
#10 0x00007f25bc178424 in start_thread () at /lib64/libpthread.so.0
#11 0x00007f25bc97fadd in clone () at /lib64/libc.so.6

Thread 5 (Thread 0x7f2596dfe700 (LWP 14083)):
#0  0x00007f25bc17e03f in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
#1  0x00007f25c2af33d4 in  () at /usr/lib64/libQt5Script.so.5
#2  0x00007f25c2af3419 in  () at /usr/lib64/libQt5Script.so.5
#3  0x00007f25bc178424 in start_thread () at /lib64/libpthread.so.0
#4  0x00007f25bc97fadd in clone () at /lib64/libc.so.6

Thread 4 (Thread 0x7f2595e47700 (LWP 14086)):
#0  0x00007f25bc97304d in read () at /lib64/libc.so.6
#1  0x00007f25b90a0400 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f25b905de94 in g_main_context_check () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f25b905e308 in  () at /usr/lib64/libglib-2.0.so.0
#4  0x00007f25b905e46c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#5  0x00007f25bd28940b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#6  0x00007f25bd23353a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#7  0x00007f25bd05fadc in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#8  0x00007f25c03310e5 in  () at /usr/lib64/libQt5Qml.so.5
#9  0x00007f25bd06491f in  () at /usr/lib64/libQt5Core.so.5
#10 0x00007f25bc178424 in start_thread () at /lib64/libpthread.so.0
#11 0x00007f25bc97fadd in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7f250e1ac700 (LWP 14193)):
#0  0x00007f25bc98c740 in clock_gettime () at /lib64/libc.so.6
#1  0x00007f25bd1100c6 in  () at /usr/lib64/libQt5Core.so.5
#2  0x00007f25bd286f99 in QTimerInfoList::updateCurrentTime() () at /usr/lib64/libQt5Core.so.5
#3  0x00007f25bd2874c5 in QTimerInfoList::timerWait(timespec&) () at /usr/lib64/libQt5Core.so.5
#4  0x00007f25bd28886e in  () at /usr/lib64/libQt5Core.so.5
#5  0x00007f25b905d98d in g_main_context_prepare () at /usr/lib64/libglib-2.0.so.0
#6  0x00007f25b905e293 in  () at /usr/lib64/libglib-2.0.so.0
#7  0x00007f25b905e46c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#8  0x00007f25bd28940b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#9  0x00007f25bd23353a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#10 0x00007f25bd05fadc in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#11 0x00007f25c0ebae92 in  () at /usr/lib64/libQt5Quick.so.5
#12 0x00007f25bd06491f in  () at /usr/lib64/libQt5Core.so.5
#13 0x00007f25bc178424 in start_thread () at /lib64/libpthread.so.0
#14 0x00007f25bc97fadd in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7f24fbdbe700 (LWP 14383)):
#0  0x00007f25b90a16a9 in g_mutex_lock () at /usr/lib64/libglib-2.0.so.0
#1  0x00007f25b905d514 in g_main_context_release () at /usr/lib64/libglib-2.0.so.0
#2  0x00007f25b905e31e in  () at /usr/lib64/libglib-2.0.so.0
#3  0x00007f25b905e46c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#4  0x00007f25bd28940b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#5  0x00007f25bd23353a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#6  0x00007f25bd05fadc in QThread::exec() () at /usr/lib64/libQt5Core.so.5
#7  0x00007f24fe4eee07 in KCupsConnection::run() () at /usr/lib64/libkcupslib.so
#8  0x00007f25bd06491f in  () at /usr/lib64/libQt5Core.so.5
#9  0x00007f25bc178424 in start_thread () at /lib64/libpthread.so.0
#10 0x00007f25bc97fadd in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7f25c341c8c0 (LWP 14034)):
[KCrash Handler]
#6  0x00007f25bc8cb9e8 in raise () at /lib64/libc.so.6
#7  0x00007f25bc8cce3a in abort () at /lib64/libc.so.6
#8  0x00007f25bd0527de in  () at /usr/lib64/libQt5Core.so.5
#9  0x00007f25bd77d7bc in QWindowPrivate::init() () at /usr/lib64/libQt5Gui.so.5
#10 0x00007f25c0f5478d in QQuickWindow::QQuickWindow(QWindow*) () at /usr/lib64/libQt5Quick.so.5
#11 0x00007f25c2029924 in KQuickAddons::QuickViewSharedEngine::QuickViewSharedEngine(QWindow*) () at /usr/lib64/libKF5QuickAddons.so.5
#12 0x00007f25c2e2b59f in PlasmaQuick::ContainmentView::ContainmentView(Plasma::Corona*, QWindow*) () at /usr/lib64/libKF5PlasmaQuick.so.5
#13 0x0000000000428971 in  ()
#14 0x000000000043e130 in  ()
#15 0x000000000043e39f in  ()
#16 0x00007f25bd262cc7 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib64/libQt5Core.so.5
#17 0x00007f25c2257bc9 in KScreen::Output::apply(QSharedPointer<KScreen::Output> const&) () at /usr/lib64/libKF5Screen.so.7
#18 0x00007f25c2247575 in KScreen::Config::apply(QSharedPointer<KScreen::Config> const&) () at /usr/lib64/libKF5Screen.so.7
#19 0x00007f25c224d179 in KScreen::ConfigMonitor::Private::updateConfigs(QSharedPointer<KScreen::Config> const&) () at /usr/lib64/libKF5Screen.so.7
#20 0x00007f25c224ecbd in KScreen::ConfigMonitor::Private::edidReady(QDBusPendingCallWatcher*) () at /usr/lib64/libKF5Screen.so.7
#21 0x00007f25bd262cc7 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib64/libQt5Core.so.5
#22 0x00007f25be01baaf in QDBusPendingCallWatcher::finished(QDBusPendingCallWatcher*) () at /usr/lib64/libQt5DBus.so.5
#23 0x00007f25be01d045 in  () at /usr/lib64/libQt5DBus.so.5
#24 0x00007f25bd263c29 in QObject::event(QEvent*) () at /usr/lib64/libQt5Core.so.5
#25 0x00007f25be39987c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#26 0x00007f25be39e986 in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#27 0x00007f25bd235bf3 in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
#28 0x00007f25bd237f16 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib64/libQt5Core.so.5
#29 0x00007f25bd288fe3 in  () at /usr/lib64/libQt5Core.so.5
#30 0x00007f25b905e197 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#31 0x00007f25b905e3c8 in  () at /usr/lib64/libglib-2.0.so.0
#32 0x00007f25b905e46c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#33 0x00007f25bd2893ef in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#34 0x00007f25bd23353a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#35 0x00007f25bd23b1fd in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
#36 0x000000000041d964 in  ()
#37 0x00007f25bc8b7710 in __libc_start_main () at /lib64/libc.so.6
#38 0x000000000041da99 in _start ()

Ksmserver crash backtrace:

Application: ksmserver (ksmserver), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f5c5649b3d0 in QScreen::handle() const () at /usr/lib64/libQt5Gui.so.5
#7  0x00007f5c45f93309 in  () at /usr/lib64/libQt5XcbQpa.so.5
#8  0x00007f5c564a87b1 in  () at /usr/lib64/libQt5Gui.so.5
#9  0x00007f5c564a82cc in QPaintDeviceWindow::event(QEvent*) () at /usr/lib64/libQt5Gui.so.5
#10 0x00007f5c56c1687c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#11 0x00007f5c56c1b986 in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#12 0x00007f5c55f33bf3 in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
#13 0x00007f5c5647fb20 in QWindowPrivate::deliverUpdateRequest() () at /usr/lib64/libQt5Gui.so.5
#14 0x00007f5c5647ffe9 in QWindow::event(QEvent*) () at /usr/lib64/libQt5Gui.so.5
#15 0x00007f5c564a8228 in QPaintDeviceWindow::event(QEvent*) () at /usr/lib64/libQt5Gui.so.5
#16 0x00007f5c56c1687c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#17 0x00007f5c56c1b986 in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#18 0x00007f5c55f33bf3 in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
#19 0x00007f5c55f8629d in QTimerInfoList::activateTimers() () at /usr/lib64/libQt5Core.so.5
#20 0x00007f5c55f867b1 in  () at /usr/lib64/libQt5Core.so.5
#21 0x00007f5c4f918197 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#22 0x00007f5c4f9183c8 in  () at /usr/lib64/libglib-2.0.so.0
#23 0x00007f5c4f91846c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#24 0x00007f5c55f873ef in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#25 0x00007f5c55f3153a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#26 0x00007f5c55f391fd in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
#27 0x00007f5c5b63b9c6 in kdemain () at /usr/lib64/libkdeinit5_ksmserver.so
#28 0x00007f5c5b2a8710 in __libc_start_main () at /lib64/libc.so.6
#29 0x0000000000400839 in _start ()
Comment 8 Stefan Radermacher 2016-05-01 15:20:53 UTC
I have this issue as well, with KDE Frameworks, Plasma 5.6.3, and Qt 5.6.0. I do not get any error dialog, but when my systgem wakes up, plasmashell is crashed. When I start plasmashell from the command line, this is logged;

requesting unexisting screen 1
requesting unexisting screen 1
requesting unexisting screen 1
requesting unexisting screen 1
KCrash: Application 'plasmashell' crashing...
KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit
sock_file=/tmp/runtime-stefan/kdeinit5__0
QSocketNotifier: Invalid socket 8 and type 'Read', disabling...
QSocketNotifier: Invalid socket 35 and type 'Read', disabling...                                 
KCrash: Attempting to start /usr/bin/plasmashell from kdeinit                                    
sock_file=/tmp/runtime-stefan/kdeinit5__0
Unable to start Dr. Konqi
Comment 9 Stefan Radermacher 2016-05-01 15:23:11 UTC
My previous post is missing the KDE Frameworks version: 5.21.0

My setup is two monitors where the right-side one is the main monitor connected via DisplayPort, while the right-side monitor is connected via DVI.
Comment 10 Sebastian Kügler 2016-08-08 11:32:55 UTC
This crash is fixed (avoided, really) by the move to QScreen, away from libkscreen in plasmashell.

If your crash persists, it will be a different one. I could not reproduce it, and the code is gone, though.
Comment 11 Stefan Radermacher 2016-08-08 12:17:35 UTC
Yes, indeed this crash is fixed, but still something strange happens after my monitors ware up: all the windows on my right monitors are moved some distance to the left so that they start on the left monitor but still overlap the right monitor.