Bug 354192 - Feature request: support dwarf debugging information in PE32 binaries
Summary: Feature request: support dwarf debugging information in PE32 binaries
Status: RESOLVED DUPLICATE of bug 211031
Alias: None
Product: valgrind
Classification: Unclassified
Component: memcheck (show other bugs)
Version: 3.10 SVN
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Julian Seward
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-21 23:50 UTC by Qian Hong
Modified: 2015-10-27 19:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Qian Hong 2015-10-21 23:50:45 UTC
Dear valgrind developers,

Valgrind is a great tool even for PE32 binaries, I use Wine + Valgrind to detect memory bugs for open source win32 programs. Recently we found bugs of Cygwin / GNU ld (win32 version) and so on. However, most open source win32 programs are compiled by gcc with dwarf debugging information, which is not supported by valgrind yet. Currently we have to manually translate the addresses reported by valgrind to symbol names and line numbers by third party tools. It works but it is very inconvenient. Valgrind has succeed to detect many problems with Wine, hopefully we can make it better.

I check the valgrind source, and found it support pdb format of debugging information for PE32 binaries, it also support dwarf format for ELF32 binaries. Could you also support Dwarf format for PE32 binaries?

We are using Wine to test hundreds of open source win32 projects from https://msys2.github.io/ , if Dwarf + PE32 could be supported, that would be great useful and great appreciated.

Thanks a lot for your great work!


Reproducible: Always

Steps to Reproduce:
1. compile a PE32 binaries, for example, on Linux:

i686-w64-mingw32-gcc -g -O0 leak.c -o leak.exe

2. Run with Wine following the wiki here:
http://wiki.winehq.org/WineAndValgrind
3.

Actual Results:  
No debugging symbol

Expected Results:  
Expect debugging symbol in leak log
Comment 1 Qian Hong 2015-10-27 19:02:59 UTC
Hi,

After searching the bugzilla again more carefully, I found my report is a duplicate of bug 211031, sorry for the noise!

*** This bug has been marked as a duplicate of bug 211031 ***