Bug 353823 - plasmashell crashes in QScreen::handle() when powering off monitor
Summary: plasmashell crashes in QScreen::handle() when powering off monitor
Status: RESOLVED DUPLICATE of bug 341497
Alias: None
Product: plasmashell
Classification: Plasma
Component: general (show other bugs)
Version: master
Platform: OpenSUSE Linux
: NOR crash
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-12 10:58 UTC by Damian Kaczmarek
Modified: 2015-10-12 11:02 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Damian Kaczmarek 2015-10-12 10:58:25 UTC
(gdb) bt
#0  0x00007ffff23302e0 in QScreen::handle() const (this=0x0) at kernel/qscreen.cpp:112                                                                                                                                              
#1  0x00007fffe3116b59 in QXcbIntegration::createPlatformWindow(QWindow*) const (this=<optimized out>, window=0x16d6f90) at qxcbintegration.cpp:196                                                                                 
#2  0x00007ffff2310ea5 in QWindowPrivate::create(bool) (this=0x165d140, recursive=recursive@entry=false) at kernel/qwindow.cpp:392
#3  0x00007ffff231109b in QWindow::create() (this=this@entry=0x16d6f90) at kernel/qwindow.cpp:548
#4  0x00007ffff2311128 in QWindow::winId() const (this=0x16d6f90) at kernel/qwindow.cpp:567
#5  0x00007ffff79a4e15 in  () at /usr/lib64/libKF5PlasmaQuick.so.5
#6  0x00007ffff79a7699 in  () at /usr/lib64/libKF5PlasmaQuick.so.5
#7  0x00007ffff1de8726 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib64/libQt5Core.so.5
#8  0x00007ffff1de819f in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib64/libQt5Core.so.5
#9  0x00007ffff1de8726 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib64/libQt5Core.so.5
#10 0x00007ffff1df5972 in QTimer::timerEvent(QTimerEvent*) () at /usr/lib64/libQt5Core.so.5
#11 0x00007ffff1de931c in QObject::event(QEvent*) () at /usr/lib64/libQt5Core.so.5
#12 0x00007ffff3135eec in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#13 0x00007ffff313ad38 in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#14 0x00007ffff1db8985 in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
#15 0x00007ffff1e0f1ad in QTimerInfoList::activateTimers() () at /usr/lib64/libQt5Core.so.5
#16 0x00007ffff1e0f4d1 in  () at /usr/lib64/libQt5Core.so.5
#17 0x00007fffede65a04 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#18 0x00007fffede65c48 in  () at /usr/lib64/libglib-2.0.so.0
#19 0x00007fffede65cec in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#20 0x00007ffff1e0f7bb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#21 0x00007ffff1db6853 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#22 0x00007ffff1dbe3f6 in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
#23 0x000000000043633b in main(int, char**) (argc=1, argv=<optimized out>) at /usr/src/debug/plasma-workspace-5.4.90git~20151007T185930~06e9766/shell/main.cpp:176

Reproducible: Always

Steps to Reproduce:
1. Power off monitor
2. Power on monitor

Actual Results:  
plasmashell has crashed

Expected Results:  
shouldn't have crashed

It happens on openSUSE 13.2 with KDE_Frameworks5_Unstable repository, The package installed has version 5.4.90git~20151007T185930~06e9766-29.1
Comment 1 Damian Kaczmarek 2015-10-12 11:00:06 UTC
Just to note, my resolution is 2560x1440 if it makes any difference. The monitor that I disable is the only one.
Comment 2 Bhushan Shah 2015-10-12 11:02:05 UTC

*** This bug has been marked as a duplicate of bug 341497 ***