Bug 353651 - Formatting disks gives wrong permissions
Summary: Formatting disks gives wrong permissions
Status: RESOLVED DUPLICATE of bug 407192
Alias: None
Product: partitionmanager
Classification: Unclassified
Component: general (show other bugs)
Version: 1.2.1
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Andrius Štikonas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-07 12:07 UTC by Michael D
Modified: 2019-05-17 18:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael D 2015-10-07 12:07:53 UTC
Suppose you're non-root user and you want to format e.g. an SD card for use in your phone, using ext4. Performing this operation in KDE Partition Manager results in the disk having root access when mounted. Performing the same operation in gnome's utility "Disks" gives the right permissions. (Incidentally one can open Disks and perform operations without needing elevated root privileges.)

Reproducible: Always

Steps to Reproduce:
1. Format disk in KDE Partition Manager
2. (Auto)mount it and try to access it from non-root user

Actual Results:  
Can't access it from non-root user

Expected Results:  
Can access it
Comment 1 Andrius Štikonas 2015-10-07 13:07:51 UTC
Partition manager itself runs as root user at the moment, that's why only root can access partitions formatted by partition manager (similarly for gparted).

It would be nice to have partition manager use policykit but unfortunately that might take a long time to implement.

*** This bug has been marked as a duplicate of bug 259678 ***
Comment 2 Andrius Štikonas 2019-05-17 18:13:54 UTC
Closing this as duplicate even though the other bug is much newer (but it has more accurate comments, i.e. it's not because of GUI running as root).

*** This bug has been marked as a duplicate of bug 407192 ***