Bug 353358 - Breeze Dark Plasma Theme and Breeze (Light) Icon Theme mix
Summary: Breeze Dark Plasma Theme and Breeze (Light) Icon Theme mix
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: System Tray (show other bugs)
Version: master
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
: 353386 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-30 08:00 UTC by andreas
Modified: 2016-02-03 15:16 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
system tray with plasma breeze-dark theme and breeze (light) icon theme (3.85 KB, image/png)
2015-09-30 08:00 UTC, andreas
Details
ownCloud icon hardly visible (10.97 KB, image/png)
2015-12-21 09:00 UTC, Sudhir Khanger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas 2015-09-30 08:00:02 UTC
Hi, 

when you use the breeze dark plasma theme the plasma icons are light. But you can say I want to have only the plasma dark theme all other applications are breeze-light than you get an mix in the system tray by white icons from the plasma theme and dark icons from the icon theme.

You have the same problem when an application e.g. digikam change the color theme in his application to breeze dark and in all other applications it is breeze light the user get the wrong icons in digikam.

Is it possible that the application can choose which icon theme is needed? change the color scheme in digikam will change the icon theme too. same in plasma

Reproducible: Always
Comment 1 andreas 2015-09-30 08:00:47 UTC
Created attachment 94783 [details]
system tray with plasma breeze-dark theme and breeze (light) icon theme
Comment 2 David Edmundson 2015-10-01 06:50:01 UTC
*** Bug 353386 has been marked as a duplicate of this bug. ***
Comment 3 David Rosca 2015-11-21 08:07:41 UTC
It's now even worse with 5.16 plasma-framework, more icons went to Breeze-light variant (eg. configure icon in applets + krunner).

Maybe the monochrome icons in Breeze icons should be modified to also use stylesheets?
Comment 4 Marco Martin 2015-12-03 17:32:00 UTC
now the breeze icons themselves have the stylesheet info, so still needs testing, but all monochrome icons regardless where they come from, should be colored with theme colors
Comment 5 Sudhir Khanger 2015-12-21 09:00:05 UTC
Created attachment 96223 [details]
ownCloud icon hardly visible

Yep some of the system tray icons are hardly visible. For example ownCloud icon.
Comment 6 Viorel-Cătălin Răpițeanu 2015-12-28 20:58:01 UTC
Telepathy's system tray icon is displaying the Breeze Dark icon even if the Breeze theme is selected.
Comment 7 Marco Martin 2015-12-29 14:56:22 UTC
potential fix:
https://quickgit.kde.org/?p=plasma-framework.git&a=commit&h=3f56e63e706e299802df115be4bc52c3743760ba

(sorry, ended up mixed up with an unrelated commit)
Comment 8 David Rosca 2016-01-19 09:17:55 UTC
Git commit 5184ac94c916bf5e5e31d60db841c88009758a62 by David Rosca.
Committed on 19/01/2016 at 09:14.
Pushed by drosca into branch 'master'.

IconItem: Try to load QIcon::fromTheme icons as svg

When showing QIcons in IconItem, it would ignore stylesheet colors.
This tries to load QIcons created with QIcon::fromTheme as svg, by using
the icon name returned from QIcon::name.

REVIEW: 126792

M  +20   -14   src/declarativeimports/core/iconitem.cpp

http://commits.kde.org/plasma-framework/5184ac94c916bf5e5e31d60db841c88009758a62
Comment 9 Marco Martin 2016-02-03 14:52:00 UTC
now stylesheets get applied.
if wrong color icons happen again open a new bug (will probably be a bug of the individual icon)
Comment 10 andreas 2016-02-03 15:16:10 UTC
I'm not a big fan of the stylesheet stuff in the svg cause you have to look if all icons (>4.000) are correct and I can't test it. In addition the plasma theme generate the breeze dark icons from the breeze icons, in breeze-icons we ship both icon in the repository (additional maintanance). It's a mix between design and coding stuff and I thought we should separate it.

I would love to see an software solution for this like LibreOffice did. They change the lightness for the dark theme.

Breeze icon
RGB: 4d4d4d = HSL: 0 0 77

Breeze dark icon
L: 255 - 77 (breeze icon) = 178 (breeze dark icon)
HSL: 0 0 178 = RGB: b2b2b2

that's how LibreOffice generate the dark icons for breeze and sifr (same solution for all monochrome themes) and they only can use png files.