Bug 353091 - Cannot specify own periods for timer widget
Summary: Cannot specify own periods for timer widget
Status: RESOLVED FIXED
Alias: None
Product: kdeplasma-addons
Classification: Unclassified
Component: timer (show other bugs)
Version: unspecified
Platform: Other All
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 382350 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-23 15:34 UTC by dzert127
Modified: 2020-12-10 18:46 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.21


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dzert127 2015-09-23 15:34:18 UTC
I can only select predefined time periods for countdown. There should be option in settings to add own periods (as it was in KDE4 timer widget).

Reproducible: Always

Steps to Reproduce:
Open settings.

Actual Results:  
No option for creating own time periods.

Expected Results:  
Option for creating own timer periods.
Comment 1 Simone Gaiarin 2016-03-05 11:48:56 UTC
This should really be fixed, since it breaks the main functionality of the widget!

Moreover it should be possible to specify a time interval on the fly, without the need to open the settings and add a new item in the list.
Comment 2 dzert127 2016-03-05 12:37:47 UTC
You can specify time interval on the fly using mouse scroll on every digit and starting timer just by left button click.
But anyway I stay with statement that there should be functionality allowing to predefine own periods.
Comment 3 Simone Gaiarin 2016-03-06 07:27:28 UTC
Thanks. I've missed the tooltip informations
Comment 4 Christoph Feck 2017-07-17 18:23:20 UTC
*** Bug 382350 has been marked as a duplicate of this bug. ***
Comment 5 apache 2018-10-17 15:13:38 UTC
Can this finally be done, please. I know about mouse scroll but I prefer to add my own values as predefined.

In
contents/config/main.xml
I added time values but this doesn't work

Code: Select all
  <group name="General">
    <entry name="predefinedTimers" type="StringList">
        <default>30,60,120,180,240,300,360,420,480,540,600,660,720,780,840,900,960,1020,1080,1140,1200,1500,1800,2700,3600</default>
Comment 6 Nate Graham 2020-12-10 18:46:18 UTC
Git commit b93baf5da0f1e1d993cda906c4823d205d3cc525 by Nate Graham, on behalf of Łukasz Korbel.
Committed on 10/12/2020 at 18:46.
Pushed by ngraham into branch 'master'.

Add settings page for predefined timers

Add new page in settings of Timer applet for editing "predefined timers" values. Those values are used in context menu of the applet.
Related: bug 301861, bug 397841
FIXED-IN: 5.21

M  +5    -0    applets/timer/package/contents/config/config.qml
D  +0    -40   applets/timer/package/contents/ui/TimerDigit.qml
A  +162  -0    applets/timer/package/contents/ui/TimerEdit.qml     [License: GPL (v2+)]
M  +15   -68   applets/timer/package/contents/ui/TimerView.qml
A  +175  -0    applets/timer/package/contents/ui/configTimes.qml     [License: GPL (v2+)]
M  +13   -13   applets/timer/package/contents/ui/main.qml
M  +5    -0    applets/timer/plugin/timer.cpp
M  +5    -0    applets/timer/plugin/timer.h

https://invent.kde.org/plasma/kdeplasma-addons/commit/b93baf5da0f1e1d993cda906c4823d205d3cc525