Bug 353062 - Freeze/failure to start when "show tray icon" is enabled
Summary: Freeze/failure to start when "show tray icon" is enabled
Status: REOPENED
Alias: None
Product: frameworks-knotifications
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR crash
Target Milestone: ---
Assignee: Martin Klapetek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-22 21:40 UTC by gandalf3
Modified: 2022-11-29 20:18 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gandalf3 2015-09-22 21:40:40 UTC
Konversation goes into an infinite loop when "Enable System Tray" is enabled in Settings > Behaviour > General Behaviour.

Output:

XSync seems available and ready
XSync Inited
Supported, init completed
Created alarm 35651585
QSystemTrayIcon::setVisible: No Icon set
QSystemTrayIcon::setVisible: No Icon set
QSystemTrayIcon::setVisible: No Icon set
QSystemTrayIcon::setVisible: No Icon set
QSystemTrayIcon::setVisible: No Icon set
QSystemTrayIcon::setVisible: No Icon set
QSystemTrayIcon::setVisible: No Icon set
QSystemTrayIcon::setVisible: No Icon set
QSystemTrayIcon::setVisible: No Icon set
QSystemTrayIcon::setVisible: No Icon set
...
(repeats endlessly)

Note that I'm using openbox and tint2.

Reproducible: Always

Steps to Reproduce:
1. Start konversation
2. Enable Settings > Behaviour > General Behaviour > Enable System Tray

Actual Results:  
Konversation froze

Expected Results:  
Expected tray icon to appear in panel

I'm using openbox for my wm and tint2 as my panel.
Konversation worked fine in the past.
Comment 1 kedrot 2015-12-21 07:59:48 UTC
This seems to be happening with any KDE5 app with a tray icon and any system tray that is not plasmashell.

I have verified this bug with the following trays:

* Trayer
* Taffybar
* Stalonetray

and the following KDE5 programs:

* Kiten
* Klipper
* KWalletmanager5

However it does not affect KDE5 programs without tray icons

* Dolphin
* Systemsettings5

Nor KDE4 programs with tray icons

* Choqok
* Kopete
* Clementine
* KGPG

Nor GTK+ programs with tray icons

* Deluge

Probably related to https://bugs.kde.org/show_bug.cgi?id=355992
Comment 2 Florian Lindner 2015-12-21 08:10:52 UTC
I can confirm that using the new KF5 based KMail 5.1 and i3 as window manager.

However, I have eased that problem by setting QT_QPA_PLATFORMTHEME=qt5ct and installing qt5ct. Now I have a missing icon, but just a clickable space where KMail should be (with working tooltip info and context menu)
Comment 3 Martin Ueding 2016-01-05 15:48:36 UTC
I have the same problem with Klipper on Fedora 23 as I use Awesome WM.
Comment 4 Kakadu.hafanana 2016-06-14 20:11:07 UTC
It happens with akregator  too. I will  be glad if that could be fixed.
Comment 5 kedrot 2016-06-14 21:35:35 UTC
Kiten no longer loops forever; however, the "No icon set" message still appears (albeit only once). Still no icon shows up in other trays.

Is there a mechanism through which a QApplication/QWindow defines a default icon? Is this being skipped in these apps?
Comment 6 Kakadu.hafanana 2016-08-03 21:36:18 UTC
Folks, can we somehow raise priority of this bug?
Comment 7 godel9 2016-11-22 08:17:19 UTC
I have found one way to avoid the problem (I have tried it with xmonad and it works for opening  klipper). Just use in a terminal
 > export QT_QPA_PLATFORMTHEME=generic
before launching klipper
 > klipper
Comment 8 Jean-Michaël Celerier 2017-09-20 09:21:41 UTC
Getting the same bug for months when using

QT_QPA_PLATFORMTHEME=kde 

or 

QT_QPA_PLATFORMTHEME=plasma

Other themes such as QT_QPA_PLATFORMTHEME=plasma do work, but I'd really like to have the "plasma" platform theme (while keeping i3 as a window manager).
Comment 9 Tomasz Borowik 2020-10-26 04:33:43 UTC
+10 can't remember how many years I've been suffering this.
Using dwm + trayer on nixos, and this completely blocks various minor kde/qt applications from launching at all.

For me the QT_QPA_PLATFORMTHEME workaround doesn't work.
But this does: unset XDG_CURRENT_DESKTOP

Now if I remember correctly adding XDG_CURRENT_DESKTOP=kde somewhere was a workaround for some other failure, unfortunately can't remember what.

Soon we'll need a whole new system service for managing environment variable workarounds to launch any gui program;p
Comment 10 Tomasz Borowik 2020-10-26 04:38:05 UTC
(In reply to Tomasz Borowik from comment #9)
> Soon we'll need a whole new system service for managing environment variable
> workarounds to launch any gui program;p

Sorry for being snarky, posted mainly to mention the workaround in my case, not to just complain.
Comment 11 Justin Zobel 2022-10-30 00:40:32 UTC
Thank you for reporting this crash in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the crash with a recent software version?

If you can reproduce the issue, please change the status to "REPORTED" when replying. Thank you!
Comment 12 Bug Janitor Service 2022-11-14 05:14:45 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 13 Bug Janitor Service 2022-11-29 05:17:58 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!
Comment 14 Jean-Michaël Celerier 2022-11-29 20:17:49 UTC
I just tried again and it still goes into the infinite loop. 

     QT_QPA_PLATFORMTHEME=kde konversation

is enough to reproduce for me when its systray is enabled.

up-to-date archlinux
i3wm as a window manager
plasma 5.26
kde frameworks 5.100
konversation 22.08.3-1
Comment 15 Jean-Michaël Celerier 2022-11-29 20:18:04 UTC
Forgot to reopen sorry