Bug 353006 - KSysGuard crash on close
Summary: KSysGuard crash on close
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Mageia RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-09-21 19:59 UTC by fabsassolas
Modified: 2015-09-25 10:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fabsassolas 2015-09-21 19:59:11 UTC
Application: ksysguard (4.11.16)
KDE Platform Version: 4.14.5
Qt Version: 4.8.6
Operating System: Linux 3.19.8-desktop-3.mga5 x86_64
Distribution: "Mageia 5"

-- Information about the crash:
- What I was doing when the application crashed:
KSysGuard crashed when i close it. My computer has slowed down before KSG crashes.

-- Backtrace:
Application: Surveillance du système (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#5  0x00007f614697b1d4 in QWidget::sizePolicy() const () at /lib64/libQtGui.so.4
#6  0x00007f6146d32a08 in QLabelPrivate::updateLabel() () at /lib64/libQtGui.so.4
#7  0x00007f6146d33957 in QLabel::setText(QString const&) () at /lib64/libQtGui.so.4
#8  0x00007f6130d4d7cb in TopLevel::answerReceived(int, QList<QByteArray> const&) () at /usr/lib64/libkdeinit4_ksysguard.so
#9  0x00007f613067eb4c in KSGRD::SensorAgent::processAnswer(char const*, int) () at /lib64/libksgrd.so.4
#10 0x00007f613068602e in KSGRD::SensorShellAgent::msgRcvd() () at /lib64/libksgrd.so.4
#11 0x00007f61477d888a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () at /lib64/libQtCore.so.4
#12 0x00007f6147758dca in QProcessPrivate::_q_canReadStandardOutput() () at /lib64/libQtCore.so.4
#13 0x00007f614775b599 in QProcess::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) [clone .part.26] () at /lib64/libQtCore.so.4
#14 0x00007f61477d888a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () at /lib64/libQtCore.so.4
#15 0x00007f6147822d3e in QSocketNotifier::activated(int) () at /lib64/libQtCore.so.4
#16 0x00007f61477e151b in QSocketNotifier::event(QEvent*) () at /lib64/libQtCore.so.4
#17 0x00007f614693c79c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /lib64/libQtGui.so.4
#18 0x00007f6146942e40 in QApplication::notify(QObject*, QEvent*) () at /lib64/libQtGui.so.4
#19 0x00007f614858a25a in KApplication::notify(QObject*, QEvent*) () at /lib64/libkdeui.so.5
#20 0x00007f61477c4cad in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /lib64/libQtCore.so.4
#21 0x00007f61477f2418 in socketNotifierSourceDispatch(_GSource*, int (*)(void*), void*) () at /lib64/libQtCore.so.4
#22 0x00007f6143287c6d in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
#23 0x00007f6143287f18 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#24 0x00007f6143287fbc in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#25 0x00007f61477f1e1e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#26 0x00007f61469da4f6 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtGui.so.4
#27 0x00007f61477c3931 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#28 0x00007f61477c3c45 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#29 0x00007f61477c8e59 in QCoreApplication::exec() () at /lib64/libQtCore.so.4
#30 0x00007f6130d4f535 in kdemain () at /usr/lib64/libkdeinit4_ksysguard.so
#31 0x000000000040819a in launch(int, char const*, char const*, char const*, int, char const*, bool, char const*, bool, char const*) ()
#32 0x0000000000409021 in handle_launcher_request(int, char const*) [clone .isra.15] ()
#33 0x000000000040972a in handle_requests(int) ()
#34 0x0000000000405303 in main ()

The reporter indicates this bug may be a duplicate of or related to bug 350140.

Possible duplicates by query: bug 350140.

Reported using DrKonqi
Comment 1 Christoph Feck 2015-09-25 10:41:08 UTC

*** This bug has been marked as a duplicate of bug 350140 ***