Bug 352810 - Control keys on the numpad not working
Summary: Control keys on the numpad not working
Status: RESOLVED DUPLICATE of bug 345504
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: 5.0.0
Platform: Ubuntu Linux
: NOR major (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-16 18:30 UTC by Lastique
Modified: 2015-09-16 19:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lastique 2015-09-16 18:30:16 UTC
Kate does not react to numpad keys when Num Lock is off. I.e. when I press 1 (End) or 7 (Home) the cursor doesn't move, pressing . (Delete) does not delete a character. The keys work in other applications, like Konsole, Firefox or Chrome. xev also reacts to keypresses. Here is an example of pressing .:

KeyPress event, serial 40, synthetic NO, window 0x7200001,
    root 0xd6, subw 0x0, time 56687402, (-950,1019), root:(421,1076),
    state 0x0, keycode 91 (keysym 0xff9f, KP_Delete), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 40, synthetic NO, window 0x7200001,
    root 0xd6, subw 0x0, time 56687551, (-950,1019), root:(421,1076),
    state 0x0, keycode 91 (keysym 0xff9f, KP_Delete), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

Numpad keys are essential on some laptop keyboards, where normal keys are harder to reach.


Reproducible: Always

Steps to Reproduce:
1. Open a file in Kate.
2. Try pressing NumPad keys.


Actual Results:  
Kate does not react to keypresses.

Expected Results:  
Keypresses should be treated similarly to regular keys (Home, End, PgUp, PgDown, Delete, etc.)
Comment 1 Kåre Särs 2015-09-16 19:41:38 UTC

*** This bug has been marked as a duplicate of bug 345504 ***