Bug 352644 - FTP shares exported by eShare app on Android are inaccessible from Dolphin with "Could not enter folder ." error message
Summary: FTP shares exported by eShare app on Android are inaccessible from Dolphin wi...
Status: RESOLVED WORKSFORME
Alias: None
Product: kio-extras
Classification: Unclassified
Component: SFTP (show other bugs)
Version: 18.04.3
Platform: Fedora RPMs Linux
: NOR major
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2015-09-13 08:39 UTC by Syam
Modified: 2018-10-29 02:13 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Syam 2015-09-13 08:39:32 UTC
I have eShare (https://play.google.com/store/apps/details?id=com.domobile.eshare) app installed on Android. The app creates an FTP share accessible on the local LAN. I am able to access this FTP site from Firefox or Opera, but not from Dolphin or Konqueror.

When I access the FTP address from Dolphin (eg: ftp://192.168.0.3:6262), I get the login window (if I have configured eShare to ask for login, otherwise I don't) and after entering the password, Dolphin gives me the error: "Could not enter folder .".
Konqueror has the same behaviour.

Reproducible: Always

Steps to Reproduce:
1. Install eShare on your android phone
2. Start eShare and enable sharing
3. Type the provided FTP address in Dolphin address bar on your computer

Actual Results:  
Dolphin gives error message "Could not enter folder ."
Comment 1 Syam 2015-09-13 08:46:19 UTC
I have KDE on Fedora 22 (x86_64).
"About Dolphin" says "Version 15.04.0 Using KDE Development Platform 4.14.9"
Comment 2 Syam 2015-09-13 14:42:50 UTC
Just tested with FileZilla. Everything seems to work - connection, upload & download.
I'm adding the message log from FileZilla, in case it's helpful:

Status:	Connecting to 192.168.0.3:6262...
Status:	Connection established, waiting for welcome message...
Status:	Insecure server, it does not support FTP over TLS.
Status:	Server does not support non-ASCII characters.
Status:	Connected
Status:	Retrieving directory listing...
Status:	Directory listing of "/" successful
Comment 3 Syam 2016-05-31 01:41:56 UTC
Can somebody please take a look at this. If I need to do something to provide more debug info,  do let me know.
Comment 4 David Faure 2016-06-14 14:45:40 UTC
Next step is to get debug output from kio_ftp. Can you follow the instructions at https://techbase.kde.org/Development/Tutorials/Debugging/Debugging_IOSlaves#GUI_.28Qt4.2Fkdelibs4_instructions.29 to get that output?
Comment 5 Syam 2016-06-14 18:00:01 UTC
I followed the instructions, and this is what comes up in ~/.xsession-errors:

kf5.kinit.klauncher: KLauncher: launching new slave "/usr/lib64/qt5/plugins/kf5/kio/ftp.so" with protocol= "ftp" args= ("ftp", "local:/run/user/1000/klauncherXM4514.1.slave-socket", "local:/run/user/1000/dolphinBC5940.4.slave-socket")
kf5.kinit.klauncher: "/usr/lib64/qt5/plugins/kf5/kio/ftp.so" (pid 5961) up and running.
error() called twice! Please fix the KIO slave.
Can't open for listing
error() called twice! Please fix the KIO slave.
kf5.kservice.sycoca: checking file timestamps
org.kde.kurifilter-shorturi: "ftp://192.168.0.3:6262"
org.kde.kurifilter-shorturi: path = ""  isLocalFullPath= false  exists= false  url= QUrl("ftp://192.168.0.3:6262")
org.kde.kurifilter-ikws: "ftp://192.168.0.3:6262" : QUrl("ftp://192.168.0.3:6262") , type = 0
kf5.kinit.klauncher: KLauncher: launching new slave "/usr/lib64/qt5/plugins/kf5/kio/ftp.so" with protocol= "ftp" args= ("ftp", "local:/run/user/1000/klauncherXM4514.1.slave-socket", "local:/run/user/1000/dolphinHf5940.5.slave-socket")
kf5.kinit.klauncher: "/usr/lib64/qt5/plugins/kf5/kio/ftp.so" (pid 5966) up and running.
error() called twice! Please fix the KIO slave.
Can't open for listing
error() called twice! Please fix the KIO slave.
Comment 6 David Faure 2016-06-14 20:55:06 UTC
Oh, you're now using KF5, I didn't notice that the "Using KDE Development Platform 4.14.9" version info was from September 2015 :-)

kio_ftp had debug output disabled in KF5, I only re-enabled it today (due to this report) so it'll be in KF 5.24 -- another month before we can get more debug output, unless you feel like compiling KIO from git.
Comment 7 Nate Graham 2018-07-20 21:27:14 UTC
Does this still happen with KDE Frameworks 5.48?
Comment 8 Andrew Crouthamel 2018-09-28 03:39:00 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 9 Andrew Crouthamel 2018-10-29 02:13:27 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!