Bug 352607 - Make install fails because of missing appdata file
Summary: Make install fails because of missing appdata file
Status: RESOLVED FIXED
Alias: None
Product: umbrello
Classification: Unclassified
Component: general (show other bugs)
Version: Git
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Umbrello Development Group
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-12 08:56 UTC by Antonio Rojas
Modified: 2015-09-15 14:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.17.2 (KDE Applications 15.08.2)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Rojas 2015-09-12 08:56:51 UTC
15.08.1 version (built against KF5) fails to install because the file org.kde.umbrello.appdata.xml is missing

CMake Error at umbrello/cmake_install.cmake:56 (file):
  file INSTALL cannot find
  "/build/umbrello/src/umbrello-15.08.1/umbrello/org.kde.umbrello.appdata.xml".


Reproducible: Always
Comment 2 Ralf Habacker 2015-09-12 10:30:58 UTC
Git commit 70ecfc71c7bf6400560b964d8ed9dfaf2a6abb57 by Ralf Habacker, on behalf of Matthias Klumpp.
Committed on 12/09/2015 at 10:19.
Pushed by habacker into branch 'Applications/15.08'.

Add AppStream metadata

(cherry picked from commit fa2014c9d3edb2cb144bc9f5f0edafa789c2975c)

Conflicts:
	umbrello/CMakeLists.txt

A  +32   -0    umbrello/org.kde.umbrello.appdata.xml

http://commits.kde.org/umbrello/70ecfc71c7bf6400560b964d8ed9dfaf2a6abb57
Comment 3 Ralf Habacker 2015-09-12 10:33:55 UTC
I did not add the version-field field because it is currently unknown if this patch could be added into recent 15.08.1, otherwise this will be fixed in 15.08.2.
Comment 4 Ralf Habacker 2015-09-15 14:54:28 UTC
15.08.1 is out, so this bug is fixed in 15.08.2