Bug 352294 - plasmashell crashes during login consistently
Summary: plasmashell crashes during login consistently
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.4.0
Platform: Fedora RPMs Linux
: NOR grave
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
: 348468 352741 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-09-04 22:49 UTC by David H. Gutteridge
Modified: 2015-10-08 16:15 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David H. Gutteridge 2015-09-04 22:49:37 UTC
Since upgrading to 5.4.0 packages in Fedora 22's testing repository, I cannot get Plasma to start, it consistently crashes during start up, immediately after the progress bar splash screen gets to 100%. (The bug submission assistant claimed this was a duplicate of 348468, but I don't see how it can be. I did look for other bugs, but couldn't find anything identical to this. My apologies if it's a duplicate.)

Reproducible: Always

Steps to Reproduce:
1. Initiate a Plasma session from the login screen.
2. Crash happens immediately after the splash screen.


Actual Results:  
The crash assistant pops up. If I try to restart the application, it simply crashes again and spawns another crash assistant window.

Expected Results:  
Run a Plasma session.

Application: plasmashell (5.4.0)

Qt Version: 5.5.0
Operating System: Linux 4.1.6-200.fc22.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fcf81329900 (LWP 2871))]

Thread 7 (Thread 0x7fcf61357700 (LWP 2873)):
#0  0x00007fcf78d2e2fd in poll () from /lib64/libc.so.6
#1  0x00007fcf7f173182 in _xcb_conn_wait () from /lib64/libxcb.so.1
#2  0x00007fcf7f174c77 in xcb_wait_for_event () from /lib64/libxcb.so.1
#3  0x00007fcf632d7999 in QXcbEventReader::run() () from /lib64/libQt5XcbQpa.so.5
#4  0x00007fcf7993a54e in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#5  0x00007fcf779dc555 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fcf78d39b9d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7fcf5ab0c700 (LWP 2875)):
#0  0x00007fcf78d29fad in read () from /lib64/libc.so.6
#1  0x00007fcf73f26b00 in g_wakeup_acknowledge () from /lib64/libglib-2.0.so.0
#2  0x00007fcf73ee28b4 in g_main_context_check () from /lib64/libglib-2.0.so.0
#3  0x00007fcf73ee2d60 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#4  0x00007fcf73ee2ecc in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#5  0x00007fcf79b71dab in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#6  0x00007fcf79b18daa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#7  0x00007fcf799355a4 in QThread::exec() () from /lib64/libQt5Core.so.5
#8  0x00007fcf7dc09245 in QQmlThreadPrivate::run() () from /lib64/libQt5Qml.so.5
#9  0x00007fcf7993a54e in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#10 0x00007fcf779dc555 in start_thread () from /lib64/libpthread.so.0
#11 0x00007fcf78d39b9d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fcf58cf3700 (LWP 2876)):
#0  0x00007fcf78d2e2fd in poll () from /lib64/libc.so.6
#1  0x00007fcf73ee2dbc in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#2  0x00007fcf73ee2ecc in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fcf79b71dab in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#4  0x00007fcf79b18daa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#5  0x00007fcf799355a4 in QThread::exec() () from /lib64/libQt5Core.so.5
#6  0x00007fcf7dc09245 in QQmlThreadPrivate::run() () from /lib64/libQt5Qml.so.5
#7  0x00007fcf7993a54e in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#8  0x00007fcf779dc555 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fcf78d39b9d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fcf52faa700 (LWP 2879)):
#0  0x00007fcf78d29fad in read () from /lib64/libc.so.6
#1  0x00007fcf73f26b00 in g_wakeup_acknowledge () from /lib64/libglib-2.0.so.0
#2  0x00007fcf73ee28b4 in g_main_context_check () from /lib64/libglib-2.0.so.0
#3  0x00007fcf73ee2d60 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#4  0x00007fcf73ee2ecc in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#5  0x00007fcf79b71dab in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#6  0x00007fcf79b18daa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#7  0x00007fcf799355a4 in QThread::exec() () from /lib64/libQt5Core.so.5
#8  0x00007fcf7dc09245 in QQmlThreadPrivate::run() () from /lib64/libQt5Qml.so.5
#9  0x00007fcf7993a54e in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#10 0x00007fcf779dc555 in start_thread () from /lib64/libpthread.so.0
#11 0x00007fcf78d39b9d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fcf516cc700 (LWP 2880)):
#0  0x00007fcf779e1540 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fcf80a45494 in QTWTF::TCMalloc_PageHeap::scavengerThread() () from /lib64/libQt5Script.so.5
#2  0x00007fcf80a454d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /lib64/libQt5Script.so.5
#3  0x00007fcf779dc555 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fcf78d39b9d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fcec3eed700 (LWP 2881)):
#0  0x00007fcf73f27ec9 in g_mutex_lock () from /lib64/libglib-2.0.so.0
#1  0x00007fcf73ee2da2 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#2  0x00007fcf73ee2ecc in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fcf79b71dab in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#4  0x00007fcf79b18daa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#5  0x00007fcf799355a4 in QThread::exec() () from /lib64/libQt5Core.so.5
#6  0x00007fcf7e7ac616 in QQuickPixmapReader::run() () from /lib64/libQt5Quick.so.5
#7  0x00007fcf7993a54e in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#8  0x00007fcf779dc555 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fcf78d39b9d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fcf81329900 (LWP 2871)):
[KCrash Handler]
#5  0x00007fcf79b521f0 in QObject::setParent(QObject*) () from /lib64/libQt5Core.so.5
#6  0x00007fcec06153be in SystemTray::PlasmoidTask::PlasmoidTask(QString const&, int, Plasma::Containment*, QObject*) () from /usr/lib64/qt5/qml/org/kde/private/systemtray/libsystemtrayplugin.so
#7  0x00007fcec0617c50 in SystemTray::PlasmoidProtocol::newTask(QString const&) () from /usr/lib64/qt5/qml/org/kde/private/systemtray/libsystemtrayplugin.so
#8  0x00007fcec061d18b in SystemTray::PlasmoidProtocol::restorePlasmoids() () from /usr/lib64/qt5/qml/org/kde/private/systemtray/libsystemtrayplugin.so
#9  0x00007fcec061e07a in SystemTray::PlasmoidProtocol::init() () from /usr/lib64/qt5/qml/org/kde/private/systemtray/libsystemtrayplugin.so
#10 0x00007fcec0609180 in SystemTray::Host::init() () from /usr/lib64/qt5/qml/org/kde/private/systemtray/libsystemtrayplugin.so
#11 0x00007fcec0621605 in SystemTray::Host::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib64/qt5/qml/org/kde/private/systemtray/libsystemtrayplugin.so
#12 0x00007fcf79b4b021 in QObject::event(QEvent*) () from /lib64/libQt5Core.so.5
#13 0x00007fcf7b0d14ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#14 0x00007fcf7b0d6976 in QApplication::notify(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#15 0x00007fcf79b1b61b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#16 0x00007fcf79b1da16 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib64/libQt5Core.so.5
#17 0x00007fcf79b71983 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5Core.so.5
#18 0x00007fcf73ee2a8a in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#19 0x00007fcf73ee2e20 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#20 0x00007fcf73ee2ecc in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#21 0x00007fcf79b71d8f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#22 0x00007fcf79b18daa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#23 0x00007fcf79b20e6c in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#24 0x0000000000430143 in main ()
Comment 1 David Edmundson 2015-09-04 22:56:46 UTC
Weird, we had a duplicate with this exact trace

https://bugs.kde.org/show_bug.cgi?id=348468

then the reporter said it magically fixed itself and we stopped looking.


Could you run plasmashell from a konsole window and include the output.
Comment 2 David Edmundson 2015-09-04 23:06:06 UTC
Oh, it's pretty obvious where the crash is. I'll fix it for 5.4.2

    m_applet = Plasma::PluginLoader::self()->loadApplet(packageName, appletId);
we don't check the reply, so if you have an invalid applet, we're gonna crash exactly there.

Implies you either have a stray .desktop file from an old install you shouldn't have or your config references a plasmoid that no longer exists.

Hopefully output above should tell us
When you run plasmashell from a terminal could you run
QT_LOGGING_RULES=systemtray.*=true plasmashell
Comment 3 David Edmundson 2015-09-04 23:07:45 UTC
*** Bug 348468 has been marked as a duplicate of this bug. ***
Comment 4 David H. Gutteridge 2015-09-04 23:18:39 UTC
Ah, sorry, that was for an older version of plasmashell, and it was closed, so I assumed it differed somehow. I guess not.

I didn't have any desktop available to work with, all I have is a black screen and a DrKonqi window, but I figured out I could spawn a terminal using the gdb debug option of DrKonqi. So, what we get is this:

[disciple@arcusix ~]$ plasmashell
"file:///usr/share/plasma/look-and-feel/org.fedoraproject.fedora.twenty.two/contents/osd/Osd.qml" 
 "Error loading QML file.
43: "PlasmaCore.Dialog.opacity" is not available in org.kde.plasma.core 2.0.
"
Failed to load OSD QML file
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/main.qml:37: TypeError: Cannot read property 'DateTime' of undefined
Known plasmoid ids: QHash(("org.kde.plasma.bluetooth", 16)("org.kde.plasma.battery", 14)("org.kde.plasma.clipboard", 9)("org.kde.plasma.pkupdates", 13)("org.kde.plasma.printmanager", 12)("org.kde.plasma.notifications", 11)("org.kde.plasma.devicenotifier", 10)("org.kde.plasma.networkmanagement", 15)("org.kde.plasma.mediacontroller", 17))
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
Application::crashHandler() called with signal 11; recent crashes: 1
/usr/bin/plasmashell  --crashes 1 &
KCrash: Application 'plasmashell' crashing...
"file:///usr/share/plasma/look-and-feel/org.fedoraproject.fedora.twenty.two/contents/osd/Osd.qml" 
 "Error loading QML file.
43: "PlasmaCore.Dialog.opacity" is not available in org.kde.plasma.core 2.0.
"
Failed to load OSD QML file
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/main.qml:37: TypeError: Cannot read property 'DateTime' of undefined
Known plasmoid ids: QHash(("org.kde.plasma.printmanager", 12)("org.kde.plasma.mediacontroller", 17)("org.kde.plasma.devicenotifier", 10)("org.kde.plasma.notifications", 11)("org.kde.plasma.bluetooth", 16)("org.kde.plasma.pkupdates", 13)("org.kde.plasma.battery", 14)("org.kde.plasma.clipboard", 9)("org.kde.plasma.networkmanagement", 15))
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
Application::crashHandler() called with signal 11; recent crashes: 2
/usr/bin/plasmashell  --crashes 2 &
KCrash: Application 'plasmashell' crashing...
"file:///usr/share/plasma/look-and-feel/org.fedoraproject.fedora.twenty.two/contents/osd/Osd.qml" 
 "Error loading QML file.
43: "PlasmaCore.Dialog.opacity" is not available in org.kde.plasma.core 2.0.
"
Failed to load OSD QML file
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
Segmentation fault (core dumped)
[disciple@arcusix ~]$ file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/main.qml:37: TypeError: Cannot read property 'DateTime' of undefined
Known plasmoid ids: QHash(("org.kde.plasma.devicenotifier", 10)("org.kde.plasma.pkupdates", 13)("org.kde.plasma.networkmanagement", 15)("org.kde.plasma.mediacontroller", 17)("org.kde.plasma.clipboard", 9)("org.kde.plasma.printmanager", 12)("org.kde.plasma.battery", 14)("org.kde.plasma.bluetooth", 16)("org.kde.plasma.notifications", 11))
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
Application::crashHandler() called with signal 11; recent crashes: 3
/usr/bin/plasmashell  --crashes 3 &
Too many crashes in short order or respawning disabled, not restarting automatically.
KCrash: Application 'plasmashell' crashing...
Comment 5 David Edmundson 2015-09-04 23:23:18 UTC
One more command (sorry!)

 plasmapkg2 -t Plasma/Applet --list
Comment 6 David H. Gutteridge 2015-09-04 23:34:34 UTC
With "QT_LOGGING_RULES=systemtray.*=true plasmashell" in konsole, the output is slightly different in the "Known plasmoid ids:" lines:

[disciple@arcusix ~]$ QT_LOGGING_RULES=systemtray.*=true plasmashell
"file:///usr/share/plasma/look-and-feel/org.fedoraproject.fedora.twenty.two/contents/osd/Osd.qml" 
 "Error loading QML file.
43: "PlasmaCore.Dialog.opacity" is not available in org.kde.plasma.core 2.0.
"
Failed to load OSD QML file
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/main.qml:37: TypeError: Cannot read property 'DateTime' of undefined
Known plasmoid ids: QHash(("org.kde.plasma.pkupdates", 13)("org.kde.plasma.battery", 14)("org.kde.plasma.devicenotifier", 10)("org.kde.plasma.printmanager", 12)("org.kde.plasma.networkmanagement", 15)("org.kde.plasma.mediacontroller", 17)("org.kde.plasma.notifications", 11)("org.kde.plasma.clipboard", 9)("org.kde.plasma.bluetooth", 16))
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
Application::crashHandler() called with signal 11; recent crashes: 1
/usr/bin/plasmashell  --crashes 1 &
KCrash: Application 'plasmashell' crashing...
"file:///usr/share/plasma/look-and-feel/org.fedoraproject.fedora.twenty.two/contents/osd/Osd.qml" 
 "Error loading QML file.
43: "PlasmaCore.Dialog.opacity" is not available in org.kde.plasma.core 2.0.
"
Failed to load OSD QML file
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/main.qml:37: TypeError: Cannot read property 'DateTime' of undefined
Known plasmoid ids: QHash(("org.kde.plasma.pkupdates", 13)("org.kde.plasma.clipboard", 9)("org.kde.plasma.networkmanagement", 15)("org.kde.plasma.battery", 14)("org.kde.plasma.printmanager", 12)("org.kde.plasma.devicenotifier", 10)("org.kde.plasma.mediacontroller", 17)("org.kde.plasma.notifications", 11)("org.kde.plasma.bluetooth", 16))
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
Application::crashHandler() called with signal 11; recent crashes: 2
/usr/bin/plasmashell  --crashes 2 &
KCrash: Application 'plasmashell' crashing...
"file:///usr/share/plasma/look-and-feel/org.fedoraproject.fedora.twenty.two/contents/osd/Osd.qml" 
 "Error loading QML file.
43: "PlasmaCore.Dialog.opacity" is not available in org.kde.plasma.core 2.0.
"
Failed to load OSD QML file
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
Segmentation fault (core dumped)
[disciple@arcusix ~]$ file:///usr/share/plasma/plasmoids/org.kde.plasma.digitalclock/contents/ui/main.qml:37: TypeError: Cannot read property 'DateTime' of undefined
Known plasmoid ids: QHash(("org.kde.plasma.notifications", 11)("org.kde.plasma.clipboard", 9)("org.kde.plasma.pkupdates", 13)("org.kde.plasma.mediacontroller", 17)("org.kde.plasma.printmanager", 12)("org.kde.plasma.battery", 14)("org.kde.plasma.devicenotifier", 10)("org.kde.plasma.networkmanagement", 15)("org.kde.plasma.bluetooth", 16))
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
unversioned plugin detected, may result in instability
Application::crashHandler() called with signal 11; recent crashes: 3
/usr/bin/plasmashell  --crashes 3 &
Too many crashes in short order or respawning disabled, not restarting automatically.
KCrash: Application 'plasmashell' crashing...
Comment 7 David H. Gutteridge 2015-09-04 23:43:17 UTC
Next command:

[disciple@arcusix ~]$ plasmapkg2 -t Plasma/Applet --list
Listing service types: Plasma/Applet
org.kde.desktopcontainment
org.kde.milou
org.kde.panel
org.kde.plasma.activitybar
org.kde.plasma.analogclock
org.kde.plasma.battery
org.kde.plasma.bluetooth
org.kde.plasma.calculator
org.kde.plasma.calendar
org.kde.plasma.clipboard
org.kde.plasma.comic
org.kde.plasma.devicenotifier
org.kde.plasma.digitalclock
org.kde.plasma.fifteenpuzzle
org.kde.plasma.folder
org.kde.plasma.fuzzyclock
org.kde.plasma.icon
org.kde.plasma.icontasks
org.kde.plasma.katesessions
org.kde.plasma.kicker
org.kde.plasma.kickerdash
org.kde.plasma.kickoff
org.kde.plasma.kimpanel
org.kde.plasma.konsoleprofiles
org.kde.plasma.lock_logout
org.kde.plasma.mediacontroller
org.kde.plasma.networkmanagement
org.kde.plasma.notes
org.kde.plasma.notifications
org.kde.plasma.pager
org.kde.plasma.panelspacer
org.kde.plasma.pkupdates
org.kde.plasma.printmanager
org.kde.plasma.showActivityManager
org.kde.plasma.showdesktop
org.kde.plasma.systemloadviewer
org.kde.plasma.systemmonitor.cpu
org.kde.plasma.systemmonitor.diskactivity
org.kde.plasma.systemmonitor.diskusage
org.kde.plasma.systemmonitor.memory
org.kde.plasma.systemmonitor.net
org.kde.plasma.systemtray
org.kde.plasma.taskmanager
org.kde.plasma.timer
org.kde.plasma.trash
org.kde.plasma.volume
org.kde.plasma.webbrowser
org.kde.plasma.windowlist
touchpad
Comment 8 David Edmundson 2015-09-04 23:48:05 UTC
Thanks ever so much

Patch is in review, in the meantime if you move your ~/.config/plasma-org.kde.plasma.desktop-appletsrc I /think/ it might startup
Comment 9 Bhushan Shah 2015-09-05 04:12:15 UTC
"file:///usr/share/plasma/look-and-feel/org.fedoraproject.fedora.twenty.two/contents/osd/Osd.qml" 
 "Error loading QML file.
43: "PlasmaCore.Dialog.opacity" is not available in org.kde.plasma.core 2.0.
"

You will require newer version of plasma-framework. Please upgrade or report to your distro
Comment 10 Bhushan Shah 2015-09-05 04:13:33 UTC
Or well, still backtrace you mentioned first is valid.. reopening
Comment 11 David Edmundson 2015-09-05 10:15:40 UTC
Git commit e572ec1cb2e0fb4467cdb2e68f4ac2e7341b75bb by David Edmundson.
Committed on 05/09/2015 at 10:15.
Pushed by davidedmundson into branch 'Plasma/5.4'.

Fix crash if trying to load an invalid applet in systray
REVIEW: 125053

M  +8    -1    applets/systemtray/plugin/protocols/plasmoid/plasmoidtask.cpp

http://commits.kde.org/plasma-workspace/e572ec1cb2e0fb4467cdb2e68f4ac2e7341b75bb
Comment 12 David H. Gutteridge 2015-09-10 20:29:09 UTC
In case this is relevant for anyone else, the cause of this was as Bhushan Shah noted: the Fedora packages that updated Plasma to 5.4 didn't note a dependency upon Frameworks 5.13. With updates to the latter applied, this issue resolved itself. I think it's likely the older bug this is related to had the same cause from the previous round of updates to these two component groups.

Thanks for your very quick response and resolution.
Comment 13 David Edmundson 2015-09-15 12:19:29 UTC
*** Bug 352741 has been marked as a duplicate of this bug. ***