Bug 352205 - shortcut ctrl+w cannot be reassigned from default action
Summary: shortcut ctrl+w cannot be reassigned from default action
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Shortcuts and Canvas Input Settings (show other bugs)
Version: 2.9.7
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-03 08:23 UTC by truekikim
Modified: 2018-09-24 07:24 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description truekikim 2015-09-03 08:23:20 UTC
Even when I delete the shortcut ctrl+w from action "close" it still closes the window.

Reproducible: Always
Comment 1 Halla Rempt 2015-09-05 12:28:50 UTC
That is "interesting"...
Comment 2 Halla Rempt 2015-09-05 12:37:31 UTC
I think I have to postpone this to 3.0, when we'll drop KDE's shortcut handling. There's something really fishy going on:

* by default, ctrl-w is not set for file_close.
* if I set ctrl-w to, for instance About KDE, KDE complains about a duplicate shortcut, but the dialog doesn't show another action with the ctrl-w shortcut.
Comment 3 1DrawingPerDay 2016-04-30 13:01:09 UTC
Something similar happens with this shortcut in Krita 3.0 Beta (git 4a58260)

I get the message: 
"The key sequence 'Ctrl+W' is ambiguous. Use 'Configure Shortcuts' from the 'Settings' menu to solve the ambiguity. No action will be triggered."

There is no other action triggered by this shortcut and if I change it to something else like Ctrl+1 it works but if revert it to Ctrl+W Krita throws the same message again.

Kind of bizarre...
Comment 4 Michael 2016-06-25 12:51:12 UTC
The shortcuts for "Standard Actions" like open, save, copy, paste use an older configuration system which isn't playing nicely with Krita's shortcut management. 

Should look into KisActionManager::createStandardAction here...
Comment 5 Halla Rempt 2018-09-18 11:32:41 UTC
Git commit 36861ec3b2608893a5c624560e5d3302bda19c31 by Boudewijn Rempt.
Committed on 18/09/2018 at 11:30.
Pushed by rempt into branch 'master'.

Remove the shortcuts from the mdi window's system menu's actions

Just changing the scope isn't enough: people also want to be
able to configure the the close window action. Fortunately,
that turns out to be quite possible.
Related: bug 375524, bug 398729

M  +8    -8    libs/ui/KisMainWindow.cpp

https://commits.kde.org/krita/36861ec3b2608893a5c624560e5d3302bda19c31
Comment 6 Halla Rempt 2018-09-24 07:24:43 UTC
Git commit 7de91a765bb10fe4c55ef851bd157177618a8171 by Boudewijn Rempt.
Committed on 24/09/2018 at 06:57.
Pushed by rempt into branch 'krita/4.1'.

Remove the shortcuts from the mdi window's system menu's actions

Just changing the scope isn't enough: people also want to be
able to configure the the close window action. Fortunately,
that turns out to be quite possible.
Related: bug 375524, bug 398729

M  +8    -8    libs/ui/KisMainWindow.cpp

https://commits.kde.org/krita/7de91a765bb10fe4c55ef851bd157177618a8171