Bug 352204 - plasmashell 5.4 hangs inside KVM VM when host window is shrinked
Summary: plasmashell 5.4 hangs inside KVM VM when host window is shrinked
Status: RESOLVED WORKSFORME
Alias: None
Product: plasmashell
Classification: Plasma
Component: general (show other bugs)
Version: 5.4.0
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-03 07:45 UTC by OlafLostViking
Modified: 2020-11-24 04:34 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
kquitapp5 plasmashell; sleep 3; plasmashell 2>> plasmashell.err (8.05 KB, text/plain)
2015-09-03 07:45 UTC, OlafLostViking
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OlafLostViking 2015-09-03 07:45:30 UTC
Created attachment 94365 [details]
kquitapp5 plasmashell; sleep 3; plasmashell 2>> plasmashell.err

I'm running an up-to-date Archlinux amd64 installation with KF5, Applications 15.08 and plasma 5.4 in a libvirt created KVM VM with qxl/spice and vdagent.

When enlargening the viewer window on the host, plasma adapts to the new resolution and the desktop uses a higher resolution. But when shrinking the window, the desktop turns black (only plasma, other applications as well as kwin handle it fine and continue working). The plasmashell process is still running. Killing and restarting it brings back a working shell.

The configuration is basically standard (just added IM applet). No KDE4 has ever been installed in this VM. Creating a new user in the VM (to clear any config) shows the same result.
Comment 1 David Edmundson 2015-09-03 08:14:48 UTC
If it's crashing we should get a drkonqui window which has a backtrace, could you attach it please.
Comment 2 OlafLostViking 2015-09-03 09:04:45 UTC
It's not crashing (so no backtrace). The process is still running after "visually disappearing". It reacts to a SIGTERM (no need for SIGKILL). Also, the signal handler still writes "User defined signal 1" to the console if I send a SIGUSR1 to the process.

While playing around with timing: when I shrink the window after the wallpaper has already been painted but the panel is still loading, it isn't turning black but continues loading (including correctly scaling the wallpaper in the end). However, removing the panel, restarting plasmashell and shrinking after that still leads to a black screen.

I could send you a ltrace and/or strace of the starting/resizing/"hanging"/killing cycle if you think that could help.
Comment 3 Justin Zobel 2020-10-25 08:59:01 UTC
Is this behavior still present in current Plasma versions?
Comment 4 Bug Janitor Service 2020-11-09 04:33:40 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Bug Janitor Service 2020-11-24 04:34:05 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!