Bug 351737 - kdeinit - can't start /usr/lib/kf5/kioexec
Summary: kdeinit - can't start /usr/lib/kf5/kioexec
Status: RESOLVED DUPLICATE of bug 353037
Alias: None
Product: frameworks-kcoreaddons
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Arch Linux Linux
: NOR normal
Target Milestone: ---
Assignee: Michael Pyne
Depends on:
Reported: 2015-08-25 05:06 UTC by piedro
Modified: 2015-12-16 02:41 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description piedro 2015-08-25 05:06:00 UTC
Saving a file with a program creates this message, kioexec is present at the location... 

Reproducible: Always
Comment 1 Philipp A. 2015-08-31 10:30:19 UTC
For me this happens when opening a .tsv file on a remote server. I have assigned .tsv files to libreoffice calc.

When i click one such file it gets downloaded to a tmp dir, and opened with calc. Only problem is: dolphin freezes for ~5 min before becoming responsive again and showing the “kdeinit - can't start /usr/lib/kf5/kioexec” dialog

bug 343329 might be related
Comment 2 Elliott Seyler 2015-10-15 14:57:04 UTC
This happens to me as well, with files accessed over HTTP and SFTP, the two protocols I use. When opening an SFTP file in Dolphin, it does hang Dolphin until the error appears.
Comment 3 Tomas Mecir 2015-10-23 18:26:24 UTC
Getting the same problem on opensuse tumbleweed, frameworks 15.14.0, dolphin 15.08.0, when opening files using kwrite from fish://.
Comment 4 H.H. 2015-11-17 08:45:26 UTC
I have the same problem, also opensuse tumbleweed like previous comment
Comment 5 tago 2015-11-18 18:11:35 UTC
I have this problem when I close a file opened by the recent documents...
Comment 6 tago 2015-11-18 18:12:57 UTC
(In reply to tago from comment #5)
> I have this problem when I close a file opened by the recent documents...

edit: when I close a LibreOffice file opened by the recent documents
Comment 7 H.H. 2015-12-08 09:02:54 UTC
This bug renders dolphin unusable to me at work. Could you please tell, how I can help, to get this bug fixed?
Comment 8 Michael Pyne 2015-12-13 00:48:10 UTC
I'm pretty lost myself, but you might try to capture the command line output of a command like

"kioclient5 exec sftp://example.net/home/path/to/.vimrc"

(or some other file that will open up in a program that doesn't support URLs natively). I used gvim for this.

You should have the URL point to the remote document you've been having problems with. The kioclient program make ask you to select which program to open with -- use the editor (LibreOffice or similar).

Hopefully you should still get the same error, otherwise I'd be even more at a loss what to do. I'm also CC'ing David Faure who is a KIO expert, maybe he'll have more advice.
Comment 9 Tomas Mecir 2015-12-13 09:42:46 UTC
Tried that - there is no command line output, the problem seems to be that kioexec5 hangs. If I use it to open something with a KDE app, kioexec5 starts the app and terminates right away and all is well. If, however, it opens LibreOffice or something, it never terminates, not even after you close LibreOffice.

Here's the output from attached gdb, no debug symbols unfortunately, but it looks like it may be of use anyway:

#0  0x00007f2034f3220d in poll () at /lib64/libc.so.6
#1  0x00007f202eb4b4b4 in  () at /lib64/libdbus-1.so.3
#2  0x00007f202eb4a3f8 in  () at /lib64/libdbus-1.so.3
#3  0x00007f202eb345d4 in  () at /lib64/libdbus-1.so.3
#4  0x00007f202eb34f79 in  () at /lib64/libdbus-1.so.3
#5  0x00007f202eb3553d in dbus_connection_send_with_reply_and_block () at /lib64/libdbus-1.so.3
#6  0x00007f20333bec20 in  () at /usr/lib64/libQt5DBus.so.5
#7  0x00007f20333acf13 in QDBusConnection::call(QDBusMessage const&, QDBus::CallMode, int) const () at /usr/lib64/libQt5DBus.so.5
#8  0x00007f2036981921 in KToolInvocation::startServiceInternal(char const*, QString const&, QStringList const&, QString*, QString*, int*, QByteArray const&, bool, QString const&) () at /usr/lib64/libKF5Service.so.5
#9  0x00007f20369822cc in KToolInvocation::startServiceByDesktopPath(QString const&, QStringList const&, QString*, QString*, int*, QByteArray const&, bool) () at /usr/lib64/libKF5Service.so.5
#10 0x00007f2036ff56d8 in KRun::runService(KService const&, QList<QUrl> const&, QWidget*, bool, QString const&, QByteArray const&) () at /usr/lib64/libKF5KIOWidgets.so.5
#11 0x00007f2036ff8a20 in KRun::runUrl(QUrl const&, QString const&, QWidget*, bool, bool, QString const&, QByteArray const&) ()
    at /usr/lib64/libKF5KIOWidgets.so.5
#12 0x00007f2036ff9220 in KRun::foundMimeType(QString const&) () at /usr/lib64/libKF5KIOWidgets.so.5
#13 0x00007f2036ff32b2 in KRun::mimeTypeDetermined(QString const&) () at /usr/lib64/libKF5KIOWidgets.so.5
#14 0x00007f2036ff332c in KRun::scanFile() () at /usr/lib64/libKF5KIOWidgets.so.5
#15 0x00007f2036ff9b9d in KRun::slotTimeout() () at /usr/lib64/libKF5KIOWidgets.so.5
#16 0x00007f2035821f8a in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib64/libQt5Core.so.5
#17 0x00007f203582e0e8 in QTimer::timerEvent(QTimerEvent*) () at /usr/lib64/libQt5Core.so.5
#18 0x00007f2035822d2b in QObject::event(QEvent*) () at /usr/lib64/libQt5Core.so.5
#19 0x00007f20360288cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#20 0x00007f203602d9d6 in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
#21 0x00007f20357f4cf3 in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
#22 0x00007f20358473bd in QTimerInfoList::activateTimers() () at /usr/lib64/libQt5Core.so.5
#23 0x00007f20358478d1 in  () at /usr/lib64/libQt5Core.so.5
#24 0x00007f2031bd7097 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#25 0x00007f2031bd72c8 in  () at /usr/lib64/libglib-2.0.so.0
#26 0x00007f2031bd736c in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#27 0x00007f203584850f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
---Type <return> to continue, or q <return> to quit---
    at /usr/lib64/libQt5Core.so.5
#28 0x00007f20357f263a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
#29 0x00007f20357fa2fd in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
#30 0x0000000000405de2 in ClientApp::kde_open(QUrl const&, QString const&, bool) ()
#31 0x00000000004064fc in ClientApp::doIt(QCommandLineParser const&) ()
#32 0x0000000000404851 in main ()
Comment 10 H.H. 2015-12-13 11:23:11 UTC
Is this bug also relevant? https://bugs.kde.org/show_bug.cgi?id=353037
Comment 11 Benjamin Robin 2015-12-13 17:28:53 UTC
If I try to open a video file (local file) from the recent documents list (opened by VLC), I do have the same problem (Il est impossible pour KDEInit de lancer "/usr/lib/kf5/kioexec"). 

The menu of recent documents shall run kioexec in the background and not wait the return of kioexec...
Comment 12 David Faure 2015-12-15 08:03:04 UTC
Yes this should be the same as bug 353037 --> please try again with KF 5.17.
Comment 13 Benjamin Robin 2015-12-15 19:32:53 UTC
This bug is fixed with KF 5.17 (at least for the menu of the recent documents).
Comment 14 Michael Pyne 2015-12-16 02:41:58 UTC
Well that's good news then!

After reviewing the backtrace from bug 353037 I'm convinced it is the same as this one, so I'll close this one as a duplicate and breath a sign of relief that it's already fixed...

*** This bug has been marked as a duplicate of bug 353037 ***