Bug 351694 - segment fault when using musicbrainz for tagging
Summary: segment fault when using musicbrainz for tagging
Status: RESOLVED DUPLICATE of bug 328359
Alias: None
Product: amarok
Classification: Unclassified
Component: Metadata Editing and Reading (show other bugs)
Version: 2.8.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: 2.9
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-24 13:25 UTC by er.schuster
Modified: 2015-08-25 11:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
segment fault (38.33 KB, text/plain)
2015-08-24 13:25 UTC, er.schuster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description er.schuster 2015-08-24 13:25:07 UTC
Created attachment 94200 [details]
segment fault

segment fault crash when updating metadata with musicbrainz
Comment 1 Myriam Schweingruber 2015-08-25 11:10:45 UTC
Please always paste backtraces inline, else the trace is not searchable.

FWIW: this is a duplicate...

Thread 1 (Thread 0x7f72d05d7800 (LWP 4313)):
[KCrash Handler]
#6  0x00007f72cd8b02c1 in QReadWriteLock::lockForRead() (this=this@entry=0x38) at thread/qreadwritelock.cpp:149
#7  0x00007f72cf749990 in MusicBrainzTagsItem::childCount() const (this=<synthetic pointer>) at /usr/include/qt4/QtCore/qreadwritelock.h:111
#8  0x00007f72cf749990 in MusicBrainzTagsItem::childCount() const (areadWriteLock=0x38, this=<synthetic pointer>) at /usr/include/qt4/QtCore/qreadwritelock.h:130
#9  0x00007f72cf749990 in MusicBrainzTagsItem::childCount() const (this=0x0) at ../../src/musicbrainz/MusicBrainzTagsItem.cpp:216
#10 0x00007f72cf74fa3c in MusicBrainzTagsModel::flags(QModelIndex const&) const (this=0x4003ab0, index=...) at ../../src/musicbrainz/MusicBrainzTagsModel.cpp:210
#11 0x00007f72ce4afb0b in QSortFilterProxyModel::flags(QModelIndex const&) const (this=<optimized out>, index=...) at itemviews/qsortfilterproxymodel.cpp:2003
#12 0x00007f72ce467237 in QTreeView::drawRow(QPainter*, QStyleOptionViewItem const&, QModelIndex const&) const (this=0x4025210, painter=0x7fffb4a939c0, option=..., index=...) at itemviews/qtreeview.cpp:1631
#13 0x00007f72ce46a6c1 in QTreeView::drawTree(QPainter*, QRegion const&) const (this=this@entry=0x4025210, painter=painter@entry=0x7fffb4a939c0, region=...) at itemviews/qtreeview.cpp:1438
#14 0x00007f72ce46e6b6 in QTreeView::paintEvent(QPaintEvent*) (this=0x4025210, event=0x7fffb4a940c0) at itemviews/qtreeview.cpp:1270
#15 0x00007f72cdf4bdc8 in QWidget::event(QEvent*) (this=0x4025210, event=0x7fffb4a940c0) at kernel/qwidget.cpp:8775
#16 0x00007f72ce31264e in QFrame::event(QEvent*) (this=0x4025210, e=0x7fffb4a940c0) at widgets/qframe.cpp:557
#17 0x00007f72ce4301a3 in QAbstractItemView::viewportEvent(QEvent*) (this=this@entry=0x4025210, event=event@entry=0x7fffb4a940c0) at itemviews/qabstractitemview.cpp:1644
#18 0x00007f72ce472990 in QTreeView::viewportEvent(QEvent*) (this=0x4025210, event=0x7fffb4a940c0) at itemviews/qtreeview.cpp:1252
#19 0x00007f72cd9bf336 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) (this=this@entry=0x17c5c30, receiver=receiver@entry=0x4024950, event=event@entry=0x7fffb4a940c0) at kernel/qcoreapplication.cpp:1065
#20 0x00007f72cdef899c in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=this@entry=0x17c5c30, receiver=receiver@entry=0x4024950, e=e@entry=0x7fffb4a940c0) at kernel/qapplication.cpp:4566
#21 0x00007f72cdeff4d8 in QApplication::notify(QObject*, QEvent*) (this=this@entry=0x7fffb4a958a0, receiver=receiver@entry=0x4024950, e=e@entry=0x7fffb4a940c0) at kernel/qapplication.cpp:4356
#22 0x00007f72cffd0b4a in KApplication::notify(QObject*, QEvent*) (this=0x7fffb4a958a0, receiver=0x4024950, event=0x7fffb4a940c0) at ../../kdeui/kernel/kapplication.cpp:311
#23 0x00007f72cd9bf1cd in QCoreApplication::notifyInternal(QObject*, QEvent*) (this=0x7fffb4a958a0, receiver=receiver@entry=0x4024950, event=event@entry=0x7fffb4a940c0) at kernel/qcoreapplication.cpp:955
#24 0x00007f72cdf4649d in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) (event=0x7fffb4a940c0, receiver=0x4024950) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#25 0x00007f72cdf4649d in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) (this=this@entry=0x3aefb60, pdev=pdev@entry=0x1ed8870, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=0x3774790) at kernel/qwidget.cpp:5599
#26 0x00007f72cdf46f65 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) (this=this@entry=0x3aef6d0, pdev=pdev@entry=0x1ed8870, siblings=..., index=<optimized out>, index@entry=2, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x3774790) at kernel/qwidget.cpp:5808
#27 0x00007f72cdf46ddd in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) (this=this@entry=0x3aef6d0, pdev=pdev@entry=0x1ed8870, siblings=..., index=2, index@entry=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x3774790) at kernel/qwidget.cpp:5795
#28 0x00007f72cdf46ddd in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) (this=this@entry=0x3aef6d0, pdev=pdev@entry=0x1ed8870, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x3774790) at kernel/qwidget.cpp:5795
#29 0x00007f72cdf4600a in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) (this=this@entry=0x3aef6d0, pdev=pdev@entry=0x1ed8870, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=0x3774790) at kernel/qwidget.cpp:5652
#30 0x00007f72cdf46f65 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) (this=this@entry=0x4024d10, pdev=pdev@entry=0x1ed8870, siblings=..., index=<optimized out>, index@entry=2, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x3774790) at kernel/qwidget.cpp:5808
#31 0x00007f72cdf46ddd in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) (this=this@entry=0x4024d10, pdev=pdev@entry=0x1ed8870, siblings=..., index=2, index@entry=3, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x3774790) at kernel/qwidget.cpp:5795
#32 0x00007f72cdf46ddd in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) (this=this@entry=0x4024d10, pdev=pdev@entry=0x1ed8870, siblings=..., index=3, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x3774790) at kernel/qwidget.cpp:5795
#33 0x00007f72cdf4600a in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) (this=this@entry=0x4024d10, pdev=pdev@entry=0x1ed8870, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=0x3774790) at kernel/qwidget.cpp:5652
#34 0x00007f72cdf46f65 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) (this=this@entry=0x3a7d1a0, pdev=pdev@entry=0x1ed8870, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x3774790) at kernel/qwidget.cpp:5808
#35 0x00007f72cdf4600a in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) (this=0x3a7d1a0, pdev=0x1ed8870, rgn=..., offset=..., flags=flags@entry=5, sharedPainter=sharedPainter@entry=0x0, backingStore=0x3774790) at kernel/qwidget.cpp:5652
#36 0x00007f72ce11c115 in QWidgetBackingStore::sync() (this=0x3774790) at painting/qbackingstore.cpp:1373
#37 0x00007f72cdf3abc0 in QWidgetPrivate::syncBackingStore() (this=0x3a7d1a0) at kernel/qwidget.cpp:1894
#38 0x00007f72cdf4be98 in QWidget::event(QEvent*) (this=0x3810140, event=0x39c1ca0) at kernel/qwidget.cpp:8693
#39 0x00007f72cdef89bc in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=this@entry=0x17c5c30, receiver=receiver@entry=0x3810140, e=e@entry=0x39c1ca0) at kernel/qapplication.cpp:4570
#40 0x00007f72cdeff4d8 in QApplication::notify(QObject*, QEvent*) (this=this@entry=0x7fffb4a958a0, receiver=receiver@entry=0x3810140, e=e@entry=0x39c1ca0) at kernel/qapplication.cpp:4356
#41 0x00007f72cffd0b4a in KApplication::notify(QObject*, QEvent*) (this=0x7fffb4a958a0, receiver=0x3810140, event=0x39c1ca0) at ../../kdeui/kernel/kapplication.cpp:311
#42 0x00007f72cd9bf1cd in QCoreApplication::notifyInternal(QObject*, QEvent*) (this=0x7fffb4a958a0, receiver=receiver@entry=0x3810140, event=event@entry=0x39c1ca0) at kernel/qcoreapplication.cpp:955
#43 0x00007f72cd9c2a71 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (event=0x39c1ca0, receiver=0x3810140) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#44 0x00007f72cd9c2a71 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x16def30) at kernel/qcoreapplication.cpp:1579
#45 0x00007f72cd9c2f03 in QCoreApplication::sendPostedEvents(QObject*, int) (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1472
#46 0x00007f72cd9ee6ee in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#47 0x00007f72cd9ee6ee in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=0x17bf3f0) at kernel/qeventdispatcher_glib.cpp:300
#48 0x00007f72c7369c3d in g_main_context_dispatch (context=0x17bfcf0) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3122
#49 0x00007f72c7369c3d in g_main_context_dispatch (context=context@entry=0x17bfcf0) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3737
#50 0x00007f72c7369f20 in g_main_context_iterate (context=context@entry=0x17bfcf0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3808
#51 0x00007f72c7369fcc in g_main_context_iteration (context=0x17bfcf0, may_block=1) at /build/buildd/glib2.0-2.44.1/./glib/gmain.c:3869
#52 0x00007f72cd9ee85e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x16e0830, flags=...) at kernel/qeventdispatcher_glib.cpp:450
#53 0x00007f72cdfa0c66 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#54 0x00007f72cd9bdd21 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fffb4a95790, flags=...) at kernel/qeventloop.cpp:149
#55 0x00007f72cd9be085 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fffb4a95790, flags=...) at kernel/qeventloop.cpp:204
#56 0x00007f72cd9c3b09 in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1227
#57 0x00007f72cdef6c1c in QApplication::exec() () at kernel/qapplication.cpp:3828
#58 0x0000000000407e04 in main(int, char**) (argc=<optimized out>, argv=0x7fffb4a95a08) at ../../src/main.cpp:329

Possible duplicates by query: bug 351636, bug 351166.
Comment 2 Myriam Schweingruber 2015-08-25 11:11:18 UTC

*** This bug has been marked as a duplicate of bug 328359 ***