Bug 351571 - kmail doesn't recognize/show some IMAP folders
Summary: kmail doesn't recognize/show some IMAP folders
Status: REPORTED
Alias: None
Product: kmail2
Classification: Applications
Component: folders (show other bugs)
Version: 4.14.7
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-21 16:18 UTC by naworski98
Modified: 2017-04-14 20:31 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description naworski98 2015-08-21 16:18:26 UTC
So, i can reproduce this Problem on several devices with Kubuntu 14.10 and 15.04 and the matching kmail/akonadi versions from the standard sources.
The Folders, that weren't recognized have names like "[foldername]" (except the ""). So other folders are shown properly, even with square brackets, as long they contain a space in between.
The two things that make me wonder are:
- it does just affect one mailserver (on others it works).
- there are no problems like that in Thunderbird.
I already tried to delete such a folder via the web interface of the mailserver and recreate it with kmail, but then it becomes instantly invisible (even thought it was created if i check in the webinterface or thunderbird). And if i create it again (without deleting) it's shown in kmail! But it seems there's no kind of connection to the real thing on the mailserver (also checked with tb and the webui).

Reproducible: Always

Steps to Reproduce:
1. Add a new Imap account to kmail/akonadi, which belongs to this specific university mailserver
2. Wait for synchronisation
3. Recognize, that some folders are missing (see the description)
Comment 1 luxarf 2017-04-14 20:31:29 UTC
I have my mails hosted at uberspace.de.
They are using Dovecot for IMAP.

I have the exact same issue: IMAP-folders with a name containing [string] are not shown and not accessible.

In a hierarchy of folders like this:
first_level
-second_level
--third_level

a. If all levels of hierarchy are using [string] as foldername, nothing is showing.

b. If the second level of hierarchy is using [string] as foldername, it is showing, but not with the name. The third level is also shown.
In this case, trying to fetch mails result in errors, becouse kmail is searching for "IMAP.first_level..third_level" which the IMAP-server cannot find.
The correct path would be "IMAP.first_level.second_level.third_level", but it seems as if "[string]" result in "".