Bug 351490 - Incomplattibility with clusterssh (and other non kde apps) - X11 copy and paste stops working
Summary: Incomplattibility with clusterssh (and other non kde apps) - X11 copy and pas...
Status: RESOLVED DUPLICATE of bug 348569
Alias: None
Product: konsole
Classification: Unclassified
Component: copy-paste (show other bugs)
Version: 15.04.0
Platform: Fedora RPMs Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords: investigated, triaged
Depends on:
Blocks:
 
Reported: 2015-08-19 17:19 UTC by Fredi
Modified: 2018-09-19 14:30 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fredi 2015-08-19 17:19:30 UTC
At first, i'm not 100% sure this is only a konsole bug as even alt+tab stops working, but the selection problem happens only with konsole, so I'm filing it here.

This bug was reported to the Fedora bugtracker too, there's some more info in there too:

https://bugzilla.redhat.com/show_bug.cgi?id=1254254

but no reply after 2 days.

Steps to reproduce:

Keep konsole open, launching clusterssh with a cluster (so it opens some xterms).
Do a copy and paste operation in one of the xterms opened by clusterssh. From now on on konsole X11 selection and kde (right click menu) copy and paste will stop working.


This happens with other randoom non KDE X11 applications, but that's the easiest way for me to 100% reproduce this bug.

In the xsession-error.log, when C&P does not work i see:

QXcbClipboard::setMimeData: Cannot set X11 selection owner
QXcbClipboard::setMimeData: Cannot set X11 selection owner
QXcbClipboard::setMimeData: Cannot set X11 selection owner



Reproducible: Always

Steps to Reproduce:
1. Open konsole
2. launch clusterssh (http://sourceforge.net/projects/clusterssh/) with a cluster (the command assumes you have clusterssh installed and sshd enabled on your local machine):
    cssh localhost
3. do a random copy and paste in the newly opened xterm

In my ~/.xsession-errors i see:

QXcbClipboard::setMimeData: Cannot set X11 selection owner

during selection on konsole while it isn't working




Actual Results:  
selection copy and paste does not work anymore on konsole.

As a tangent in my case even alt+tab stops working but a nohup kwin --replace restores alt+tab so this i think should be a kwin related issue, just mentioning this for completeness.



Expected Results:  
X11 copy and paste to work correctly regardless of applications.

Just ask for any more info needed, or if it's not a kde / konsole problem please point me where to file a bug report in case.


As a "workaround" for now i'm using gnome teminal, though it's more than 10 years that i use konsole daily for hours and I'm used to it.

Thanks in advance,
Frederik
Comment 1 Fredi 2015-10-01 12:20:35 UTC
Ok, after ~3/4 other fedora 22 kde binary releases (the list of my installed packages follows) the result is the same.

This are konsole logs wen the problem happens:

$ konsole --nofork 
QCoreApplication::arguments: Please instantiate the QApplication object first
The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.
The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.
QXcbClipboard::setMimeData: Cannot set X11 selection owner
QXcbClipboard::setMimeData: Cannot set X11 selection owner

Here's what i see in my xsession-errors (note the cssh launching that provokes the bug, actually launching cssh server where server is a cluster made of server1 and server2):

Opening to: server1 server2
QXcbConnection: XCB error: 2 (BadValue), sequence: 34438, resource id: 31457285, major code: 141 (Unknown), minor code: 3

networkmanager-qt: void NetworkManager::AccessPointPrivate::propertiesChanged(const QVariantMap&) Unhandled property "LastSeen"
networkmanager-qt: void NetworkManager::AccessPointPrivate::propertiesChanged(const QVariantMap&) Unhandled property "LastSeen"
networkmanager-qt: void NetworkManager::AccessPointPrivate::propertiesChanged(const QVariantMap&) Unhandled property "LastSeen"
networkmanager-qt: void NetworkManager::AccessPointPrivate::propertiesChanged(const QVariantMap&) Unhandled property "LastSeen"
networkmanager-qt: void NetworkManager::AccessPointPrivate::propertiesChanged(const QVariantMap&) Unhandled property "LastSeen"
networkmanager-qt: void NetworkManager::AccessPointPrivate::propertiesChanged(const QVariantMap&) Unhandled property "LastSeen"
networkmanager-qt: void NetworkManager::AccessPointPrivate::propertiesChanged(const QVariantMap&) Unhandled property "LastSeen"
trying to show an empty dialog
trying to show an empty dialog
QXcbConnection: XCB error: 3 (BadWindow), sequence: 43004, resource id: 31457285, major code: 141 (Unknown), minor code: 3
QXcbConnection: XCB error: 149 (Unknown), sequence: 43005, resource id: 31457285, major code: 142 (Unknown), minor code: 2

Other datapoints:

* When this happens kwin too starts behaving quite strange, seems dead. I cant move windows and window switching with alt-tab does not work, the only way to recover it is a kwin --replace & (i even made an alias for that as i'm using it after each cssh session)

* I have a dual monitor setup, not sure this matters


Now, is there something else i can do to troubleshot? Can you suggest me to test something? Is this bug report even interesting?


Here are my installed packages:



$ rpm -qa | egrep '^(kde|qt|plasma)' | sort 
kdeaccessibility-4.14.3-1.fc22.noarch
kde-apps-rpm-macros-4.14.12-1.fc22.noarch
kde-baseapps-15.04.2-1.fc22.x86_64
kde-baseapps-common-15.04.2-1.fc22.noarch
kde-baseapps-libs-15.04.2-1.fc22.x86_64
kde-cli-tools-5.4.1-1.fc22.x86_64
kdecoration-5.4.1-1.fc22.x86_64
kde-filesystem-4-51.fc22.x86_64
kdegames-minimal-4.14.3-1.fc22.noarch
kdegraphics-strigi-analyzer-15.04.0-1.fc22.x86_64
kdegraphics-thumbnailers-15.04.0-1.fc22.x86_64
kde-l10n-14.12.3-8.fc22.noarch
kdelibs3-3.5.10-68.fc22.x86_64
kdelibs-4.14.12-1.fc22.x86_64
kdelibs-common-4.14.12-1.fc22.x86_64
kdelibs-ktexteditor-4.14.12-1.fc22.x86_64
kdelibs-webkit-4.14.12-1.fc22.x86_64
kdenetwork-common-4.14.3-1.fc22.noarch
kde-partitionmanager-1.2.1-3.fc22.x86_64
kdepasswd-15.04.2-1.fc22.x86_64
kdepim-common-4.14.9-1.fc22.x86_64
kdepim-libs-4.14.9-1.fc22.x86_64
kdepimlibs-4.14.9-1.fc22.x86_64
kdepimlibs-akonadi-4.14.9-1.fc22.x86_64
kdepimlibs-gpgme-4.14.9-1.fc22.x86_64
kdepimlibs-kxmlrpcclient-4.14.9-1.fc22.x86_64
kdepim-runtime-4.14.9-1.fc22.x86_64
kdepim-runtime-libs-4.14.9-1.fc22.x86_64
kde-plasma-activitymanager-debuginfo-0.5-6.fc20.x86_64
kdeplasma-addons-5.4.1-1.fc22.x86_64
kdeplasma-addons-debuginfo-4.14.3-3.fc20.x86_64
kde-plasma-akonadi-calendars-debuginfo-0.2.2-3.fc20.x86_64
kde-plasma-akonadi-contacts-debuginfo-0.1.7-5.fc20.x86_64
kde-plasma-akonadi-tasks-debuginfo-0.1.3-3.fc20.x86_64
kde-plasma-daisy-debuginfo-0.0.4.26-3.fc20.x86_64
kde-plasma-ihatethecashew-debuginfo-0.4-7.fc20.x86_64
kde-plasma-nm-debuginfo-0.9.3.6-1.fc20.x86_64
kde-plasma-publictransport-debuginfo-0.10-0.9.20111204git.fc20.x86_64
kde-plasma-quickaccess-debuginfo-0.8.1-9.fc20.x86_64
kde-plasma-runcommand-debuginfo-2.4-4.fc20.x86_64
kde-plasma-smooth-tasks-debuginfo-0.0.1-0.9.20120313hge8a97edfdebc.fc20.x86_64
kde-plasma-translatoid-debuginfo-1.30-10.svn01092011.fc20.x86_64
kde-plasma-yawp-debuginfo-0.4.5-2.fc20.x86_64
kde-platform-plugin-4.11.22-2.fc22.x86_64
kde-print-manager-15.03.95-2.fc22.x86_64
kde-print-manager-libs-15.03.95-2.fc22.x86_64
kde-runtime-15.08.1-1.fc22.x86_64
kde-runtime-drkonqi-15.08.1-1.fc22.x86_64
kde-runtime-flags-15.08.1-1.fc22.noarch
kde-runtime-libs-15.08.1-1.fc22.x86_64
kde-settings-22-11.fc22.noarch
kde-settings-kdm-22-11.fc22.noarch
kde-settings-ksplash-22-11.fc22.noarch
kde-settings-plasma-22-11.fc22.noarch
kde-settings-pulseaudio-22-11.fc22.noarch
kde-style-breeze-5.4.1-1.fc22.x86_64
kdesu-5.4.1-1.fc22.x86_64
kdevelop-4.7.1-1.fc22.x86_64
kdevelop-libs-4.7.1-1.fc22.x86_64
kdevplatform-1.7.1-1.fc22.x86_64
kdevplatform-libs-1.7.1-1.fc22.x86_64
kdewebdev-3.5.10-23.fc22.x86_64
kdewebdev-libs-3.5.10-23.fc22.x86_64
kde-workspace-common-4.11.22-2.fc22.noarch
plasma-breeze-5.4.1-1.fc22.x86_64
plasma-breeze-common-5.4.1-1.fc22.noarch
plasma-desktop-5.4.1-2.fc22.1.x86_64
plasma-desktop-doc-5.4.1-2.fc22.1.noarch
plasma-mediacenter-debuginfo-1.3.0-1.fc20.x86_64
plasma-milou-5.4.1-1.fc22.x86_64
plasma-mobile-debuginfo-0.4-4.fc20.x86_64
plasma-nm-5.4.1-1.fc22.x86_64
plasma-nm-l2tp-5.4.1-1.fc22.x86_64
plasma-nm-openconnect-5.4.1-1.fc22.x86_64
plasma-nm-openswan-5.4.1-1.fc22.x86_64
plasma-nm-openvpn-5.4.1-1.fc22.x86_64
plasma-nm-pptp-5.4.1-1.fc22.x86_64
plasma-nm-vpnc-5.4.1-1.fc22.x86_64
plasma-pk-updates-0.2-1.fc22.x86_64
plasma-systemsettings-5.4.1-1.fc22.x86_64
plasmate-debuginfo-1.0-5.fc20.x86_64
plasma-widget-menubar-debuginfo-0.2.0-1.fc20.x86_64
plasma-workspace-5.4.1-3.fc22.x86_64
qt3-3.3.8b-64.fc22.x86_64
qt-4.8.6-30.fc22.i686
qt-4.8.6-30.fc22.x86_64
qt4-style-oxygen-5.4.1-1.fc22.x86_64
qt5-qtbase-5.5.0-15.fc22.x86_64
qt5-qtbase-common-5.5.0-15.fc22.noarch
qt5-qtbase-gui-5.5.0-15.fc22.x86_64
qt5-qtdeclarative-5.5.0-3.fc22.x86_64
qt5-qtgraphicaleffects-5.5.0-2.fc22.x86_64
qt5-qtlocation-5.5.0-3.fc22.x86_64
qt5-qtmultimedia-5.5.0-3.fc22.x86_64
qt5-qtquickcontrols-5.5.0-3.fc22.x86_64
qt5-qtscript-5.5.0-3.fc22.x86_64
qt5-qtsensors-5.5.0-3.fc22.x86_64
qt5-qtsvg-5.5.0-3.fc22.x86_64
qt5-qttools-5.5.0-4.fc22.x86_64
qt5-qttools-common-5.5.0-4.fc22.noarch
qt5-qttools-libs-designer-5.5.0-4.fc22.x86_64
qt5-qtwebkit-5.5.0-4.fc22.x86_64
qt5-qtx11extras-5.5.0-2.fc22.x86_64
qt5-qtxmlpatterns-5.5.0-3.fc22.x86_64
qt-common-4.8.6-30.fc22.noarch
qt-devel-4.8.6-30.fc22.x86_64
qt-gstreamer-1.2.0-3.fc22.x86_64
qtlockedfile-2.4-18.20150629git5a07df5.fc22.x86_64
qt-mobility-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-bearer-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-bearer-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-common-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-common-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-connectivity-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-connectivity-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-feedback-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-feedback-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-gallery-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-gallery-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-location-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-location-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-multimediakit-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-multimediakit-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-pim-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-pim-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-publishsubscribe-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-publishsubscribe-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-sensors-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-sensors-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-serviceframework-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-serviceframework-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mobility-systeminfo-1.2.2-0.17.20140317git169da60c.fc22.i686
qt-mobility-systeminfo-1.2.2-0.17.20140317git169da60c.fc22.x86_64
qt-mysql-4.8.6-30.fc22.x86_64
qt-qdbusviewer-4.8.6-30.fc22.x86_64
qtscriptbindings-0.2.0-8.fc22.x86_64
qt-settings-22-11.fc22.noarch
qtsingleapplication-2.6.1-23.fc22.x86_64
qtsoap-2.7-9.fc22.x86_64
qtwebkit-2.3.4-6.fc22.i686
qtwebkit-2.3.4-6.fc22.x86_64
qtwebkit-devel-2.3.4-6.fc22.x86_64
qt-x11-4.8.6-30.fc22.i686
qt-x11-4.8.6-30.fc22.x86_64
$
Comment 2 Fredi 2015-10-01 12:21:54 UTC
BTW I have reported this on Fedora's bugtracker too: https://bugzilla.redhat.com/show_bug.cgi?id=1254254
Comment 3 Fredi 2015-10-01 14:39:41 UTC
Another update, this is definitely a duplicate of a kwin bug:

https://bugs.kde.org/show_bug.cgi?id=348569

Thanks to Rex Dieter for the support.

*** This bug has been marked as a duplicate of bug 348569 ***
Comment 4 Andrew Crouthamel 2018-09-19 14:30:07 UTC
This bug has had its resolution changed, but accidentally has been left in NEEDSINFO status. I am thus closing this bug and setting the status as RESOLVED to reflect the resolution change.