Bug 350855 - KMail/KF5 changing display font for message body has no effect
Summary: KMail/KF5 changing display font for message body has no effect
Status: RESOLVED DUPLICATE of bug 337656
Alias: None
Product: kmail2
Classification: Applications
Component: UI (show other bugs)
Version: 5.4.1
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-01 09:20 UTC by Andreas Cord-Landwehr
Modified: 2017-01-20 20:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Cord-Landwehr 2015-08-01 09:20:29 UTC
Changing the display font for the message body in "Settings" -> "Configure KMail" -> Appearence" -> "Fonts" does not have any effect on the display font size when opening a message (also not in the the message preview widget next to the message list). Restarting KMail does not change this.

Reproducible: Always
Comment 1 Andreas Cord-Landwehr 2015-08-01 09:21:42 UTC
Additional information, just recognized: the font size of the mail header information change though. But not the font of my (plain text) mails.
Comment 2 Denis Kurz 2017-01-20 19:28:20 UTC
Confirmed for 5.4.1. I changed the font for "Message Body" to Hack, size 13. Preview as well as message viewer window were quite unimpressed. Just as reported, restart didn't help either. In contrast to Comment 1, however, I didn't notice any changes in headers. The settings simply have no effect at all.

Other than "Message Body", all the other options in the "Apply to" field didn't change anything either, except for "Composer". The font for "Composer" is applied to some header fields in the composer (From, Subject), but not all (To). The message body in the composer is unaffected, too.
Comment 3 Denis Kurz 2017-01-20 19:32:00 UTC
Sorry! I, too, missed a detail: I chose *bold* text for unread messages in the message list. The font and size are still not applied to messages in the message list, but unread messages are displayed bold.
Comment 4 Denis Kurz 2017-01-20 20:22:29 UTC

*** This bug has been marked as a duplicate of bug 337656 ***