Bug 350793 - Desktop file missing StartupWMClass (with fix included here)
Summary: Desktop file missing StartupWMClass (with fix included here)
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: 4.7.2
Platform: Archlinux Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-30 14:50 UTC by Mark Blakeney
Modified: 2017-07-01 11:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Blakeney 2015-07-30 14:50:36 UTC
I have used kmymoney frequently for 10 years and finally got around to identifying and fixing an annoying bug that has existed for at least the last 5 years. I use kmymoney on GNOME and I use it in multiple windows for 3 unrelated financial entities. Kmymoney has always shown those windows as separate apps on my GNOME dock. The problem is merely that the line "StartupWMClass=Kmymoney" needs to be added to the kmymoney.desktop file.

Reproducible: Always

Steps to Reproduce:
1. Start one instance
2. Start another instance
3. See 2 KMM icons in dock

Apply the trivial fix stated here and then only a single grouped icon appears, like all other GNOME and KDE apps.

Actual Results:  
See above.

Expected Results:  
See above.
Comment 1 Thomas Baumgart 2015-07-31 06:56:10 UTC
Git commit 90af1561c2d7aa4bebbf7a2a0b2569584e0da724 by Thomas Baumgart.
Committed on 31/07/2015 at 06:53.
Pushed by tbaumgart into branch 'master'.

Added StartupWMClass entry in desktop file

M  +1    -0    kmymoney/kmymoney.desktop

http://commits.kde.org/kmymoney/90af1561c2d7aa4bebbf7a2a0b2569584e0da724