Bug 350663 - Changing default default web browser reverts after closing settings page
Summary: Changing default default web browser reverts after closing settings page
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_componentchooser (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: usability
: 367845 370201 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-27 14:48 UTC by Timofey
Modified: 2018-11-27 03:02 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.12.8


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timofey 2015-07-27 14:48:05 UTC
I can change between browsers like konqueror and iceweasel in the system settings, but as soon as I set it as chromium, click apply, and close the window, it reverts back. Restarting does not work. I have tried xdg-settings, but this does not seem to work on my kde. 
Package: systemsettings (4:4.11.13-2)

Reproducible: Always

Steps to Reproduce:
1.Go to default applications through system settings
2.Click web browser
3.Change to chromium
4.Click apply
5. Close window
6. Attempt to open link, and see that it does not open through chromium.
7.confirm that it has not changed to chromium by repeating steps 1 & 2.

Actual Results:  
Chromium was not changed to the default browser, while changing any other browser as the default did in fact work

Expected Results:  
Chromium would be the default browser
Comment 1 Timofey 2015-07-27 15:25:03 UTC
EDIT: I found out that this was caused by typing "chromium" when selecting the web browser applications rather than finding it under the list of known applications ie. typing chromium does not work, choosing "chromium web browser", which is listed as one of the "known applications" does work.
Comment 2 Vadym Krevs 2016-01-07 09:06:22 UTC
Same behaviour, including the observation from comment 1, in systemsettings 5.5.2 on openSUSE Leap 42.1.

Please fix this as this is highly annoying.
Comment 3 Christoph Feck 2016-09-02 08:25:21 UTC
*** Bug 367845 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Feck 2016-10-06 22:30:08 UTC
*** Bug 370201 has been marked as a duplicate of this bug. ***
Comment 5 HD 2017-02-27 21:50:14 UTC
Not sure if this is connected, but I have the issue of not being able to change the default browser in "Default Applications" at all. When I change it and press apply or ok, it reverts back to "in an application based on the contents of the URL". 

My reason for changing it was that I get the error "KDEInit could not launch '/usr/lib/firefox/firefox'", and I can't figure out how to solve that or why it would even look for firefox there.

I'm on debian stretch with plasma 5.8.4.
Comment 6 Anguo 2017-05-24 03:52:11 UTC
Bug 380133 - Cannot see/change default browser settings 
https://bugs.kde.org/show_bug.cgi?id=380133
Comment 7 Kayra Akman 2018-05-01 11:07:38 UTC
(In reply to HD from comment #5)
> Not sure if this is connected, but I have the issue of not being able to
> change the default browser in "Default Applications" at all. When I change
> it and press apply or ok, it reverts back to "in an application based on the
> contents of the URL". 
> 
> My reason for changing it was that I get the error "KDEInit could not launch
> '/usr/lib/firefox/firefox'", and I can't figure out how to solve that or why
> it would even look for firefox there.
> 
> I'm on debian stretch with plasma 5.8.4.

I was about the report this issue. Selecting "in the following application" item was not enough. A browser in the drop-down must be selected, even if there is only one, so that the setting change is applied and saved.

Kubuntu 18.04, Plasma 5.12.4, Falkon as the only available web browser.
Comment 8 Nate Graham 2018-11-27 00:26:20 UTC
This turned out to be a fairly easy fix. Here's a patch: https://phabricator.kde.org/D17181
Comment 9 Nate Graham 2018-11-27 03:02:13 UTC
Git commit 26fb5ec20af60682561c7a9678506199966ef2c1 by Nate Graham.
Committed on 27/11/2018 at 03:01.
Pushed by ngraham into branch 'Plasma/5.12'.

[Componentchooser KCM] Make default browser app choice work even when combobox is not used

Summary:
FIXED-IN: 5.12.8

When choosing a default browser app using the app list combobox, the choice was only being saved after the combobox was used, because its signal was connected to an inline function that saved the choice, while the radio button that enabled the combobox was not. As a result, if you clicked on that radio button and didn't need to use the combobox because it was already showing your preferred browser, that action was not actually getting saved.

This patch fixes the situation my moving the inline function into a real explicit slot function and connecting the radio button to it as well.

Test Plan:
- Go to the component chooser KCM's default browser module
- Reset to defaults, then leave the KCM and open it again
- Click the {nav in the following application} radio button
- Do NOT touch the combobox
- Click {nav Apply}
- Leave the KCM and come back

With this patch, the radio button's state is preserved and the correct browser is selected in the combobox.

Reviewers: #plasma, cfeck, davidedmundson

Reviewed By: #plasma, davidedmundson

Subscribers: davidedmundson, plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D17181

M  +10   -7    kcms/componentchooser/componentchooserbrowser.cpp
M  +1    -0    kcms/componentchooser/componentchooserbrowser.h

https://commits.kde.org/plasma-desktop/26fb5ec20af60682561c7a9678506199966ef2c1