Bug 350573 - Compact mode causes plasma freezes
Summary: Compact mode causes plasma freezes
Status: RESOLVED DUPLICATE of bug 348385
Alias: None
Product: kdeplasma-addons
Classification: Unclassified
Component: systemloadviewer (show other bugs)
Version: 5.3.2
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-24 06:47 UTC by Antonio Rojas
Modified: 2015-08-15 07:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Rojas 2015-07-24 06:47:00 UTC
Adding a system load viewer in compact mode to the panel causes Plasma to freeze after a while. Can't reproduce in the default bar mode. 

Backtrace:
(gdb) bt
#0  0x00007ffff5ac7c18 in QQuickShaderEffectSource::updatePaintNode(QSGNode*, QQuickItem::UpdatePaintNodeData*) () from /usr/lib/libQt5Quick.so.5
#1  0x00007ffff59de408 in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/libQt5Quick.so.5
#2  0x00007ffff59dec8b in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/libQt5Quick.so.5
#3  0x00007ffff59dee00 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/libQt5Quick.so.5
#4  0x00007ffff59adb5c in ?? () from /usr/lib/libQt5Quick.so.5
#5  0x00007ffff59aecd1 in ?? () from /usr/lib/libQt5Quick.so.5
#6  0x00007ffff34e100c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#7  0x00007ffff34e64e6 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#8  0x00007ffff211289b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#9  0x00007ffff216805d in QTimerInfoList::activateTimers() () from /usr/lib/libQt5Core.so.5
#10 0x00007ffff2168561 in ?? () from /usr/lib/libQt5Core.so.5
#11 0x00007fffedad09fd in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#12 0x00007fffedad0ce0 in ?? () from /usr/lib/libglib-2.0.so.0
#13 0x00007fffedad0d8c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#14 0x00007ffff216923f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#15 0x00007ffff211026a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#16 0x00007ffff211820c in QCoreApplication::exec() () from /usr/lib/libQt5Core.so.5
#17 0x000000000042ed66 in main ()


Reproducible: Always
Comment 1 Bhushan Shah 2015-07-24 06:50:12 UTC
Probably it is dup of bug 348385
Comment 2 Bhushan Shah 2015-07-24 06:51:58 UTC
and given is Qt 5.5 it can be this too : https://bugs.kde.org/show_bug.cgi?id=350143
Comment 3 Antonio Rojas 2015-08-15 07:14:37 UTC

*** This bug has been marked as a duplicate of bug 348385 ***