Bug 350386 - =kde-base/kdm-4.11.19 auto login breaks XkbVariant neo,basic for layout de,de
Summary: =kde-base/kdm-4.11.19 auto login breaks XkbVariant neo,basic for layout de,de
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kdm
Classification: Miscellaneous
Component: general (show other bugs)
Version: 4.11.10
Platform: Gentoo Packages Linux
: NOR normal
Target Milestone: ---
Assignee: kdm bugs tracker
URL: https://wiki.neo-layout.org/ticket/43...
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-19 23:55 UTC by Manuel Ullmann
Modified: 2018-04-16 20:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
Keyboard configuration for evdev/udev intended for xorg.conf.d (258 bytes, text/plain)
2015-07-19 23:59 UTC, Manuel Ullmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Ullmann 2015-07-19 23:55:21 UTC
If kdm does an auto login, it seems not to set up XkbVariant correctly. If the ergonomic neo layout is the primary german variant, certain key combinations will stop working (see below). The combination neo, nodeadkeys is also affected. This does not happen, if neo is a secondary variant, or if kdm does not login automatically.





Reproducible: Always

Steps to Reproduce:
1. Activate kdm’s auto login mode
2. Use an xorg.conf.d file to activate layouts de,de with neo,basic variants.
3. Restart kdm.

Actual Results:  
Ctrl+F[1–12] will print the following in an editor:
PQRS;3~;3~;3~;3~;3~;3~;3~;3~
Meta+<arbitrary-key> will also print random stuff.

Expected Results:  
These combinations should be reported to X correctly.

If you happen to speak german, you’d notice, that I gave the wrong command for reproduction steps in the linked URL. I’ll add a comment there for that. I guess I was to tired, when I reported it there.

Besides that, I know of course, that sddm is default for KF5. So it would be nice, if you could support its developers to get it right this time.
Comment 1 Manuel Ullmann 2015-07-19 23:59:36 UTC
Created attachment 93653 [details]
Keyboard configuration for evdev/udev intended for xorg.conf.d
Comment 2 Nate Graham 2018-04-16 20:19:29 UTC
KDM is unmaintained and not used in KDE Plasma 5.

SDDM is the login manager used in KDE Plasma 5. If you still have this same issue with SDDM, please file an issue on the SDDM bugtracker (after doing a search for existing issues first!): https://github.com/sddm/sddm/issues/