Bug 349751 - Wrongs links to ebn (Code Checking + Documentation Sanitation) generated from data in *.json files
Summary: Wrongs links to ebn (Code Checking + Documentation Sanitation) generated from...
Status: RESOLVED WORKSFORME
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2015-06-30 14:26 UTC by Burkhard Lück
Modified: 2018-10-27 04:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Burkhard Lück 2015-06-30 14:26:17 UTC
On many application pages (www.kde.org/applications/*/*/development) the two links to EBN Code Checking + Documentation Sanitation are broken.

Reason is apparently an outdated function ebnUrlBase() in websites/capacity/includes/classes/class_appdata.inc.

ebnUrlBase() returns a correct result only for apps in svn (thats only a minority nowadays) and for some apps in git like kdegames or dolphin with an entry "parent" : "kde/parentrepo" in the appname.json file.

Therefore these links are wrong for all apps in calligra (no parent entry in json), all apps in kdepim (wrong parent entry in json - only "kde" + missing parentrepo).

ebnUrlBase() even has code to process koffice in svn like:
"if (in_array('koffice', $parts)) ""
Comment 1 Albert Astals Cid 2015-07-04 14:49:40 UTC
Fix the json for those that don't have it correct? It seems to me you know what needs to be done?
Comment 2 Burkhard Lück 2015-07-06 08:35:28 UTC
(In reply to Albert Astals Cid from comment #1)
> Fix the json for those that don't have it correct? It seems to me you know
> what needs to be done?

Fixing the json (= adding a parent entry) is easy and I can do that, but it is not sufficient, the function ebnUrlBase() in websites/capacity/includes/classes/class_appdata.inc has to be fixed as well
Comment 3 Albert Astals Cid 2015-07-06 20:33:49 UTC
 You'll have to give me something more solid here, like which application, what did you change in the json and what's the expected ebn url that should generate.

Can't read your mind yet ;)
Comment 4 Burkhard Lück 2015-07-08 15:25:54 UTC
Diff with comments for necessary changes in function ebnUrlBase()

websites/capacity$ git diff
diff --git a/includes/classes/class_appdata.inc b/includes/classes/class_appdata.inc
index cfa47e4..c0fb7fe 100644
--- a/includes/classes/class_appdata.inc
+++ b/includes/classes/class_appdata.inc
@@ -259,10 +259,9 @@ class AppData
         function ebnUrlBase() {
             // examples:
             // KDE/kdeedu/parley:               http://englishbreakfastnetwork.org/krazy/reports/kde-4.x/kdeedu/parley/index.html
-            // KDE/kdebase/apps/dolphin:        http://englishbreakfastnetwork.org/krazy/reports/kde-4.x/kdebase-apps/dolphin/index.html
+            // KDE/applications/dolphin:        http://englishbreakfastnetwork.org/krazy/reports/kde-4.x/applications/dolphin/index.html
             // extragear/graphics/digikam:      http://englishbreakfastnetwork.org/krazy/reports/extragear/graphics/digikam/index.html
-            // koffice/kword:                   http://englishbreakfastnetwork.org/krazy/reports/bundled-apps/koffice/kword/index.html
-            // amarok (gitorious):              http://englishbreakfastnetwork.org/krazy/reports/extragear/multimedia/amarok-git/index.html
+            // calligra/krita:                  http://englishbreakfastnetwork.org/krazy/reports/bundled-apps/calligra/krita/index.html
 
             $ebn = '';
             if ($this->data['repository'][0] == 'svn') {
@@ -280,7 +279,7 @@ class AppData
                     }
                 } else if (in_array('extragear', $parts)) {
                     $ebn = 'extragear/'.$parts[$len-2].'/'.$parts[$len-1];
-                } else if (in_array('koffice', $parts)) {
+                } else if (in_array('koffice', $parts)) { //no koffice on kde,org, remove this "else if"
                     $ebn = 'bundled-apps/'.$parts[$len-2].'/'.$parts[$len-1];
                 }
             } else if($this->data['repository'][0] == 'git') {
@@ -291,6 +290,9 @@ class AppData
                 if ($parts[0] == 'kde') {
                     $ebn = "kde-4.x/" . $parts[1] . "/" . strtolower($this->data['repository'][1]);
                } else {
+// replace "else" with "else if  ($parts[0] == 'extragear') {}
+//            and with "else if  ($parts[0] == 'calligra') {}
+//            and with "else if  ($parts[0] == 'applications') {}
                     $ebn = $parts[0] . "/" . $parts[1] . "/" . strtolower($this->name());  
                }
                return $ebn;
Comment 5 Albert Astals Cid 2015-07-09 20:29:32 UTC
I am not sure i understand the needed changes, can you please post links to the broken applications in https://www.kde.org/applications/ and the links they should be pointing to in ebn?
Comment 6 Andrew Crouthamel 2018-09-25 21:46:43 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Andrew Crouthamel 2018-10-27 04:16:29 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!