Bug 349750 - Laptop does not suspend when lid closed in lock screen
Summary: Laptop does not suspend when lid closed in lock screen
Status: RESOLVED WORKSFORME
Alias: None
Product: Powerdevil
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR major
Target Milestone: ---
Assignee: Plasma Development Mailing List
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2015-06-30 13:57 UTC by Martin Klapetek
Modified: 2018-10-29 02:20 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
dump of the interesting part of journalctl (52.38 KB, text/plain)
2016-02-01 10:10 UTC, Olivier Churlaud
Details
journal log showing list closed and open events with no suspension (243.73 KB, text/plain)
2017-02-28 22:16 UTC, Michael N
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Klapetek 2015-06-30 13:57:47 UTC
I'm sitting at a cafe doing things on my laptop, then take a book and read a book while the laptop screen turns off (and locks) after couple minutes. After about half an hour I realize it's too late and I need to run to catch the bus. I close the laptop lid and put the laptop in my back. Laptop however won't suspend and will almost fry itself inside a neoprene case inside my bag.

Laptop is configured to suspend on lid close and does suspend properly when lid is closed. It does not suspend when screen is locked however.
Comment 1 Kai Uwe Broulik 2015-07-02 15:39:38 UTC
Frying your laptop is a severe issue, raising priority
Comment 2 Olivier Churlaud 2016-02-01 10:10:15 UTC
Created attachment 96950 [details]
dump of the interesting part of journalctl
Comment 3 Olivier Churlaud 2016-02-01 10:11:13 UTC
Oups wrong thread...  please forget this last one...
Comment 4 Aleix Pol 2016-02-02 14:52:27 UTC
What's the status of this? Can we confirm or close?
Comment 5 Aleix Pol 2016-02-02 14:52:50 UTC
?
Comment 6 Niall 2016-02-03 14:59:50 UTC
I can confirm this, I have noticed before but did not consider it as a major issue as my laptop battery's life is over- effectually making it a desktop at home.
Comment 7 Martin Klapetek 2016-02-03 19:19:02 UTC
Does not happen for me anymore.

Niall - what's your plasma version?
Comment 8 Michael N 2017-02-28 22:15:01 UTC
I can confirm this is an issue with my laptop. I am running kubuntu 16.10 with plasma 5.7.5. I can suspend via the gui menu, but when I close the lid the screen stays on and the system does not suspend. I do see the lid closed and open events in journal log, which I will attach.
Comment 9 Michael N 2017-02-28 22:16:19 UTC
Created attachment 104278 [details]
journal log showing list closed and open events with no suspension
Comment 10 Nicolas Girard 2018-04-25 09:58:48 UTC
Unable to reproduce here on Kubuntu 18.04beta.
powerdevil 5.12.4.

Additional informations

  lsb_release -rd

    Description:    Ubuntu Bionic Beaver (development branch)
    Release:        18.04

  uname -a

    Linux 4.15.0-19-generic #20-Ubuntu SMP Sun Apr 22 00:03:34 UTC 2018
  x86_64 x86_64 x86_64 GNU/Linux

  swapon -s
    Filename                 Type            Size    Used    Priority
    /dev/dm-1                partition       999420  0       -2
Comment 11 Andrew Crouthamel 2018-09-28 03:38:46 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 12 Andrew Crouthamel 2018-10-29 02:20:23 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!