Bug 349669 - Tooltip jumps to top of screen after clicking on quick launch icon
Summary: Tooltip jumps to top of screen after clicking on quick launch icon
Status: RESOLVED FIXED
Alias: None
Product: frameworks-plasma
Classification: Unclassified
Component: components (show other bugs)
Version: 5.1.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-27 19:19 UTC by Mark
Modified: 2016-05-05 21:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
tooltip jump demonstration (1.96 MB, video/x-matroska)
2015-06-27 19:21 UTC, Mark
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark 2015-06-27 19:19:33 UTC
Hi,

A picture tells a thousand words. I wonder how many words a video is then ;) Attaching a video demonstrating the problem.

Reproducible: Always

Steps to Reproduce:
1. <not required, but shows the problem better> set the general animation setting at it's lowest (you can find it System settings -> Display and monitor -> Compositor*) where you just drag the "Animation speed" slider all the way to the right and press apply.
2. Hover your cursor over one of your quick launch items. Don't click yet untill the tooltip appears. You can wait till it's fully visible or just click right when you think it's fine. **
3. Once you click it the tooltip shoots up to the top of the screen.



* = It's difficult to find! When searching for animation speed in system settings it highlights the "Desktop behavior" page.. It's definitely not there! There are only animation speed changes per plugin, not the generic one. Another bug?

** = I have slightly weird behavior with this but. The tooltip "almost always" shoots up, but not always! It seems to _always_ shoot up if you click while it's fading in and nearly always when it's fully visible.

I added this but to plasma-framework since that's where the component is. I looked in the task manager QML settings and couldn't spot a X or Y position placement for the tooltip (i could have overlooked it) which leads me to think that the issue isn't in the side using the tooltip, but in the actual component.
Comment 1 Mark 2015-06-27 19:21:02 UTC
Created attachment 93373 [details]
tooltip jump demonstration
Comment 2 Mark 2015-11-06 22:16:29 UTC
Any update on this please? I'm annoyed by the junp and like to fix it, but don't really know where a good starting point might be for this. Any pointers would be helpful.
Comment 3 Marco Martin 2015-11-19 16:01:41 UTC
sadly can't reproduce.
does this happens only with quicklaunch? or other icons as well? does is always happen or sometimes?
Comment 4 Mark 2015-11-19 22:41:22 UTC
(In reply to Marco Martin from comment #3)
> sadly can't reproduce.
> does this happens only with quicklaunch? or other icons as well? does is
> always happen or sometimes?

Hi Marco,

It happens with all tooltips that are in the same style as the one of quicklaunch. so for instance also the tooltip for kickoff.

This happens _always_ for me till this very day. I'm using the nvidia binary driver on a gtx 670 card (in case that matters).

Also be very sure to put your animations at the slowest possible speed. It occurs every time and only for a very small fraction of time (1 frame perhaps) so you will have a hard time noticing it if you're not bothered by it on the regular animation speed.
Comment 5 Mark 2015-11-24 14:10:54 UTC
Hmm, i think i need to correct myself on my last comment. It might be a bit misleading.

Right now i can reproduce this every single time for the task manager tooltips for applications that have been "Show a launcher when not running" checked. For those apps that are not running yet you have a single icon. If you hover _that_ icon you get the tooltip. Then Click _while_ the tooltip is still visible. And voila, the tooltip jumps to the top of the screen.

But that is a description of the video i added.. Just watch the video. If it still isn't clear, then read the above description with it and it should be crystal clear.
Comment 6 Marco Martin 2016-02-17 10:12:48 UTC
hopefully shortly when the tooltips will be moved by a kwin effect rather than x window anymating themselves should solve/alleviate this too
Comment 7 Marco Martin 2016-05-04 12:07:34 UTC
is still happening on Plasma 5.6?
Comment 8 Mark 2016-05-05 21:09:53 UTC
(In reply to Marco Martin from comment #7)
> is still happening on Plasma 5.6?

It seems to be working fine now. Thank you for taking care and closing this issue.