Bug 349407 - Amarok hangs (unresponsive) when started with an audio CD inserted
Summary: Amarok hangs (unresponsive) when started with an audio CD inserted
Status: RESOLVED DUPLICATE of bug 339190
Alias: None
Product: amarok
Classification: Unclassified
Component: Collections/CD (show other bugs)
Version: 2.8.0
Platform: Fedora RPMs Linux
: NOR major (vote)
Target Milestone: 2.9
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-20 10:24 UTC by Syam
Modified: 2015-06-21 13:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Syam 2015-06-20 10:24:17 UTC
When an audio CD is in the drive and Amarok is started, it hangs (the window becomes unresponsive). The CPU utilisation increases (to steady 70-100%). Closing Amarok from systray icon menu does not work. Only way is to send KILL signal (not TERM) from ksysguard.

If I eject the disk midway, then it does come out. After a few seconds, Amarok shows "Examining: Finished" pop-up messages. But it remains unresponsive and CPU utilisation also remains high as earlier.

The behaviour is similar if I start Amarok and then insert the audio CD.


Reproducible: Always

Steps to Reproduce:
1. Insert and audio CD
2. Start Amarok
OR
1. Start Amarok
2. Insert and audio CD
Comment 1 Myriam Schweingruber 2015-06-21 13:37:06 UTC
There is a known problem in the CD stack.

*** This bug has been marked as a duplicate of bug 339190 ***