Bug 348746 - Background color in fullscreen mode should be pure black or else somehow user-customizable
Summary: Background color in fullscreen mode should be pure black or else somehow user...
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 4.13.2
Platform: Debian unstable Linux
: HI normal with 20 votes (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: usability
: 360590 387801 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-05 14:21 UTC by Josef Kufner
Modified: 2021-01-15 20:38 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 21.04


Attachments
Image to laod in Gwenview. (9.23 KB, image/png)
2017-12-11 20:22 UTC, Thomas Meiner
Details
Screenshot of Gewnview, mith loaded image red_text.png (369.97 KB, image/png)
2017-12-11 20:23 UTC, Thomas Meiner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Josef Kufner 2015-06-05 14:21:57 UTC
Currently the background in fullscreen mode is dark grey with decent texture. It looks fine when browsing thumbnails, but it is disturbing when looking at dark photo, so I would like to make the background 100% black.

I would prefer separate option for image view and for browsing, but it is not neccessary.

Reproducible: Always
Comment 1 Standa 2015-11-10 15:41:36 UTC
I confirm this, background colour in fullscreen mode cannot be changed. I prefer black background too.
Comment 2 Nate Graham 2017-09-08 20:47:31 UTC
Confirmed. The easiest way to change this would be to make Gwenview use the color set for Tooltip Background in System Settings > Color.
Comment 3 Christoph Feck 2017-09-20 11:52:55 UTC
There is a slider to change the background brightness in the settings dialog. Using the tooltip color whould be distracting for those (incl. me) who have classic yellow as the tooltip color.
Comment 4 Christoph Feck 2017-09-20 11:55:20 UTC
Ah sorry, this ticket is about the slideshow.
Comment 5 Christoph Feck 2017-09-20 12:22:08 UTC
*** Bug 360590 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2017-12-11 19:40:50 UTC
*** Bug 387801 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Meiner 2017-12-11 20:22:10 UTC
Created attachment 109324 [details]
Image to laod in Gwenview.
Comment 8 Thomas Meiner 2017-12-11 20:23:34 UTC
Created attachment 109325 [details]
Screenshot of Gewnview, mith loaded image red_text.png
Comment 9 Thomas Meiner 2017-12-11 20:30:41 UTC
This bug isn't fixed since 2015.

Since a few versions, the image background is black. But the surrounding backgrund still isn't

See the attached images!
I opened the image "red_text.png" in Gwenview 16.12.3 in full screen mode. The second image shows a shreenshot of Gwenview-full screen mode. 
There you can see the grayish background outside of the image. I shuld be as back as the image backgrund itself. 
"red_text.png" contains on back at all. Most of it is transparent.
Comment 10 Huon 2018-03-24 05:53:35 UTC
This is fairly easy to implement, and I think the better option is to leave Browse view with the texture, and only make Image view have a black background.

It's probably generally a bad idea to change it without giving the option to change it back (I'm sure someone would complain). But I also think it's not quite worthy of an option in the Config dialog. A hidden config option perhaps?

I will implement this if we have some sort of consensus on 'how'.
Comment 11 null 2018-03-24 08:44:17 UTC
@Huon: Thanks for looking into this ;)

For Browse mode, I agree that the texture should be kept. However, I tried out a purely black background in View mode, and I don't really like it, in particular it looks odd next to the greyish background of the sidebar and the top bar, as well as when switching between modes.

As far as I can see, there are two problems:
1. Texture comes out as too light on some projectors.
2. Transparent background of raster image does not adapt to texture.

For #2, by pure chance we have https://phabricator.kde.org/D11630. Regarding #1, my preference would be to make the texture colour (or rather just the V in HSV) configurable. Effectively this would also allow to set it to black.

@Thomas:
> Since a few versions, the image background is black.
I guess you set the config option "Transparent background: Solid color" to black.
Comment 12 Thomas Meiner 2018-03-24 08:57:03 UTC
Pleas, stop to act as guardian for users!!
Some need it black others like it greyish. Let them choose the colour!

It's not about design. It's about functionality. 
I often use Gwenview to instant present images. On screen or beamer.
A coloured or greyish backgrund destroys the true colour of the image. Allays. 

Just make all (really all) the backgrounds depending on the existing background setting. If you like it greyish, you can just change this setting...

> @Thomas:
>> Since a few versions, the image background is black.
> I guess you set the config option "Transparent background: Solid color" to black.

Thats exactly what I did. "Background color" and "Transparent background:" is on #000000.
Comment 13 null 2018-03-24 09:06:28 UTC
> Pleas, stop to act as guardian for users!!
If your image's background is set to transparent, that's not something we should touch. If you want it black, GIMP it to black.

> Just make all (really all) the backgrounds depending on the
> existing background setting
That won't work, because in fullscreen mode the background should be darker.

> Thats exactly what I did.
I see. Next time, please specify what options you changed. This makes is easier to triage the bug.

> This bug isn't fixed since 2015.
Just to let you know: We work on this in our free time.
Comment 14 Thomas Meiner 2018-03-24 09:17:26 UTC
(In reply to Henrik Fehlauer from comment #13)
> > Pleas, stop to act as guardian for users!!
> If your image's background is set to transparent, that's not something we
> should touch. If you want it black, GIMP it to black.

Have you seen the images I posted on 2017-12-11? Have you?
> 
> > Just make all (really all) the backgrounds depending on the
> > existing background setting
> That won't work, because in fullscreen mode the background should be darker.

No, it just be the background colour and not lighter or darker...

> 
> > Thats exactly what I did.
> I see. Next time, please specify what options you changed. This makes is
> easier to triage the bug.

I've never asked for different background colours for the image an the surrounding backgrund. But an option that is called "background color" should change the backgrund colour and not exclude the full scree. That's a bug and not a design problem. 

> 
> > This bug isn't fixed since 2015.
> Just to let you know: We work on this in our free time.

In older versions of Gwenview it used to work as expected. Why make it more complicated then needed?
Comment 15 Josef Kufner 2018-03-24 09:27:44 UTC
You are mixing two things together. Windowed mode and fullscreen mode.

In windowed mode the surroundings of the image should use standard window background by default and it makes sense to provide an option to change it. The dark grey texture is quite good for thumbnails, a bit worse for image view, but still ok.

In fullscreen mode, there is no need for any color or texture. Just make it black. The black background, surroundings, and everything will nicely fit with black edges of the screen. When using projector, it will project nothing around the image. There is no use case for any other color than black in fullscreen mode.
Comment 16 null 2018-03-24 09:43:35 UTC
@Thomas: Please compile and run the patch I linked to before adding another comment.

@Josef:
> You are mixing two things together. Windowed mode and fullscreen mode.
No, I'm not. I simply do not subscribe to the view that _every_ user is using a projector, therefore the texture has its use cases also in fullscreen view mode.

> In windowed mode the surroundings of the image should
> use standard window background
No, because that would be a really light grey, blending in with the toolbar colours. Note how Dolphin uses white, but Gwenview consciously uses something darker.

> In fullscreen mode, there is no need for any color or texture.
Fullscreen mode is the _only_ mode where the texture is used. The texture is not used in windowed mode.

> black edges of the screen
My screen does not have purely black edges. I agree for projectors it makes sense, so I'm in favour of the option as I said above. And even if Gwenview displayed pure black, there would still be some light shining through, unless you own a huge OLED wall.

> There is no use case for any other color than black in fullscreen mode.
The use case is that it looks nicer, prevents extreme contrasts and gives a warm feel to Gwenview. Note that in almost all dark colour schemes the background is not set to a pure black, but something ligher, for exactly that reason.

Just open the attached PNG in Firefox: They have nearly the same UI texture in fullscreen (and even in windowed mode). For the background of the PNG, they even use a light grey…
Comment 17 Nate Graham 2018-03-24 14:19:20 UTC
The texture only shows up in full screen *browse* mode. If you're using Gwenview to present images on a projector, Then the only relevant thing is what color the background is in full-screen *view* mode, right?
Comment 18 null 2018-03-24 17:10:41 UTC
Not quite, the texture is used consistently in both fullscreen modes. In both modes none of the UI shows a pure black, so when I tested using only black for fullscreen view mode it look inconsistent and it did not feel "right".
Comment 19 Nate Graham 2018-03-25 21:55:00 UTC
Strange, I compiled from source on my Kubuntu machine and I see pure black in the View mode, but in my Neon VM, I see the texture.

My vote would be to officially adopt the (accidental/unintentional/mysterious?) behavior that I see on my Kubuntu machine and make it pure black in View mode, but not Browse mode. The inconsistency shouldn't actually matter here.
Comment 20 Thomas Meiner 2018-03-27 22:01:18 UTC
(In reply to Josef Kufner from comment #15)
> In fullscreen mode, there is no need for any color or texture. Just make it
> black. The black background, surroundings, and everything will nicely fit
> with black edges of the screen. When using projector, it will project
> nothing around the image. There is no use case for any other color than
> black in fullscreen mode.

Exactly... full screen mode doesn't need any color or texture. 

As I see, in windowed mode the surrounding and backgrund black now. But why excluding the full screen mode? Makes no seance at all. 

I don't care abut browse-mode at all. Maybe use the texture there if you like. For browsing is Dolphin doing a good job.

But in view mode it should act the same in both: windowed and full screen. If you set black in the setting, it should be real black in both of them.
Comment 21 null 2018-03-27 22:10:09 UTC
> full screen mode doesn't need any color or texture.
Sidebar, statusbar and the toolbar on the top can also be visible, so the reason to have the texture is still applicable.

> But why excluding the full screen mode?
That's why I proposed to make it configurable as detailed in Comment 11.

> I don't care abut browse-mode at all.
Well, other users do care about a consistent background between fullscreen Browse and View mode.
Comment 22 Huon 2018-03-27 22:21:14 UTC
Just had an idea - why don't we put a checkbox in the fullscreen settings popup accessed with the cog icon in the autohide bar. Something like "Use black background".

That wouldn't clutter the main settings dialog with a specific setting, and it would only affect Fullscreen View mode, which is what people want.
Comment 23 null 2018-03-27 22:28:53 UTC
> checkbox in the fullscreen settings popup
I guess that could work, but I can also see people getting confused by the wording (because they won't notice the difference to the texture and it's not clear why they'd want to change the setting).
Comment 24 Huon 2018-03-27 23:56:17 UTC
(In reply to Henrik Fehlauer from comment #23)
> > checkbox in the fullscreen settings popup
> I guess that could work, but I can also see people getting confused by the
> wording (because they won't notice the difference to the texture and it's
> not clear why they'd want to change the setting).

If it changed instantly, it would be pretty noticeable. It's easy to see a change if it's happening as you click.
We could word it differently? "Pure black background" suggests the default isn't pure black. Or could even do something like "Projector mode", though that's a bit cryptic for my liking.
Comment 25 Serpico 2019-07-30 09:17:00 UTC
There's an easy fix for this. Just change the color of file located here and problem is solved:
/usr/share/gwenview/images/background.png
Comment 26 Thomas Meiner 2019-07-30 18:26:26 UTC
(In reply to Serpico from comment #25)
> There's an easy fix for this. Just change the color of file located here and
> problem is solved:
> /usr/share/gwenview/images/background.png

It works well! A really working workaround!
Thank you Serpico! 

Since 4 years (!) the first working solution. 

Not really a solution. Just a workaround!

The bug is not fixed, because the next update for Gwenview, will override the edited image again. Pleas, make the Background pending on the "solid color background" in the settings. User shouldn't need to edit images in /usr/....
Comment 27 Bug Janitor Service 2021-01-11 21:52:48 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/gwenview/-/merge_requests/28
Comment 28 Nate Graham 2021-01-15 20:38:31 UTC
Implemented by Antonio Prcela with https://commits.kde.org/gwenview/275e9288c8b587078b3c4ff75633157a44197eba in Gwenview 21.04!