Bug 348695 - The numeric keypad doesn't provide input into the calculator, numeric keys do
Summary: The numeric keypad doesn't provide input into the calculator, numeric keys do
Status: RESOLVED DUPLICATE of bug 344638
Alias: None
Product: kcalc
Classification: Unclassified
Component: general (show other bugs)
Version: 2.13
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Evan Teran
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-04 11:40 UTC by a.wiekens
Modified: 2015-06-05 10:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description a.wiekens 2015-06-04 11:40:35 UTC
While trying to use the kcalc application, none of the keys on the numeric keypad seem to end up in the GUI. The numpad as such works in other applications.

Reproducible: Always

Steps to Reproduce:
1. Start kcalc
2.Type numbers on numpad (with numlock enabled)
3. Type numbers from alphanumeric part of keyboard

Actual Results:  
The GUI doesn't respond on any keystroke on the numpad, but does when typing using the alphanumeric part of the keyboard

Expected Results:  
Respond to the key presses and display the typed input

Other applications do get the information from the numpad.
Comment 1 Burkhard Lück 2015-06-05 03:09:29 UTC
$ kcalc --version
Qt: 4.8.6
KDE: 4.14.2
KCalc: 2.13

Not reproducable for me
Comment 2 Christoph Feck 2015-06-05 10:29:13 UTC

*** This bug has been marked as a duplicate of bug 344638 ***