Bug 348153 - When you choose an output the list is at the wrong place
Summary: When you choose an output the list is at the wrong place
Status: RESOLVED NOT A BUG
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_phonon (show other bugs)
Version: 5.3.0
Platform: Kubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Harald Sitter
URL: http://www.hostingpics.net/viewer.php...
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-23 15:03 UTC by jeremy9856
Modified: 2015-05-23 19:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jeremy9856 2015-05-23 15:03:52 UTC
In Sound and other stuff when you choose an output the list is at the wrong place

http://www.hostingpics.net/viewer.php?id=380582screenshot5.png

Reproducible: Always

Steps to Reproduce:
1. Choose an output

Actual Results:  
The list is at the wrong place

Expected Results:  
The list is at the right place
Comment 1 Harald Sitter 2015-05-23 18:03:03 UTC
That's unreleased software and not the phonon KCM. The bug at any rate is known and in QML Controls (unfortunately I don't have a bug url handy).
Comment 2 jeremy9856 2015-05-23 18:07:03 UTC
Sorry to report at the wrong place. I didn't find an other thing related to "sound and other stuff". That's great that it's a known bug.

What do you mean by "That's unreleased software" ?
Comment 3 Harald Sitter 2015-05-23 18:19:02 UTC
Alpha software -> https://mail.kde.org/pipermail/plasma-devel/2015-April/041025.html
Comment 4 jeremy9856 2015-05-23 19:00:27 UTC
Thank you but the link you post is about the volume applet and if you look at the screen I posted (http://www.hostingpics.net/viewer.php?id=380582screenshot5.png) I talked about the "output selection" in the sound settings.

So I don't know if we talk about the same thing.
Comment 5 Harald Sitter 2015-05-23 19:11:59 UTC
That is the same thing. The applet comes with a configuration module which is called Sound and has a funky description like Sound and other stuff.

The list is broken because the configuration module was created using a technology called QML which still has a number of problems for desktop applications (such as combobox lists being rendered at the wrong position which is what you are seeing).
The configuration module also shouldn't have a white background for example, which is an issue that will be resolved in the upcoming KDE Frameworks release.
Comment 6 jeremy9856 2015-05-23 19:14:01 UTC
Thank you very much for this clarification ;)